Can't turn off airplane mode on Windows 10 desktop PC

I'm having the same problem as many others, and I'm getting pretty frustrated with Windows 10 overall (starting to really miss Windows 7).

I'm using a desktop computer, so obviously I have no use for airplane mode. yet the operating system forces the feature on me, and now I can't turn it off. When I slide it to off, it pops right back over to on.

I've looked at all the solutions thus far (press Fn + F2, Fn + PrintScrn, etc.). Nothing works. If I boot into safe mode with networking, I can indeed access the Internet. However, when I boot normally, no luck; airplane mode is stuck on. I've tried a selective startup and eliminated all the nonessential startup items; still no luck. My computer is now worthless from a business perspective because I can't access the Internet or my home network (no email, no nothing) -- all because of a feature that has no place in a desktop environment in the first place.

Microsoft, I really don't need a stock answer ("Go to settings," etc.). I need a solution. And fast.

 

Question Info


Last updated April 19, 2019 Views 31,637 Applies to:

Hi,

Facing the same problem as you, I have collected several definite recommendations. What finally helped me is changing the Network Adapter Properties.

In Network Adapters section on your Windows 10 enter Properties and go to Power Mangement tab and clear off the option Allow the computer to turn off this device to save power, save the changes and reboot your PC.

If that doesn't work for you, I suggest reading the article "Windows 10: Airplane mode quiz" which offers you 4 more tips to overcome the issue.

68 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Switch on Radio Management Service. Yup, I also had this problem but now it works :)

Never ever set this service to "Disabled"

25 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

None of the above worked, still stuck in airplane mode. any more ideas?

9 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Lee,

Since you've already tried the troubleshooting steps recommended above and the issue is still persistent, we suggest that you do a System Maintenance to isolate the issue.

The System Maintenance Troubleshooter will help you run Windows computer maintenance tasks automatically. This will detect if there are current conflict, integrity violation and fix common concerns too. To do this, please follow the steps listed below:

  1. Type Troubleshooting in the Search bar and press Enter.
  2. Select System and Security and click on System Maintenance.
  3. Click Next and follow the prompt.
  4. Restart your computer and check if it helps to turn off Airplane Mode.

Kindly update us with the result and let us know if you need further help.

8 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.