Cannot access Western Digital NAS with File Browser after upgrading to Windows 10

Just over a month ago I upgraded from Windows 7 Home 64-bit to Windows 10. After the upgrade I found that I was no longer able to access a Western Digital MyBookLive NAS on my home LAN network through the File Browser, or indeed with the file browsers of any of the installed programs. Subsequently, I rolled back to Windows 7 largely due this problem and in part as a result of issues that arose after attempting to recover a disc back-up of the Windows 10 system that I had created after upgrading.

I raised the MyBookLive access problem on the Western Digital Community forum and have been avidly monitoring the responses that have have come back. Here is the thread:

https://community.wd.com/t/windows-10-cannot-access-my-book-live-with-file-browser/141176

Clearly others are experiencing the same or similar issues. Some have suggested various workarounds and hacks, which to my mind should not be necessary, and I certainly to not wish to find myself having to try this and that to see if it works. There needs to be a formal fix for this problem, whether that needs to come from Microsoft or Western Digital. Current opinion from that thread is that the problem lies with Windows. 

As such, I am addressing it here first. Please, no suggested hacks.

Thanks.

Hi,

Thank you for posting your query on Microsoft Community Forums.

I would suggest you to post your query on Microsoft TechNet forum for this issue. There you can get more effective and appropriate suggestions by experts familiar with this topic.

TechNet Support Forum.

Hope the information helps. Let us know if you need further assistance with Windows, we’ll be glad to assist you.

Thank you.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

This is really frustrating. Tried to post the same query on the TechNet Support forum, but in order to include the link to the thread on the Western Digital Community forum (needed to describe the issue in full) I was advised that my account first has to be verified, and that in order to expedite that I needed to post a request on another thread dedicating for that purpose- which I did yesterday:

https://social.microsoft.com/Forums/en-US/910ceecf-e32a-41d3-9b6b-5a9a1ec6c59d/verify-your-account-33?forum=reportabug#b457cf1b-6018-4fdc-a425-10f7ca0aa9bb

But still response, and at the time of writing there are 8 other people after me requesting the same thing.

What a ridiculous state of affairs. How on earth do I get my query responded to ?   

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Log into the MyBook Live Duo Console

Go to "Shares"

On each share, Under "Share Access", select "Public"

This means all network users can access the whole MyBook Live Duo but sadly this is the only way until WD write new Windows 10 compatible software. I believe they have no intention of doing this despite the fact that MyBook Live Duo is still available for sale at retail outlets. At least this way the MyBook Live Duo is still usable for something.

 

On each windows 10 Computer you want to use to access the MyBook Live Duo over the network.

 

Control Panel> Network and Internet> Network and Sharing Centre>

Click "Change advanced sharing settings" (At top left of screen)

 

In "Private (Current profile)":

 

Tick "Use user accounts and passwords to connect to other computers"

(If you use Homegroups then this may cause other issues)

 

Expand "All Networks"

Tick "Turn off password-protected sharing"

 

Apply changes and Restart computer.

 

Then in the start menu: Under "All apps" click on "Windows System". Then right click on "Command Prompt" > More> Run as Administrator.

 

In the command prompt:

Type:

sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi

Press Enter. It should say Success

Then type:

sc.exe config mrxsmb20 start= disabled

Press Enter. It should say Success

 

Restart the computer.

 

You will now have full access to the MyBook Live Duo.

 

Sadly this technique allows your windows computer to connect to other non-password protected computers in your network. This is something Windows 10 was designed not to do normally. If you just have a home network then this may be a reasonable compromise in order to keep using you MyBook device. This lack of support is a reason to not buy WD devices in the future.

14 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated February 6, 2021 Views 6,770 Applies to: