Windows 10 keeps asking for browser confirmation

I have set Firefox as default browser in Windows 10 instead of Edge, but I still get messages asking me to confirm which browser to use.  This is really annoying when I have specified a default already, how do I stop it? Any ideas?  Thanks

Hi,

Thank you for posting the query on Microsoft Community.

The settings might have not synced with the system settings.

I suggest you to try the steps provided below and check if it helps.

Check the settings under Default apps.

1. Go to Start > Settings > System.

2. Choose Default apps, then scroll down and check the Web browser.

3. Click on it and change. 

Hope this helps in resolving the issue. If the issue persists, do get back to us. We will be happy to assist you.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Kalpana, Thanks for the advice.  The browser was already set to Firefox in the system settings, I re-selected it but again when I clicked the hyperlink to this forum on your email I was asked which browser I wanted to use!  Thus I still have the problem.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Ian,

Thank you for the reply.

Sorry for the delayed reply.

I suggest you to try the steps provided below and check if it helps.

  1. Go to Start > Settings > System.

  2. Choose Default apps, then scroll down to Web browser.

  3. Tap or click the browser that’s currently listed as your default, then choose the browser from the list of apps.

 If the issue persists, then try to change it the other way.

  1. Go to Search and enter Default programs, and then tap or click Default Programs (You will see two options, click on one with the green circle with a check mark).
  2. Tap or click Set your default programs.

  3. Select Internet Explorer from the list of programs.

  4. Tap or click Set this program as default, and then tap or click OK.

If the issue persists, then try SFC scan and check.

Scan for damaged system files. Right-click the Start icon and select Command Prompt (Admin). In the Command Prompt window, type sfc /scannow and hit Enter.

Then type dism /online /cleanup-image /restorehealth and hit Enter.

Hope this helps in resolving the issue. If the issue persists, do get back to us. We will be happy to assist you.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

After migrating from Windows 7 Home (Swiss German Version) to Windows 10 I encountered exactly the same issue as described above. I followed the instructions on SFC (no integrity violations found) and dism (100% completed). The issue with Windows 10 always asking for browser confirmation persists. Beside Edge I tried Chrome and Firefox as standard browsers always with the same result. Any ideas on how to proceed?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

I suggest you to try switching the account to a local account and then back to a Microsoft account and see if you continue to face the issue. Follow the steps provided below:

1. Press Windows key + I to open settings.

2. Click Accounts > Your email and accounts

3. Click "sign in with a local account instead" and follow the screen instructions to create the local account.

4. Once you are signed in through a local account, repeat steps 1 and 2 and click "sign in with a Microsoft account instead".

5. Enter your Microsoft account credentials during the setup.

Let us know the result.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

Starting point in my installation was a local account. I therefor switched to a Microsoft account and than back to a local account again based on your instruction. I did this twice. The second time I tried to open a html link in Outlook 2010 under the Microsoft account. In all situations the issue with Windows 10 always asking for browser confirmation persists.

Within the browser (Chrome) the links work fine. e.g. mail in outlook.com with a html link

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

In order to identify if this is a corrupted user account related issue, I suggest you to create a new user account and check if the issue persists.

Set up accounts

Let us know the result.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

I created a new account  and the issue with Windows 10 always asking for browser confirmation persists.

Additional information:

In preparation of this test I wanted to avoid to create an Outlook account under the new user account. I therefore created a Word 2010 document with embedded links. All the links worked fine in the Word document under the old and new user account. I than stored the same document as pdf. With Accrobat Reader DC, Windows 10 was always asking for browser confirmation in both user account. I than created an Outlook 2010 account under the new user account with the result that Windows keeps asking  for browser confirmation.

I do not know if this additional information is helpful or not. To me it seems that Word 2010 is using a different way to open links compared to Outlook 2010 and Accrobat Reader DC (current version).

Thank you for your support!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Microsoft smart people.

By the text in your posts I suggest to replace you with automatic reply to every post with 'run sfc /scannow' and then 'dism /online...'. I can assure you in 95% cases it's just waste of time. No it does not work. It works when system is about to die but then it is still better to run refresh or just download latest version of windows 10 and run install from USB.

As you may see sfc always runs without issues found or if it fix any issues it do not fixing the issue reported. Find some solutions not just postpone fixing them. If there is patch to fix it give us KB if there is no fix yet let us know but do not SFC us.

Krzysztof

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

https://support.microsoft.com/en-us/help/3094186/you-are-prompted-to-specify-internet-explorer-when-you-click-a-link-in

I had the same issue (explorer was default and kept being prompted).

I followed these steps and haven't had a problem since.

7 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated September 22, 2020 Views 5,691 Applies to: