Win10 10586 - FOUND FIX for system error 1231 bug ( network shares broken, missing machines on network, etc )

OK, this was puzzling for a while, after update to build 10586, cannot see anything else in WORKGROUP.

NET VIEW gives error 1231 !!

Discovered that this new Windows build has magically become CASE SENSITIVE to machine names!!

IF you have missing shares or completely disappeared machines on your LAN, make sure their machine names are not mixed-case. If they are mixed case, rename them to ALL CAPS and then reboot.

Problem SOLVED, they will no longer be invisible on your network.

Just posting this for the benefit of anyone else who may have machines that are ping-able, and have good  DNS name resolution, but it seems that NETBIOS resolution is 'somehow' broken, even though it is properly enabled. What I discovered today was that somehow the latest Win10 build has become slightly CASE-SENSITIVE - and this breaks the old NETBIOS standard going back to antiquity.

So rename your "invisible" shares or machine names to UPPER-CASE, and they will magically appear on your WORKGROUP again.

Microsoft, feel free to send me my bug-finder's bounty-hunter check  :-)

 

Discussion Info


Last updated September 23, 2019 Views 34,815 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

GREAT JOB

excellent catch

we need to team up and bill MS

also you may want to look at this post of mine which deals with the same:

http://answers.microsoft.com/en-us/windows/forum/windows_10-networking/windows-10-pro-ver-1511-build-105863-lost-all/fcc6bda3-3ca7-498c-b4c2-834c51dbf99c?tm=1447522564378&auth=1

Thanks.

It is still a bit flaky even with all devices in the same case.  There seems to be an issue with numerals as we in names as well

How do I make this change? I've been having wifi problems since I installed the November Windows Update.
  • Right-click on This PC on Desktop or in File Explorer
  • Click Properties
  • In "Computer Name, Domain and Workgroup" area click "Change Settings"
  • In "To rename this computer...or workgroup, click change" section, Click "Change"
  • Change Computer name on next screen
  • Click OK
  • Reboot PC

This fix does not work for us after November Windows 10 update.  Updated machines disappeared from network and fail to reappear even after renaming as described above.

did you try uninstall adapter

then try

HAD TO UNINSTALL AND INSTALL CLIENT FOR MICROSOFT NETWORKS AND FILE AND PRINT SHARING FOR MICROSOFT NETWORKS

 NETWORK AND SHARING>CHANGE ADAPTER SETTINGS>RIGHT CLICK ADAPTER>CHOOSE PROPERTIES>UNINSTALL CLIENT FOR MICROSOFT NETWORKS

NETWORK AND SHARING>CHANGE ADAPTER SETTINGS>RIGHT CLICK ADAPTER>CHOOSE PROPERTIES>UNINSTALL FILE AND PRINT SHARING FOR MICROSOFT NETWORKS

NETWORK AND SHARING>CHANGE ADAPTER SETTINGS>RIGHT CLICK ADAPTER>CHOOSE PROPERTIES>INTERNET PROTOCOL VERSION 4>INSTALL>CLIENT>INSTALL CLIENT FOR MICROSOFT NETWORKS

NETWORK AND SHARING>CHANGE ADAPTER SETTINGS>RIGHT CLICK ADAPTER>CHOOSE PROPERTIES>INTERNET PROTOCOL VERSION 4>INSTALL>SERVICE>INSTALL FILE AND PRINT SHARING FOR MICROSOFT NETWORKS

SHUTDOWN

you can also try:

RUN>CMD (AS ADMIN)>NET VIEW /ALL

RUN>CMD (AS ADMIN)>NBTSTAT -r

RUN>CMD (AS ADMIN)>NBTSTAT -n

RUN>CMD (AS ADMIN)>NBTSTAT -c

RUN>CMD (AS ADMIN)>NBTSTAT -s

RUN>CMD (AS ADMIN)>NBTSTAT -S

RUN>CMD (AS ADMIN)>NBTSTAT -RR

RUN>CMD (AS ADMIN)>NBTSTAT -R

RUN>CMD (AS ADMIN)>NBTSTAT -A (ip address)

RUN>CMD (AS ADMIN)>net use

RUN>CMD (AS ADMIN)>net use (\\share name)

and:

problem with NAS' (in this case Synology) and SMB 3.11.
This maybe the correct solution.

http://forum.synology.com/enu/viewtopic.php?f=49&t=106924

sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
sc.exe config mrxsmb20 start= disabled

reboot

you may have to do this on all computers, and reset router, shut down all computers and apply fix one at a time

This solution didn't work for me. I still don't see other computers and NAS in my network (as I used to see before this last Win10Pro update).

Try the following. On every computer in the workgroup go to:

Settings->Network & Internet->Ethernet->Change Advanced Sharing Options

and check

Use User Accounts and passwords to connect to other computers

That worked for me.

Of course, read the warning above that checkbox.

Finally found the fix. Works on two machines so far.
Problem was Linux box is not visible.

Solution: On Linux box limit samba to SMB1. Add the following line to smb.conf under

[global]

max protocol = SMB1

Restart samba on Linux.

On Windows 10 run:

sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
sc.exe config mrxsmb20 start= disabled

I made it into a batch file and run as administrator.

restart windows computer and the linux box appears.

As I said it works on two so far will now run it on my other Win 10 machines. The Windows 7 PC's don't have the problem.

Just modifying the registry is not sufficient you must limit the protocol to smb1

Update:

Fixed all 4 Window 10 machines including insider preview one.

Machine names and case seem irrelevant. I use HOME-NET for workgroup.

Cheers,

Hans

Congratulations HansAWiggers!

You did it!

Now I can see other PC, laptop and NAT storage device at my local network.

Microsoft should pay you for that!

Best regards, Joao

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.