Win 10: Properties button of IPv4 and IPv6 settings of a VPN connection without function

Hello,

if you try to change the settings of IPv4 or IPv6 of an VPN connection you're out of luck. The button is without function.

To reproduce:

Open Network and Sharing Center -> Change Adapter Settings -> open Properties of a VPN Connection/Adapter -> switch to Networking Tab -> select IPv4 or IPv6 protocol -> click on the "Properties" button -> nothing happens

This button was working fine on Windows 7, 8 and 8.1

The real problem i want to solve: http://answers.microsoft.com/thread/513bdeea-0d18-462e-9ec3-a41129eec736

 

Question Info


Last updated December 9, 2019 Views 105,174 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

This is a crucial bug. Without access, I am stuck routing my internet traffic through the VPN host network internet connection. Very, very slow. Msft, please fix!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

My work VPN is not set up to allow remote computers logging in to use the server for internet access.

But in Windows 10, it's no longer possible to be both connected by VPN to work and also have any internet access because the built-in MS VPN client automatically sets the IPv4 and IPv6 networking properties to only use the "remote default gateway" for all internet access when connected via VPN to a remote server.    And unfortunately, at my office, for security reasons, that is not possible.

When I'm connected to my office via VPN, this means I can't get e-mails, can't send e-mails, can't do anything else that requires internet access at all.   I can browse remote file shares and upload and download files, but nothing else.

This was a problem with every version of Windows since XP.  But it was easily solved in XP, Vista, 7, 8, and 8.1 by  allowing the end user to change the network protocol settings for IPv4 and IPv6, to uncheck the "default gateway" for internet access. 

It's a simple "tick" of a check box, either on or off.   In Win 10, you can see the VPN Adapter's network protocols, but you cannot access "Properties".   The button is there but it does nothing.

This has been a known issue since at least this past May when it first occurred with one of the earlier Preview Builds, and MS has been aware of it since that time, but has done ZERO to fix it.  If they have, I haven't been able to find any fix.  

Frankly, I cannot believe that we are still waiting.  Launch day +2 and no fix in sight.

Based on this flaw, I cannot and will not be using Windows 10, nor can I recommend it to anyone who needs to access a remote work server using the built in VPN client.

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Found a workaround!!!!

This actually works.   I am typing this as I am connected to my office via VPN.   Found it on a TechNet Forum posting from just yesterday.  

Here's the problem and the solution from that post:

And another issue I'm facing is that open Network & Sharing Center --> Change Adapter Settings --> MyVPNConnection --> Properties --> Networking --> IPv4 or IPv6 clicking the properties button, just does nothing, nor error no info (and the button is not grayed out). As workaround to enable/disable "Use default gateway" I use the following PowerShell command:

  1. Get-VpnConnection
  2. Set-VpnConnection -Name "myVPN" -SplitTunneling $True

Edit: This also happens on a second computer with Windows 10 RTM Enterprise Edition"

If you've never used Power Shell, it's pretty easy.  In Win10,  go to "Start"  then find the folder for "Windows Power Shell" click the > to open the folder in the menu, and select the program "Windows Power Shell" by right-clicking on it and selecting "run as administrator."

The Power Shell window will then pop up. If you don't see it, it may be hidden by whatever else you have on your screen.  But it will be there.

At the command line,  just enter the first command,  

"Get-VpnConnection"

This will return a detailed listing of the settings for your Microsoft built-in VPN client adapter that you've already set up to connect remotely to a server, i.e., it will show all the settings for each VPN.  

Next, perform the second command

Set-VpnConnection -Name "myVPN" -SplitTunneling $True

Be sure to insert the actual name of your own VPN (whatever you named it and what is shown next to "Name" after you perform the first command and get the settings returned) in the space for "myVPN", but be sure to place the command  "-Name" before it.  

Once you've typed in both commands, hit Enter.

The commands are case-sensitive, so be mindful of that. 

I ran this, tried connecting to my office VPN, and I now have internet connection using my own computer's (and not the server's) default gateway.   So it works!!!

I do not know if the settings will hold through a reboot.  I will try that next.   But hopefully this is more than a temporary fix, and once you run it the settings will stick so you don't have to do it all over again each time you reboot the machine (which would be a major PITA given that Windows 10 is constantly rebooting to deal with all of the constant updating).

I will report back again after a reboot.

44 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I also found a workaround within the windows insider forums:

http://answers.microsoft.com/en-us/insider/forum/insider_wintp-insider_web/network-connection-vpn-ipv4-properties-not-working/a60edf99-4b06-4219-bb75-b7c08de4ff9e

  1. Open this file with an editor (e.g. notepad): C:\Users\[YOURUSER]\AppData\Roaming\Microsoft\Network\Connections\Pbk\rasphone.pbk
  2. Search for this line: "IpPrioritizeRemote"
  3. Set = from "1" to "0"

I think the author in the link recommends copying the original .pbk before editing, just to be safe.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Got anyone of you working DNS resolution of remote server names?

Ref: http://answers.microsoft.com/thread/513bdeea-0d18-462e-9ec3-a41129eec736

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

It was real helpful. Now I can connect VPN and have my local internet.

I just do not know what happens after doing these setting. Is it harmless?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

rasphone.pbk is empty......

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

tmc45's suggested work around appears to be for Windows 10 PHONE, not for Windows 10 VPN for PC's.

The suggestion I gave works for Windows 10 versions for PC's.   And it just works.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

If your VPN connection is not listed, you should use:

Get-VpnConnection -AllUserConnection

If your VPN is in this list, you should use:

Set-VpnConnection -Name "My VPN" -AllUserConnection -SplitTunneling $True

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Tried this on a brand new Surface Pro 3 (Windows 10 already installed) one of my clients purchased yesterday from the Microsoft Store. Does not work. 

Results:

PS C:\windows\system32> Get-VpnConnection
PS C:\windows\system32> Set-VpnConnection -Name MyVpn -SplitTunneling $True
Set-VpnConnection :  The configuration cannot be applied to the local user VPN connection MyVpn. : The system
could not find the phone book entry for this connection.
At line:1 char:1
+ Set-VpnConnection -Name MyVpn -SplitTunneling $True
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : ObjectNotFound: (MyVpn:root/Microsoft/...S_VpnConnection) [Set-VpnConnection],
   CimException
    + FullyQualifiedErrorId : VPN 623,Set-VpnConnection

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.