Wifi very slow on laptop, but ok on other devices - Windows 10

Hello people,

so HP pavilion 

From windows 8.1 official upgrade to windows 10.

After the upgrade my wifi connection  of the laptop is only 1 mbps. My actual internet connection is 10 mbps.

All other device connect normally, smartphones and tablets.

Any ideas ?

cheers

 

Question Info


Last updated October 18, 2019 Views 23,268 Applies to:

Hi,

Welcome to Microsoft Community. Your interest in Windows 10 is much appreciated. 

Try the below methods and check if the internet connection works fine on laptop:

Method 1:

I would suggest you to run the “Internet Connection and Network Adapter troubleshooter” to diagnose the exact issue.
Follow the steps mentioned below:

  1. Open Control Panel.
  2. Type “Troubleshooting” in the search box and hit enter.
  3. Select “Network and Internet” option.
  4. First select “Internet connections” troubleshooter.
  5. Follow the on-screen instructions.
  6. Then select “Network Adapter” troubleshooter and then follow the on-screen instructions.

Method 2:
If the issue persists, I would suggest you to disable security software temporarily and check.

Note: Once you are done with the troubleshooting, ensure that you have checked the option Turn on security software under settings tab.

 

Refer to the link for additional information.

Wired and wireless network problems
http://windows.microsoft.com/en-IN/windows/network-connection-problem-help#network-problems=windows-8&v1h=win8tab3&v2h=win7tab1&v3h=winvistatab1&v4h=winxptab1

 

Keep us posted if you face any issues on windows in future. We will be glad to help you.

 

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Annu

I've had the same problem as Panayiotis1984. Upgraded to Windows 10 on my Lenovo from windows 8.1 - now the wifi is painfully slow. The wifi still works fine on my other devices (smartphone etc).

I tried the steps that you suggested but they did not bring an improvement.

Any other suggestions?

Michael

8 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The solution for me was to go to Activity Center (Windows Key + A) and turn off "Location".  My Wi-Fi speed is now consistent at the highest speed I am paying for and returns the same result on speed test as my wired connection.

142 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.