Why does "Mobile Hotspot" work, but not the netsh "Hosted Network"?

When I use the netsh command to set and start the "Hosted Network", I can set the settings fine, but starting the hosted network yields "The hosted network couldn't be started. The group or resource is not in the correct state to perform the requested operation.". I have already tried the fix where you enable the "Virtual Adapter" device in device manager, but it did not change anything.

On the flip side, using the "Mobile Hotspot" option inside of the settings starts fine and works correctly.

I am running Windows 10 Pro x64 Anniversary Edition (build 14393) on a Dell Inspiron 7558. The wireless networking card is dual-band 802.11ac.
 

Question Info


Last updated November 16, 2019 Views 4,323 Applies to:

Hi Matthew,

Mobile Hotspot is a feature that has been recently added during the release of Windows 10 Anniversary Update (version 1607), while the Hosted Network started with Windows 7. It became a more popular approach in creating virtual WiFi networks since Windows 8 had the Ad hoc connection was removed from the Network and Sharing Center.

With this in mind, setting up a virtual wifi network using the Hosted Network feature of netsh is now being managed by the Mobile Hotspot feature of Windows 10 version 1607. Hence, you will notice that using the Mobile Hotspot works but setting it up manually using Hosted Network doesn't.

If you really prefer to set up your virtual wifi network manually using Hosted Network instead of the new Mobile Hostpost feature, you may follow the steps below and recreate your virtual hotspot network:

Method 1: Enable Network Sharing.

  1. Press Windows key + R from your keyboard.
  2. Type ncpa.cpl and hit enter.
  3. Click Sharing tab.
  4. Place a check mark under "Allow other network users to connect through this computer's Internet connection".
  5. Click Apply and hit OK.
  6. Restart your computer.

Method 2: Modifying Power Management Setting.

  1. Press Windows key + R from your keyboard.
  2. Type devmgmt.msc and press enter.
  3. Expand Network Adapters, right-click on the wireless adapter and then select Properties.
  4. Choose Power Management tab.
  5. Place a check mark under "Allow the computer to turn off this device to save power".
  6. Click OK.
  7. Restart your computer.

Let us know how it goes.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Matthew,

Mobile Hotspot is a feature that has been recently added during the release of Windows 10 Anniversary Update (version 1607), while the Hosted Network started with Windows 7. It became a more popular approach in creating virtual WiFi networks since Windows 8 had the Ad hoc connection was removed from the Network and Sharing Center.

With this in mind, setting up a virtual wifi network using the Hosted Network feature of netsh is now being managed by the Mobile Hotspot feature of Windows 10 version 1607. Hence, you will notice that using the Mobile Hotspot works but setting it up manually using Hosted Network doesn't.

If you really prefer to set up your virtual wifi network manually using Hosted Network instead of the new Mobile Hostpost feature, you may follow the steps below and recreate your virtual hotspot network:

Method 1: Enable Network Sharing.

  1. Press Windows key + R from your keyboard.
  2. Type ncpa.cpl and hit enter.
  3. Click Sharing tab.
  4. Place a check mark under "Allow other network users to connect through this computer's Internet connection".
  5. Click Apply and hit OK.
  6. Restart your computer.

Method 2: Modifying Power Management Setting.

  1. Press Windows key + R from your keyboard.
  2. Type devmgmt.msc and press enter.
  3. Expand Network Adapters, right-click on the wireless adapter and then select Properties.
  4. Choose Power Management tab.
  5. Place a check mark under "Allow the computer to turn off this device to save power".
  6. Click OK.
  7. Restart your computer.

Let us know how it goes.

Thank you SO much for a fast and relevant response! You don't know how much it makes my day when I can get a good response like that.

I first enabled "Allow other network users to connect through this computer's Internet connection" for my wireless adapter. Then, I "placed a check mark" under (enabled) "Allow the computer to turn off this device to save power" (it was already enabled).

Then, I opened an administrator command prompt, and ran the two following commands:

netsh wlan set hostednetwork mode=allow ssid=Test key=12345678

which yielded:

"The hosted network mode has been set to allow.
The SSID of the hosted network has been successfully changed.
The user key passphrase of the hosted network has been successfully changed."

After, I enabled the hosted network with "netsh wlan start hostednetwork". However, this is what I got:

"The hosted network couldn't be started.

The group or resource is not in the correct state to perform the requested operation."

What now?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thank you for the response.

You may need to restart or refresh your internet connection by following the steps below:

  1. On the Start menu, type Network Connections and hit enter.
  2. Right click on the Wireless adapter and choose Disable.
  3. Wait for a few seconds and enable the Wireless adapter.

You may now enable the Hosted network.

Let us know how it goes.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

That sadly did not work. However, I notice that there is a "Microsoft Wi-Fi Direct Virtual Adapter #2" device. Enabling it did not help either.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

We need additional information. Can you verify if your computer is supporting hosted networks? Here's how to check:

  1. Press Windows key + X on your keyboard.
  2. Choose Command Prompt (Admin).
  3. Type or copy this command and hit enter.
       netsh wlan show drivers

Kindly provide us a screenshot of the result so we can properly identify the issue.

We look forward to your response.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

It does not. However, why does "Mobile Hotspot" still work, even though it states that my NIC can't do hosted networks?

P.S. For clarification, I have attached screenshots of the "Mobile Hotspot" options, and its location inside settings.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Same... i have same problem... how to fix that ?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi rafihaidar,
specify if you are using the mobile hotspot or if you are using Netsh commands to activate the manual hotspot.

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.