Trouble Logging on to Social Security Site

I cannot log onto the Social Security Administration web site.  When I click the "Sign In" tab I get a white page stating "This Page Cannot Be Displayed."  I have run several Internet Connection diagnostics and they have identified problems but can't fix them.  After running a diagnostic I got this message:  "One or more network protocols are missing on this computer."  I've also gotten this one:  "Windows Sockets registry entries required for network connectivity are missing" and "One or more network settings are missing on this computer."  I have no idea how to fix these problems but I am able to log into other secure web sites without any problems.  I just upgraded to Windows 10 from 8.1 a few days ago and everything else is working fine on my computer. Can anyone help me fix these network issues?
|

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

What browser?  Have you tried using a different one?

6 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Thanks for the reply Jim, I've tried Explorer, Edge and Chrome, same problem with them all.

8 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Jim,  I finally had to pay $100 and have a Microsoft technician work the problem and he was at it for over four hours.  The bottom line is there is a proxy issue somewhere with my system that blocks the Social Security Login page.  The technician came up with a work around , it was a software program the technician loaded onto my computer.  I can now log on to Social Security with this software package running but it interferes with other programs.  So, I keep the program turned off unless I need to log on to Social Security.  I guess this is the only or best fix for now.  It's a strange problem and I wonder if I'm the only one who has it??

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

My wife and I were just forced to update to windows 10. We always wait as long as we can to update to a new Microsoft version as we don't like to be the beta tester for new releases. After updating our two laptops , a dell and a Microsoft surface book, both computers now cant log onto www.socialsecurity.gov . I hope Microsoft or someone can tell us how we can fix this problem?

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

What browser? Have you tried a different one? What happens when you try to access the site?

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I'm using internet explorer, Bing and I also tried Google. As soon we try to access www.ssa.gov we get the round circle in the upper left corner next to the address and after 30 seconds or so  on the screen it says " we cant find this page" It does the same thing on any browser, with any hashtag like / login... ect.   on both my dell and my wife's Microsoft surface book. We can still access social security on her I pad and it comes up instantly just like my dell did before the upgrade to windows 10. My wife always used our dell to access social security because her password was saved and she didn't have to look it up to use her surface . I bought her  surface book this past Christmas so when the dell wouldn't work she tried the surface to access the site for the first time and had the same results as the updated dell? For some reason the social security sight doesn't seem to like windows 10 on our windows 10 machines even though one is made by Microsoft?

3 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I'm able to reach SSA.gov using Windows 10 and three different browsers (Edge, IE11 and Firefox 45.0), so it's not a Windows 10 issue per se.  I suggest that you contact your ISP to see if they might be able to shed any light on the issue.

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I have the same problem. Running Windows 8. From several different browsers. Cannot login to SSA.gov. It has to be some setting, but I cannot find it. There has to be a way to fix this besides running a program as Jeff mentioned. Someone brought a laptop into my home last weekend and I could login (to SSA) on it with no problem. So it is not my ISP, I don't think. Does anyone know of any browser settings or any other settings that might fix this?

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I was able to solve my problem with the help of my IT contact. My dell computer could not log onto the SSA site after updating from windows 8.1 to windows 10. As a coincidence I had just bought my wife a Microsoft Surface Book that came with windows 10 so I tried to log in on that unit and it couldn't get in either. We could log in using my wife's Ipad Air. After working on the problem on my Dell for an hour or so nothing worked. We decided the only commonality to the problem was the Wi Fi network. We removed the Wi Fi hub from the dell. I rebooted the Wi Fi by unplugging it and then plugging it back in. WE then searched for the Wi Fi hub and re-logged back on to it and the problem was gone. Widows must have reconfigured the connection as a new login. Did the same thing with the Surface and now both computers work fine? We don't know why it worked but who cares because it fixe the problem. I hope this might work for you?

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Thanks so much.  I just spent 4 hours fighting this issue and just now found your solution.  I am hard wired into my Internet connection so I am a little different.  I will shut down my Verizon wireless service and see if a reboot will solve the problem. 

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated June 10, 2021 Views 6,491 Applies to: