Internet Connection Sharing in Windows 10

How am i can share my internet to another computer or laptop

i had connected from wifi first device 

second device how am i share internet

***Subject edited for clarity by the moderator.***

 

Question Info


Last updated August 17, 2019 Views 329,433 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi Deven,

 

To enable Internet Connection Sharing in Windows 10, please follow the steps below:

 

  1. Press Windows key + X to open the Power User menu and select Network Connections.
  2. Right-click the network adapter with an Internet connection (Ethernet or wireless network adapter), then select Properties.
  3. Click Sharing.
  4. Put a check mark on Allow other network users to connect through this computer’s Internet connection.
  5. From the Home networking connection drop-down menu, select the Microsoft Hosted Virtual Adapter.
  6. Click OK to finish.

 

Let us know how it goes.

164 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

  1. Put a check mark on Allow other network users to connect through this computer’s Internet connection.
  2. From the Home networking connection drop-down menu, select the Microsoft Hosted Virtual Adapter.
  3. Click OK to finish.

I got to step 4, then couldn't find anything like "Home Networking" in step 5.  See step 1 and 2 above  I am running Win10 Pro. The crazy thing is, it was working for a while without doing this or enabling the ICS Service.

As I remember, you had to assign the second adapter a static IP address?  (Win95 & XP)

Any help would be appreciated.

33 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Kenosha,

For more details about enabling Internet Connection Sharing on Windows 10, we recommend checking out this page. It contains threads about the same issue, including solutions from other Windows experts.

Let us know if you have additional questions.

9 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Kenosha,

For more details about enabling Internet Connection Sharing on Windows 10, we recommend checking out this page. It contains threads about the same issue, including solutions from other Windows experts.

Let us know if you have additional questions.

This page does not lead to anything useful for Windows 10. Why can't Microsoft just provide clear, logical steps to perform simple setup tasks?

91 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Deven,

To enable Internet Connection Sharing in Windows 10, please follow the steps below:

  1. Press Windows key + X to open the Power User menu and select Network Connections.
  2. Right-click the network adapter with an Internet connection (Ethernet or wireless network adapter), then select Properties.
  3. Click Sharing.
  4. Put a check mark on Allow other network users to connect through this computer’s Internet connection.
  5. From the Home networking connection drop-down menu, select the Microsoft Hosted Virtual Adapter.
  6. Click OK to finish.

Let us kno how it goes.

      this X where i get

7 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Ain't no "Sharing" under Properties. Holy crap. Why would an UPGRADE to Win10 mean a DOWNGRADE in functionality?

74 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Just came up on this thread to connect a another PC to a laptop and share the internet via ethernet port the Wifi and Ethernet networks must be bridged.

Internet sharing will not work if you are connected to wifi because the hotspot needs the antenna and you can’t use it at the same time.

From the network connection page right-click Ethernet adapter while holding CTRL key and then right-click WiFi adapter.

Once they are both highlighted left-click on an adapter and select Bridge Connection.

Now you can use your device internet.

Note: Laptop wifi antenna is located on the display so leave it open for higher network speed.

53 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Deven,

To enable Internet Connection Sharing in Windows 10, please follow the steps below:

  1. Press Windows key + X to open the Power User menu and select Network Connections.
  2. Right-click the network adapter with an Internet connection (Ethernet or wireless network adapter), then select Properties.
  3. Click Sharing.
  4. Put a check mark on Allow other network users to connect through this computer’s Internet connection.
  5. From the Home networking connection drop-down menu, select the Microsoft Hosted Virtual Adapter.
  6. Click OK to finish.

Let us kno how it goes.

      this X where i get

Also, connect a router or switch to the network interface card in your computer.  Otherwise, internet connection sharing will not resume, following a reboot of your computer.  Finally, my internet sharing works, after rebooting the computer which is sharing internet.  When you are asked, select to have your network interface card connected network be private.  

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Just came up on this thread to connect a another PC to a laptop and share the internet via ethernet port the Wifi and Ethernet networks must be bridged.

Internet sharing will not work if you are connected to wifi because the hotspot needs the antenna and you can’t use it at the same time.

From the network connection page right-click Ethernet adapter while holding CTRL key and then right-click WiFi adapter.

Once they are both highlighted left-click on an adapter and select Bridge Connection.

Now you can use your device internet.

Note: Laptop wifi antenna is located on the display so leave it open for higher network speed.

Thanks a bunch, JG(?) both those solutions are going to be useful.  (FYI, I have an older but still kickin' HP laptop.  lid closed of course!  It would be in the way of the external monitor. . .

Anyhoo, , much appreciated, especially since i worked for nearly 20 years an IT tech, Help desk then Server engineering  I was an MCSE on Windows 2000 in early 2001.  I got a congratulatory note in the mail signed Bill Gates .So I knew how to bridge devices, but didn't think of that.

Muchas gracias, again, and you can share this reply with anyone.

Frank,  aka kkicker

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

4. Put a check mark on Allow other network users to connect through this computer’s Internet connection.

5. From the Home networking connection drop-down menu, select the Microsoft Hosted Virtual Adapter.

6. Click OK to finish.

I got to step 4, then couldn't find anything like "Home Networking" in step 5.  See step 1 and 2 above  I am running Win10 Pro. 

I had this too, eventually found I had to enable it via the command prompt. If anyone has this issue, first uncheck the sharing you enabled in the first three steps and restart your pc (otherwise this option still won't appear).

- Run a command prompt with admin privileges (if unfamiliar with this just search for CMD on the desktop toolbar search, then right click the "Command Prompt" app it finds and run as admin)

- Type: NETSH WLAN set hostednetwork mode=allow ssid=Your_SSID key=Your_Passphrase

- (In the above replace 'Your SSID' with desired network name and 'Your Passphrase' with a security code of at least 8 letters/digits)

- Type: NETSH WLAN start hostednetwork

- Now do steps 1 to 4 as described in the OP above.

- You should now have options in the home networking drop-down menu

- For step 5, it might not be called 'Microsoft Hosted Virtual Adapter', mine was called 'Local Area Connection 3', but it was identified as an MS virtual adapter in its properties. I also had an entry just called 'wifi' - don't use this one, didn't work for me.

- If you want to disable this virtual adapter in the future use the following commands:

NETSH WLAN stop hostednetwork

NETSH WLAN set hostednetwork mode= disallow

It's actually pretty quick and easy once you've done it once. You may have to reenable if you reboot your pc.

NOTE: I was setting up a pc which had an Ethernet internet access connection, then using its wifi for the new shared connection. Not all wifi cards are suitable for the above, apparently.

34 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.