Windows Sound

After upgrading to Windows 10 my built in speakers do not turn off after plugging in my headphones. If I have speakers as default the headphones do not work and vice versa. When I go into device manager the following comes up under speaker under events, Device SWD\MMDEVAPI\{0.0.0.00000000}.{ea41a943-2c25-4dc5-b4cc-b682585e7f63} could not be migrated. Under Headphones under events I get the following, Device SWD\MMDEVAPI\{0.0.0.00000000}.{85a28444-4217-4a0e-b48b-1a23bc23c4b6} could not be migrated. Is that drivers that could not be migrated. I tried removing the sound card, speaker and headphones and rebooting but no help. It tried going to ASUS for a driver but could not find one for Windows 10. Any ideas?
|

Hi Richard,

If you find drivers for a previous version of Windows on the manufacturer's website, then download them and install using the compatibility mode. Use the below steps :

  1. Right click on the setup file of the driver and select Properties
  2. Select Compatibility Tab
  3. Place a check mark next to Run this program in Compatibility mode and select the operating system accordingly from the drop down list
  4. Let the driver to install and then check the functionality.

Vinod Archak
Forum Moderator

5 people found this reply helpful

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I solve the same problem.
Try to update driver for VIA sound controller.
Select:
1) Browse my computer for drivers
2) Pick from insalled drivers "High Definition Audio Device".

Try to install drivers from http://support.asus.com/Download.aspx?SLanguage=en&m=Audio&os=36

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I solve the same problem.
Try to update driver for VIA sound controller.
Select:
1) Browse my computer for drivers
2) Pick from insalled drivers "High Definition Audio Device".

Try to install drivers from http://support.asus.com/Download.aspx?SLanguage=en&m=Audio&os=36

Thank you. I tried it and it worked great.

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi Richard,

If you find drivers for a previous version of Windows on the manufacturer's website, then download them and install using the compatibility mode. Use the below steps :

  1. Right click on the setup file of the driver and select Properties
  2. Select Compatibility Tab
  3. Place a check mark next to Run this program in Compatibility mode and select the operating system accordingly from the drop down list
  4. Let the driver to install and then check the functionality.

Thanks for reply. I tried the other solution and it worked great.

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated May 26, 2021 Views 6,834 Applies to: