Windows 10 not seeing some external drives

After upgrading to Windows 10 Pro, windows sees my two Seagate Expansion external USB 3.0 Drives.  Windows does not see my two Seagate Backup Plus external USB 3.0 drives until I unplug then plug either the USB cable or power cable.  Everything worked fine in Window 7 Pro. The four are plugged into a 4 port PCI USB 3.0 Card. At a loss as to why now not being seen.
 
Question Info

Last updated June 7, 2018 Views 707 Applies to:

Hi Larry,

 

I suggest you to run the Hardware and Devices troubleshooter and check if it helps.

 

a) Press Windows and X key together and select Control Panel.

b) Click on Troubleshooting.

c) Click on View all option on the left side of the Windows.

d) Click on Hardware and Devices option.

e) Click on Next and follow the onscreen instructions to troubleshoot the issue.

 

You may also try installing the latest chipset drivers from the manufacturer's website and check.

 

Please update us with the status. We will be glad to assist you.

K.Z. Sharief Khan
Ex-Microsoft Forum Moderator

Did this solve your problem?

Sorry this didn't help.

I am using a VANTEC Quad Chip 4-Port Dedicated 5Gbps USB 3.0 PCIe Host Card Model UGT-PCE430-4C    in my computer. I have the 4 external Seagate drives plugged into it. Under windows 7, it had no issues of seeing all 4 drives when I booted up.  After the upgrade to windows 10, on bootup, windows does not see the Seagate Backup Plus drives until I unplug them and replug them either power or USB cable. 

I did as you suggested and the only thing it saw was I had disabled automatically install new drivers.  I changed that.

Still on reboot, windows does not see the Backup Plus drives .

EDIT:

OK I did a Repair on the drivers for the USB card, did a reboot, and now the drives show up.  I will do some additional Reboots later to see if the issue is resolved.

Did this solve your problem?

Sorry this didn't help.