Windows 10 - Jerky Mouse Movement

I recently upgraded from Windows 8.1 to Windows 10 on my Lenovo Twist laptop. Since upgrading to Windows 10, my Logitech M305 mouse movement has become erratic and jerky. The mouse point randomly freezes as I move it around the screen. It is not the mouse, I have tried it on several other computers, including another computer running Windows 10 with no issue. I have tried other mice on my Lenovo Twist laptop, including a wired mouse, and have the same issue with jerky erratic movement. I am having the same issue with erratic jerky movement using the touchpad or keyboard TrackPoint. I have installed all the Windows 10 updates. I have installed the latest Windows 10 drivers for the mouse, graphics, touchpad, etc. I have updated the BIOS to the latest version. The mouse is ok through the boot cycle, but once everything is loaded it starts the erratic jerky movement. All is fine when I boot in safe mode. Obviously it appears to be a conflict, but I can't figure out what the conflict is from. Anyone experienced this? Anyone have any ideas on fixing it? I am frustrated.
 

Question Info


Last updated August 21, 2019 Views 68,279 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi Arlen,
 
Welcome to Microsoft Community.
I appreciate your interest in windows 10 and also for trying troubleshooting steps to fix issue. I understand the inconvenience you faced. I will certainly help you with this.
 
This issue could have occurred due to third party software.
 
I would suggest you to perform Clean Boot and check.
 
Clean Boot.
Booting the computer in a clean boot state can reduce software conflicts and help identify the root cause of the issue. You can refer to this article for more information:
http://support.microsoft.com/kb/929135
 
Disclaimer:
After troubleshooting, reset the computer to start as usual. Refer to the step How to set the computer to start as usual after clean boot troubleshooting under more information.
 
I hope this helps.
 
Let us know the status of the issue so that I can assist you better.
 
Thanks.

11 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi, 
I have the same problem. 
The mouse (Trackpoint) feels like I'm fighting it (it's never done that) as well as the lag. 
I tried the solution that you recommended but I don't think it will solve the problem. The problem began after the last windows update on Monday night (Auguest 31, 2015) and it also happened 2 updates ago, as well. But the update between the two didn't cause mouse lag. It has something to do with the update and how it's allocating ram for different utilities. I'm also getting problems with YouTube (in Chrome). When I'm watching any Video they tend to freeze and sometimes when i'm typing in the addressbar (in Chrome) it is unresponsive. When I minimize and maximize the screen it then becomes responsive or it becomes completely unresponsive (program crashes). Also it tend to lag when I start typing faster than 60 wpm. 
It's a Windows 10 Update issue relating to Ram allocation as far as I can tell. I was going to rollback to the previous update but I disabled that feature. 
I have a feeling it will be fixed in the net update. 
if it gets fixed disable updates if it doesn't leave updates on until it gets fixed, then disable updates. 

14 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

My solution was to move the little Logitech USB receiving dongle for my "jumpy" mouse / keyboard (M310 / K520) to a different USB port on the back of my machine.

118 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

You have got to be kidding. I've read the instructions for "clean boot" and it's basically leaving me to do a detailed diagnosis of every possible interaction for dozens (hundreds?) of system software components.  I have no idea where most of these components came from, their names are generally meaningless and there's no way to tie them back to installed software.  99% of the software on my computer was there when I bought it and I have no way of knowing what is required by Lenovo to properly run, what is related to virus scanning, etc.  To say that this is a "solution" to a jerky mouse issue is ridiculous!

Microsoft needs to support, not just pass the buck.

312 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Since Microsoft is leaving us to fend for ourselves, I'll add one note that might help someone discover what is going on - I've noticed that when Task Manager is running AND is the foreground window, the mouse suddenly becomes smooth, with no jerkiness.  If another window comes to the foreground, then the jerkiness returns.  So there is something about Task Manager taking control that eliminates whatever background service is running that causes the jerkiness.

22 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have noticed the same thing. When I am in Task manager or control panel, the mouse movement is fine. When I bring another screen to the forefront, the erratic movement returns. Still haven't found a solution. Is this a memory allocation for graphic driver issue?

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am experiencing the same problem and also believe it to be related to Task Manager. 

I have one thing to add in that I use dual monitors with my Lenovo Yoga 3.  The display/screen for the laptop does not have the jumpy mouse issue, only the 2nd monitor. 

I upgraded to Windows 10 about 10 days ago, but the problem appeared today when  I opened control panel and task manager.

I hope someone figures this out as it is killing my productivity.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This stuff happened with me as well.  What I did was to uninstall all windows updates after kb3081452. And the lag went away.  Everything It would install  an update it will become Jerky  and the moment II uninstalled it became fine. It is crude but it gets me by.  But please enlighten and share if there is a fix for this

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'm sorry, but you have a bug with your Operating System. My mouse was fine until the Fall upgrade. Now the mouse pointer "jumps" or lags. It is an ELAN Touchpad running the latest Windows 10 x64 drivers. Nothing I've tried works and I've tried your solution, reinstalling drivers, using just the ps2 driver, etc - to no avail. Also, interestingly - the problem clears up when task manager is in the foreground. I know my mouse has no problems because it works fine on the other OS on my computer - and it worked great until this last major update.

9 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

No issue at all while back upgrading from Windows 8.1 to 10 with all software installed intact.  But after upgrading again to ver. 1511, the mouse became jittery, and lag occurred with keyboard.  This applies to the Lenovo Helix for the on board keyboard, trackpoint, and all the various mouse and keyboards attached via a USB dock or its USB ports.

After another hour of upgrading the same OS, and after read up online for endless unless feedbacks and troubleshooting for days with uninstall and reinstalls, finally pop into my mind that sound card drivers could be the culprit.

On my Helix, the Realtek High Definition Audio driver dated 6/16/2015 version 6.0.1.7535 is installed along with an Intel(R) Display Audio.  In the start up, following are loaded:

"C:\Program Files\Realtek\Audio\HDA\RAVBg64.exe" /FORPCEE4
"C:\Program Files\Realtek\Audio\HDA\RAVBg64.exe" /LENOVO_MICPKEY
C:\Program Files\Realtek\Audio\HDA\RAVCpl64.exe -s

By disable these 3 start ups in the Task Manager then reboot, the mouse and keyboard runs smoothly with no jitters.  No need to disable the sound drivers in Device Manager. There are no adverse affect on sound output in music or video playback.

Hope this information helps someone else.

18 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.