Unknown Device

 I have an unknown device with the code 28. The hardware id for the device is:

ACPI\VEN_INT&DEV_3510
ACPI\INT3510
*INT3510

It will not update the drivers for some reason, and I cannot find any drivers for this device anywhere... If you know of a place to check, please let me know. Also if you require anymore information, please feel free to ask me.

 

Question Info


Last updated February 25, 2020 Views 20,022 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Installing the Intel Turbo Boost Max driver cleared this "unknown device" error.  The TBM download is here:


https://downloadcenter.intel.com/download/25994/Intel-Turbo-Boost-Max-Technology-3-0

32 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Installing the Intel Turbo Boost Max driver cleared this "unknown device" error.  The TBM download is here:


https://downloadcenter.intel.com/download/25994/Intel-Turbo-Boost-Max-Technology-3-0

Thank you that did it for me. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thank you, worked for me on my Asus Rampage V Edition 10 and 6800K.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thank You. It solved my situation also!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

That fixed it for me as well: Asus X99 Deluxe II - 6900K

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Installing the Intel Turbo Boost Max driver cleared this "unknown device" error.  The TBM download is here:


https://downloadcenter.intel.com/download/25994/Intel-Turbo-Boost-Max-Technology-3-0

I was building our corporate image and had an Unknown Device on a Lenovo P510 ThinkStation. Downloading their SCCM driver package didn't provide a solution. After finding this post, and trying it, sure enough, that was the culprit. Lenovo did have the Turbo Boost Max listed on their download site, but not included with the SCCM driver package. Thanks ScholarWarrior for the post!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

6800K - Asus Deluxe X99

Solved for me also.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

True at first i also thought it solved the problem with the unknown device BUT now i see in my even viewer the following:

Device ACPI\INT3510\2&daba3ff&0 requires further installation.

- System
- Provider
[ Name] Microsoft-Windows-Kernel-PnP
[ Guid] {9C205A39-1250-487D-ABD7-E831C6290539}
EventID 430
Version 0
Level 4
Task 0
Opcode 0
Keywords 0x4000000000000000
- TimeCreated
[ SystemTime] 2016-10-22T22:04:11.844439600Z
EventRecordID 660
Correlation
- Execution
[ ProcessID] 4
[ ThreadID] 160
Channel Microsoft-Windows-Kernel-PnP/Configuration
Computer ShadowKing
- Security
[ UserID] S-1-5-18
- EventData
DeviceInstanceId ACPI\INT3510\2&daba3ff&0

So what does this mean?

Regards

Reza

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Did you Check for Updates and install all Windows Updates until no more are offered when you check again? 

If so what drivers are presently missing in the Device Manager?  It explains how to find them including if necessary tracing Hardware ID in Updating a driver. - Microsoft Community .

Is this Asus PC or mobo?  Is there an ACPI driver on the Asus Support Downloads webpage for this model to install?

----------------------------------
I am a volunteer and not Microsoft.

Over 100,000 helped in forums for 10 years. I don't quit for those who are polite and cooperative.

Windows MVP 2010-20

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yes i have installed everything from MS, just checked again, Winver-->14393.321

I build the PC myself, my motherboard is Asus X99 Deluxe II.

I installed all the chipset and drivers as well from Asus webpage.

Actually i made a support ticket with Asus and they told me :

--------------

hi

Thanks for the information, please uninstall the intel driver as it wont work on this board. Then try these 2

first possibility

http://dlcdnet.asus.com/pub/

then if that fails to install please try this one

http://dlcdnet.asus.com/pub/

---------------

But sadly these are not correct. The unknown drive remains if i installa the Asus recommended driver/program so i think they just hoped it would work.

This Turbo boost driver actually makes the Unknows device to go away but again the driver dont seem to work fully since i see

-->Device ACPI\INT3510\2&daba3ff&0 requires further installation.

No ACPI i think on Asus page. Actually most of the drivers are more recent from windows update compared to Asus webpage:

http://www.asus.com/Motherboards/X99-DELUXE-II/HelpDesk_Download/

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.