Touchpad delay after typing in Windows 10 on Lenovo Flex 2-15

(Update: Solution found!)

After updating to Windows 10 I started experiencing touchpad delay for about a second after I press any keyboard key. When I downgraded my drivers it started working prefectly with no delay, but I was unable to use 3 finger gestures introduced with Windows 10 and also there were no 3 finger swipe to go backwards that I was using in Windows 8.1.

I thought that maybe this is caused by palm tracking feature, but when I set it to minimum the problem was still there. Also I tried installing and uninstalling drivers and touchpad from device manager. Also changed "delay after type" in Windows setting to never. None of the above helped. I'm sure that my touchpad detects all the touches and it's not a hardware issue, cause when I open notification tray and make a tap with three fingers I see three dots appear on elan settings icon.

P.S. The strangest thing is that when I start typing in search box then make a pause and start typing again it works without any delay and I can type and use my touchpad at the same time. Cortana is the only program where I could make it work so far.

(Update: 

I've found a solution. Type in search "regedit", then right-press on the HKEY_CURRENT_USER, tap on Find and type "Elantech". Then go to SmartPad and set values of DisableWhenType_DelayTime_Gesture,  DisableWhenType_DelayTime_MoveDisableWhenType_DelayTime_Tap all to 0. Restart your computer and viola  there should be no touchpad delay after typing.

Here's other guy's explanation you may prefer: http://wj32.org/wp/2012/12/19/asus-ux31e-setting-up-the-elantech-touchpad-driver-for-windows-8/

P.S. This worked for my Lenovo Flex 2-15 with Elantech touchpad)

 

Question Info


Last updated April 28, 2019 Views 18,556 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi,

Thank you for posting your query on Microsoft Community.

I would require more information to help you better.

What is the make and model of the computer?

This issue could be due to screen resolution is not set correctly.

To check your screen resolution

Your screen resolution must be at least 1024 x 768 to have multiple windows and apps on your screen at the same time.

  1. Click on Windows button then go to Settings, and then click on system.
  2. Then click on Display and then choose option Advanced display settings
  3. Check for the screen resolution.

Hope this information helps and reply with the necessary information I’ll be glad to assist you further.

Thanks.

Regards,
Yaseer.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The model is Lenovo Flex 2 15. 

Screen resolution is set to 1920 x 1080. My screen shows multiple windows and apps, it's not an issue.

The problem is with touchpad delay. I have to wait for a second after I use my keyboard for the touchpad to function again. I tried different settings and drivers but none helped. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

My model is a laptop Toshiba Satellite L755
Screen Resolution is set to 1366x768

Im dealing with the same problem; After using the laptop's keyboard i have to wait 2 seconds to be able to use the touchpad. I went into the activity center -) all settings -) Devices -) mouse and touchpad and there is somekind of setting under the mouse settings that gives "protection" soo your touchpad doesnt move while you are typing, there is 4 types of "protection"; No delay, slow delay, medium delay and fast delay. I think the default setting is Medium Delay, and even if you switch to fast/slow/no delay its still on Medium Delay.

It cant be changed and playing games on my laptop is impossible due to that delay. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'm having this same issue with my touchpad on my Alienware.  It is driving me crazy!  Really hoping to find a fix ASAP...

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'm having the same exact issue described above on my lenovo flex 2-15 after upgrading to Windows 10. I set my delay to "No Delay" to no avail. This is really infuriating when working in microsoft word and cycling between trying to highligh something and type. Wish I hadn't upgraded to Windows 10 so soon. Hope a fix comes soon.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I've found a solution. Type in search "regedit", then right-press on the HKEY_CURRENT_USER, tap on Find and type "Elantech". Then go to SmartPad and set values of DisableWhenType_DelayTime_Gesture,  DisableWhenType_DelayTime_MoveDisableWhenType_DelayTime_Tap all to 0. Restart your computer and viola  there should be no touchpad delay after typing.

Here's other guy's explanation you may prefer: http://wj32.org/wp/2012/12/19/asus-ux31e-setting-up-the-elantech-touchpad-driver-for-windows-8/

P.S. This worked for my Lenovo Flex 2-15 with Elantech touchpad. Hope this will also help guys with Toshiba and Alienware laptops. ;)

8 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I fixed mine by uninstalling synaptics touchpad driver. Went to control panel and uninstalled it from there. It didnt had any delay after that.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yeah I also tried that but without drivers I couldn't use Windows 10 gestures when you can swipe with three fingers to open Task View, tap with four to open Notification Center etc. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Found the solution for Synaptics touchpads:

1. Open mouse properties.

2. Click Clickpad tab and then click on Values...

3. Click on advanced, then on SmartSense/Palm Check.

4. Set it to the minimum.

5. ???

6. Profit

14 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This fixed the 2 or 3 second delay on my HP Envy dv6 with a synaptics touchpad. Thanks!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.