How to set AMP to use manually selected ports.

I have a VOX AMP that has a USB connection uses a KORG USB midi driver.

The connection has to be made within the old 10-MIDI-port-limitation, otherwise the AMP is not seen by the KORG Tone Room software.

Now strange things (?) happen on my Windows 10 system.

The driver always gets installed to the 11th port (mid10 or higher), though the ports mid1-mid9 are still available and not taken by any other device.

How can that happen?

How can I handle the situation, f.e. manually switch the AMP to use mid1-mid9 for the connection?

Thx in advance for every hint.

Best, Adrian

What is with mid1-mid9?

Why is (always) mid10 used for the VOX?

***Original title: Strange MIDI-port problem (10-port-limitation-related)***

 

Question Info


Last updated September 19, 2019 Views 1,442 Applies to:
Answer
Answer

I had exactly this problem and I had to do some registry wrangling to solve it. Firstly go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class. You see lots of apparently random collections of numbers and letters. There are multiple entries for {4d36e96c-e325-11ce-bfc1-08002be10318}. Find the one that contains a REG_SZ value called "Class" with value "MEDIA":

Expand this key out and you'll see several keys each with 4 digits. All of them will have a Drivers key, some of them a midi key below that. Identity all that do and write down the value of the subkey below that. In my case mine is called "KORGUM64.DRV":

Now this is where we need to be super careful. We need to add a String value called "Alias" under each of the keys which end .DRV. The first one needs to be set to midi, the 2nd midi1 the 3rd midi2 etc. Write down exactly which is which as we'll need it for the next step. Some will have the same value (probably wdmaud.drv) don't worry about that - just crack on!

Finally navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32 and add new string values with the names midi, midi1 midi2 etc. and the driver values you had from before:

If you use 32 bit software you may also need to add exactly the same value at HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows NT\CurrentVersion\Drivers32

10 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer

Hi Adrian,

Thank you for writing to Microsoft Community Forums.

The drivers create ports automatically and assign them to devices to communicate with the system. Some applications assign random ports every time you connect the device with your computer where as some of them use the fixed ports for devices, however we can try assigning ports manually to the device. Kindly follow the steps given below.

  • Connect the device with your Windows PC.

  • Right click on Start (Windows logo) and choose Device manager.

  • Expand Ports (COM & LPT).

  • Disconnect the device and see which communication port disappears.

  • Now, reconnect the device and make sure that the port re-appears under Ports (COM & LPT).

  • Right click on the port (Communication port (COM N) and select Properties.

  • Go to Port Settings tab.

  • Click on Advanced.

  • Click on the dropdown list next to COM Port Number and select the port you would like to assign to the device and click Ok.

  • Close the Properties window by clicking Ok.

  • Close Device Manager and see if it works.

I would also suggest to check if there is any option to choose a different port within the driver setup while installing it.

In case none of these methods works, I would suggest to get in touch with the device manufacturer and see if they have any updates/utilities to override this default behavior.

Hope it helps

Regards,

Peer Samie

Microsoft Community-Moderator

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.