MSI touchpad not working after Windows 10 update

I am so frustrated trying to search for a solution to this.  After updating to Windows 10 my touchpad is not working.  It flashes the enable/disable button if you try and turn it on or off and won't let you scroll or click.  I have tried uninstalling it and installing the one from the manufacturer, but windows 10 seems to be resistance against that.  I have tried so many times I can't say what happens each time, but I have gotten the "already a newer version" message, a message saying that it needed to be restarted even after restarting 3 times in a row, and the version that is uninstalled eventually becomes active again.   I would like a definitive solution. 
 

Question Info


Last updated May 25, 2019 Views 42,067 Applies to:

Hello,

Thank you for posting your concern here in Microsoft Community and welcome to the Windows 10 Family. I would be happy to assist you.

From the description provided, I understand that the touchpad does not work after upgrading to Windows 10.

Please follow the below suggested methods and see if the following troubleshooting helps to resolve the issue.

Method 1

Follow these steps to run the windows in built troubleshooter:

a)      Write Troubleshooting in the search box and hit enter.

b)      Click on Troubleshooting tab.

c)      Click on view all option on the upper left corner.

d)      Select the Hardware and Device options from the list.

e)       Click Next to run the Hardware and Device Troubleshooter.

Method 2

Disable and enable the driver

If the above recommendation did not fix the issue, please follow the below steps and check.

a. Press Windows key + X and click on Control Panel.
b. Click on Mouse.

c. On the Device Settings tab of the Mouse Properties screen, click the Disable button to turn off the Touchpad.

d. Restart the system and enable.

Uninstall the drivers from Device Manager

a. Right click on Start, and select Device Manager from the Power User menu.

b. Locate Mouse and Pointer devices and expand the same.

c. Select the drivers, right-click and select Uninstall.

d. Restart the computer, if prompted.

Note: Drivers should get installed after restarting the computer. If it does not, you would have to install the latest driver from manufacturer's website.

Additionally, also follow the below link written by one of our MVP, Andre Da Costa, on Install and Update drivers in Windows 10

http://answers.microsoft.com/en-us/insider/wiki/insider_wintp-insider_devices/how-to-install-and-update-drivers-in-windows-10/a97bbbd1-9973-4d66-9a5b-291300006293

(Also applies to Windows 10)

Hope the above information was helpful. If you need further information, feel free to write to us and we would be happy to help you.

Thank you.

14 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I ran into this problem too on MSI and Win 10.

I solved it in my own case by going into

1) settings --> devices.

2) Go to the mouse & touchpad tab.

3) Click on Additional Mouse Settings. It's at the bottom of the page.

That brings up a new radio dialog box called 'Mouse Properties'. It should have a bunch of tabs lined up along the top, mine defaults as open on the devices tab. If not, click the devices tab.

4) On the devices tab of the Mouse Properties box you should find a button labelled Settings...

5) Click the Settings button.

Yet another pop up box appears, this time it is the Properties for Synaptics Touchpad box and this has all the settings command and control you should need to solve your problem but even then the thing is hidden. Specifically, there is a menu on the left hand side. It has + symbols to expand the file tree structure. 

6) Click on the + scrolling.

This expands the scrolling options to set and apply preferences. I applied my new scrolling preferences, switched to a web browser and it was scrolling as normal.

Worked for me hope it works for others and the original poster.

112 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thank you all for your help it solved my fault on my MSI Apache pro 62 with win 10 .

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Wow when I first starting researching this I read that my Asus GT72 didn't have scrolling options. I thought it was weird for such an expensive gaming laptop not to have scrolling but I gave up. Then today as I was resetting the laptop for selling I thought wait a minute, there has to be a way.... and after half an hour of searching confusing comments everywhere I found your solution BartAlder. YES - not only is it scrolling but so many scrolling options! Thank you so much for posting the answer for us.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

by the way now in windows 10 i had update just like this problem and i went to device and mouse settings and itll say devices and there will be 1 and mine was disabled because of update just click enable and apply then ok and ur set.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Just finished the Windows 10 Fall 2017 Creator's update and both my mouse pad and wireless mouse were freezing up. I uninstalled their drivers but problem still happened.  I figured it could be a display driver problem so in Device Mgr I did a Display driver update by searching the internet and this fixed the problem.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Exactly the same problem here. Microsoft is doing their people to suffer. How I will click on something without a mouse..... Great help guys!!! One more problem like that and I will switch to Mac.... 

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.