Internal SATA hard drives show up as removable devices in 'Safely Remove Hardware'

Hi,

Issue; I've got two of my internal SATA hard drives (4 internal hard drive in total) showing as removeable drives in the 'safely remove hardware and eject media' tray icon list.

I don't want to accidentally eject one of them so I would like them not to appear in the 'eject media' list.

What I've tried so far; I've checked the BIOS and all 'Hot Plug' for these devices is disabled. I've checked the Policies in Device Manager that Cache Writing is enabled ('Better Performance' or 'Quick Removal' are two other options and they are set to Better Performance for each device) 

I found a solution on the MS forum which partly works for me. That is a registry edit run from command prompt as follows;

reg.exe add “HKLM\SYSTEM\CurrentControlSet\Services\storahci\Parameters\Device” /f /v TreatAsInternalPort /t REG_MULTI_SZ /d x (where 'x' is the Bus number of the device)

I have two drives Bus 0 and Bus 1 showing as removeable. The problem is, I enter one Bus and it no longer appears as removeable. So far, so good. But when I try the same for the second bus, it just replaces the first entry in the Registry, so I can only fix one or the other, not both. I can't add the second drive.

.

I'd be grateful if anyone could advise how/if I can work around this. 

Many thanks in advance

 Win 10 Pro (x64) up to date -  Intel (R) Core (TM) i7-3770K @ 3.50GHz  - 32BG RAM - ASUSTeK P8Z77-V PRO

|

Hi,

Can you provide the following information which may help determine any issue(s):

Windows Key + R > type msinfo32 in the "Open" box  > OK > File > Save > then save as an .nfo file

Then make the resulting .nfo file available via a public folder on OneDrive or similar site.

Also, can you do the following:

Windows Key + R > type eventvwr in the "Open" box > OK > expand "Custom Views" and then right-click "Administrative Events" > select "Save all events in Custom View As" and save as an .evtx file

Then make the resulting .evtx file available via a public folder on OneDrive or similar site.

Here's a link on using OneDrive:

http://windows.microsoft.com/en-ca/onedrive/share-file-folder

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi auggy, many thanks for your reply. I have, since posting my request for assistance, solved the issue by eventually finding out how to add both drives into a String Value via the following command;

reg.exe add "HKLM\SYSTEM\CurrentControlSet\Services\storahci\Parameters\Device" /f /v TreatAsInternalPort /t REG_MULTI_SZ /d "0\01"

I copied and pasted this exactly into an elevated Command Prompt. 

This enabled me to add Busses 0 and 1 into the 'Treat As Internal Port' entry in the registry

I hope this info will help anyone else with the same issue.

I must point out that I backed up my registry before I made any changes as this was entirely experimental and working from info I found on other websites.

Thanks again

6 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Thanks for the follow-up.

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated September 11, 2021 Views 2,813 Applies to: