DVD drive reports E:/ Directory name is invalid

Hi All,

After doing a clean install on my PC of Windows 10 whenever I insert a disc in my DVD drive (Drive E:) I get the error message Directory name is invalid. Device Manager reports that the device is installed (LG BD-RE BH10LS30) and working properly. An attempt to update the driver returns the message The latest driver for your device is already installed. If I click on the drive when it is empty it says "Please insert a disc in drive E:" When I do this it shows the disc as a rewritable DVD whether it's a .cda audio disc, bluRay DVD or anything else. I took advantage of this and burned some files to a rewritable DVD. Whenever I insert this disk it is immediately recognised and I can open the disc and view all the files on it. Anything else it just says E:/ Directory name is invalid. I have the same problem on my laptop although I have not yet done a clean install here but just installed the free download for Windows 10.

PC = Gigabyte GAZ87X-UD3H and Intel core i7 4770 with 8 GB of 1600 MHz RAM. Any suggestions would be much appreciated.

richo

 

Question Info


Last updated September 22, 2018 Views 54,980 Applies to:
Answer

Hi Boo,

I finally seemed to have solved my problem. I am not really sure why my method solved the problem so I will tell you everything I did in the hope that it may work for you if you haven't already fixed it.

First of all, immediately after clean installing Windows Ten I upgraded my bios to the latest version for my mobo. Don't know if this caused the problem in the first place. Then I disconnected the DVD drive, rebooted the computer. Still same problem.

Then a couple of days ago I added another key to the registry as described in Microsoft article KB 314060 resolution 5 even though I wasn't really sure if this was relevant to my problem. No difference although I can't remember if I did a cold boot or a warm boot after updating.

Then this morning I did something really simple. I just changed the SATA port the drive was connected to from Port 1 to Port 3. Voila! Everything is normal. WMP plays and rips audio and data files open ready to be read. The drive has been working perfectly in SATA Port 1 with 8.1 for one year so as I said I don't know why changing the port solved the problem unless something got screwed up when I updated the UEFI. Hope there is something in the foregoing that will help you.

Richard

80 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.