Duplex setting on printer not persistent

I have an HP LaserJet P2055dn running on Win10 (new to Win 10 by about 1 month - this worked fine with Win 7).  The system doesn't retain the duplex setting and I keep having to go back to reset the duplex capability as follows.  Settings ->device->Printer->select HP Laserjet P2055dn -> Device and printer folder ->HP Laserjet P2055dn->Device settings ->Installation Option -> duplex and I select 'installed' .  The next time I try to print duplex, I don't get an option for duplex (print on long side or short side) and I repeat the above and the system says the duplex option is 'not installed'.  So I keep having to reset the printer so that the duplex option is installed.  How can I get the system to keep the duplex option installed 

I have used the troubleshooter and reinstalled the drivers, but neither helped.

tks,

 

Question Info


Last updated May 21, 2019 Views 5,597 Applies to:

Hello,

Thank you for posting your query in Microsoft Community.

I request you to follow the methods below.

Method 1:

Uninstall and Reinstall the Printer's Driver.

Step 1: Uninstall the Printer's Drivers

a. Press “Windows Logo” + “X” keys on the keyboard.

b. Click on “Device Manager” from that list.

c. Search for the Printer from the device list, right click on it and then select “Uninstall”. On the un-installation window, if you have an option: “Delete the driver software for this device” you may select that and then remove the corrupted drivers from the computer.

d. Follow the on-screen instructions to complete it and then restart the computer if prompted.

After the restart, please go ahead with the next steps to install the latest drivers and check if that resolves the issue.

Update Driver Software from the Manufacturer’s website:

Step 2: Go to the Printer manufacturer’s website and search for the latest Windows 10 drivers available for the printer model and then install it by following the instructions given in the website.

Method 2:

Follow these steps to install the drivers in compatibility mode and check if that helps.

a. Download the driver from the manufacturer’s website.            

b. Right-click on the driver setup file and click on ‘properties’.

c. Click on the ‘compatibility’ tab and check the box ‘Run this program in compatibility mode for’ and select operating system from the drop down menu and proceed with the installation. Once this is done, restart the computer and check if the issue persists

I request you to refer the article below:

Fix printer problems

http://windows.microsoft.com/en-us/windows/printer-problems-in-windows-help#fix-printer-problems=windows-8&v1h=win8tab1&v2h=win7tab1&v3h=winvistatab1&v4h=winxptab1

Note: The above article willhelp you identify and fix common printer problems in Windows. Printing problems can be caused by cables that aren’t connected properly, problems with wireless adapters or settings, damaged or incompatible printer drivers or missing updates.

I hope this helps you. If you have any further query in future, feel free to contact us. We will be happy to help you.

Thank you.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The reply is not responsive to my question.  The printer works, and I can get it to print duplex, but I have to reset the printer to duplex printing (in the customize printer-device settings screen) every time I want to print duplex.  It reverts to 1 sided printing; how can I get duplex printing to be persistent??

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have this exact same problem, with the exact same printer. with the exact same results, Every time I restart or print I need to tell windows that the duplex unit is installed. Did you ever find a solution to this? 

Thanks

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This is an issue for HP support, as it appears that their "universal" driver is limited in function in Windows 10.  You might want to try disconnecting the printer and uninstalling it in Device Manager.   Reboot the PC and then connect the printer, and Windows will find the best driver.  If that doesn't work, it's a problem with the driver and not the OS.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

I know this post is a little bit old, but I hope I still can help.

I had the same problem, but I solved it.

Responsible is the UAC. I normally set the UAC to maximum security for administrators when I installed Windows. So I did after the installation of Win 10 (perhaps you too). Now  I reset the UAC in admin account to Standard adjustment (in UAC control panel). Then I reinstalled the P2055 driver and set the duplex option to -installed-.

After reboot of the system the option stayed in the driver panel.

Hope this helps.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello Koala72

Thank you for the clue using UAC from Administrator profile and then installing the printer again, this fixed the issue I have been having ever since Window 10 was installed.

The clue that this works is when you check printer setting "Devices and Printers" the various options are now greyed out.

Thanks again and Cheers

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.