Drive 4K resolution with Intel HD 4000 (Windows 10 issue)

I have installed Windows 10 Pro on my core i5 with built-in Intel HD4000 graphics.

Now, I have used to run Linux on that exact HW before installing Windows 10.  That onboard graphics had no problem driving my 4K display (through the HDMI port, at 30 Hz).

For some reason, I cannot get Windows 10 to drive that monitor at 4K resolution.  It is not even appearing as an option when trying to change resolution.

ANY idea what is going on ?!

Thanks in advance!

|

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hello,

Thank you for posting your query on Microsoft Community Forums.

I would appreciate, if you can provide us the following information to help us understand the issue better?

  • What is the make and model of your computer?

This issue may occur due to corrupted display drivers.

I would suggest you to uninstall the display driver and install latest display driver from the computer manufacturer website.

Step 1: Uninstall display driver.

a)      Right-click on the Start Button and click on Device manager.

b)      Double-click on Display Adapters to expand.

c)      Right click on the display adapter driver that is listed and select properties.

d)     In the window opened, click on drivers tab.

e)      In the drivers tab, Click on Uninstall option.

Step 2:
Install latest display driver from the computer manufacturer website and check if it helps.

Also refer:


Run Windows Update and download the latest driver:

How to: Install and Update drivers in Windows 10

Hope this information is helpful. Do let us know if you need any further assistance, we'll be glad to assist you.

5 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I have the exact same problem :-(

However, I was running Windows 7 before and not Linux. I have of course updated with the latest Intel HD 4000 drivers from Intel but it remains the same.

If I ask Windows 10 to list all of the modes that the Intel HD 4000 supports then the highest resolution is 1920x1080. The intel config SW shows that my monitor (not the driver) can go to 4K.

Thus, this requires a driver update from Intel's side before it will work as far as I see it :-(

/JSA

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi Ashish,

No make / model - it is a desktop built from parts...

I can provide any relevant info you may ask for, but make / model is not one of them  ;-)

As mentioned originally - EXACT same configuration running Linux was working great driving 4K resolution.

Sounds like other people (Jacob, in this thread) have the same issue. And it seems Windows 7 -> 10 suffers from same issue.  For what it's worth - I have never had Windows 7 installed on this desktop, so I cannot confirm.

Any other idea (other than re-install Intel's graphics driver)?

Thanks,

Zachi.

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Ha!

I got it working :-)

All I did was more googling...

It turns out that the Intel HD driver usually comes with the opportunity to add custom resolutions. In the previous versions they have had a button for entering this mode. This is not the case for this version - the button/menu is not there but the application remains :-)

Thus, update to the latest Intel HD 4000 driver for Windows 10 and click on your "search windows" and type: "CustomModeApp":

Right click the search result and select: "Run as administrator".

The Intel custom mode application will now open:

*NOTE*: You have to select the right monitor in the upper left corner!

Now, I entered 3840 for "Bredde" (Width in Danish) and 2160 for "Højde" (Height in Danish). I set "opdateringshastighed" (Frequency) to 30 but it ended up setting it to 29 by it self. I chose the CVT-RB as the timing standard.

Then I went to the Intel display configuraiton center and selected the newly added mode - and boom 4K on windows 10 with intel HD 4000 :-)

*UPDATE*: I have some problems making the chosen custom resolution sticky. Does anyone know how to do this?

104 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Jacob,

Forgot to mention in my original post - I DID try that, too...

I cannot add that custom resolution.  see screen shot:

at bottom-right you can see the error I am getting when trying to add this custom resolution ("The custom resolution exceeds the maximum bandwidth capacity").  Tried refresh rate of 29 as well. same result. :(

BTW, can I lower the color depth (to 24-bit)?  That pull-down has ONLY 32-bit option...

Thanks,

Zachi.

11 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Ok... Then I think it must have something to do with the fact that I am running with DisplayPort and you with HDMI. Maybe the GFX driver for win 10 reports an incorrect HDMI version e.g. 1.3 and your TV uses 1.4 but it is not recognized (in Win10)?

/JSA

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Update (good news / bad news):

I got it to work (and that is where good news end...)

The issues I am experiencing:

1. To get it to work, I had to choose 24 Hz ;-(

2. On top of that, every 1-3 minutes the screen goes black, and takes 5 seconds to recover (I suspect it loses sync, and has to re-sync)...

My questions are:

1. ANY way to manually (regedit ?) change the new resolution that was manually added?  I would like to reduce color depth from 32-bit to 24 or 16, and increase the frequency to 30 Hz...

2. Anyone got any experience / knowledge / idea on WHY my monitor keeps losing sync?!  Maybe changing from 24Hz to 30Hz fix it, I will only know once I manage to do it.

Looking forward to hear back (from Jacob or anyone else...),

Zachi.

3 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I'm glad you got it working.

My persistence problem solved it self somehow. After a I have entered the new resolution manually a couple of times it seems like win10 has accepted it and starts using it when I attach the monitor. I use the same monitor at home and at work. The monitor is very picky about the input on the DisplayPort pins compared to other monitors I have used.

I think you problem is related to the driver. In principle the resolution change box should show the intersection between the resolutions which the driver/hw is capable of and the monitors capabilities. This is not the case for this driver. Thus, a proper fix is a driver update.

If you get some feedback on register DB hacking then please share it.

I really hope you get it to work.

If you can then try it with another monitor to see if the sync problems disappears.

/JSA

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Quick update:

I have installed a newer driver from Intel (10.18.10.4276).

NO CHANGE AT ALL.

My problems still persist  :(

Still does not offer me 4K resolution.

Still cannot create a custom resolution with more than 24p refresh rate.

Still (when using custom resolution 4K 24p) - every few seconds it loses sync, re-syncs, and that takes a good 5-6 seconds, which makes it totally un-usable!!!

Am I all alone with my issues?!?!

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Mine just did the update as well and it seems like it just continued to work.

and yes :-| you are all alone with your problems - dooh!

I would still recommend you to try with another 4K monitor. Depending on how old your monitor is then the 4K support in it might not be that good.

Another thing to consider is the MST/SST problem but that is with DisplayPort and you are using HDMI if I recall correctly - right?

/JSA

6 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated June 14, 2021 Views 59,375 Applies to: