DirectPlay Can't be enabled

Hello

So I have enabled directplay from "programs and features" but it requires restart after that, when I restart still it is not enabled

If you have any idea how to fix this issue please let me know

Thank you

[Moved from: Windows/ Gaming on Windows 10]   

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi,

Thank you for providing details about your concern. We would like to ask for more information so we could provide a proper resolution. Kindly answer the following questions:

  • Which Windows 10 build are you using?

Here are the steps on how to get the Windows version and build number of your PC:

1. Go to Settings.

2. Click System.

3. Click About.

You can also do this:

1. Hit Start.

2. Type winver.

3. Press Enter.

  • Are you using any third-party antivirus software?
  • Were there any changes made on your device prior to this? Was Windows upgraded recently?

Installing any important and optimal updates can often correct issues by replacing outdated files and fixing vulnerabilities. The best way to keep your PC current is to turn on automatic updates. With automatic updates, you don’t have to search for updates online or possibly miss critical fixes or device drivers for your Windows PC. Windows Update automatically installs important updates as they become available.

To turn on automatic updates in Windows 10:

 
  1. Select the Start button, then select Settings  > Update & security  > Windows Update . If you want to check for updates manually, select Check for updates.
  2. Select Advanced options, and then under Choose how updates are installed, select Automatic (recommended).

We look forward to your response.

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello 

This is my Windows version

I'm not using any third-party antivirus software and I even tried to turn off Windows defender

I think I have latest version and I have Windows updates set to automatic

 

Thank you


7 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Did you enable BOTH Legacy Components AND DirectPlay or just DirectPlay? 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yes of Course

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

have you resolved this issue yet i have the same problem and don't know to how solve it

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Brad,

For us to better assist you with this concern, we need to ask a few questions:


  • Which Windows 10 build are you using?
  • Are you using a third-party antivirus software?
  • Were there any changes or updates made prior to this issue?
  • What troubleshooting steps have you tried so far?

For steps to help resolve the issue, you can refer to the steps provided by Kris Ver on this thread.

Looking forward to your reply.

Thank you.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This isn't a great help at all. Every time there is a problem, you suggest to update Windows, and for every update, there is ALWAYS a problem. We're going on a loop here. Ridiculous.

26 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Intel(R) Core(TM) i7-7700HQ CPU @2.80GHz
32.0 GB RAM
Windows 10 Home
Version 1709, OS Build 16299.192

I'm having the exact same issue with a brand-new, up-to-date Acer Predator laptop. God, imagine! A brand new laptop that can't run RollerCoaster Tycoon (a game from 1999 recently purchased through GOG)! It's, like... insultingly hilarious.

Each time I tick "Legacy Components > DirectPlay" it's like the change doesn't "stick." I've disabled Windows Defender and Malwarebytes. I've tried launching the software as an administrator in compatibility mode. Nothing works.

I finally went into PowerShell as an administrator and attempted to enable DirectPlay by force, by typing:

PS C:\WINDOWS\system32> Enable-WindowsOptionalFeature -Online -FeatureName LegacyComponents

and here's what I got:


Enable-WindowsOptionalFeature : One or several parent features are disabled so current feature can not be enabled.

At line:1 char:1

+ Enable-WindowsOptionalFeature -Online -FeatureName LegacyComponents
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    + CategoryInfo          : NotSpecified: (:) [Enable-WindowsOptionalFeature], COMException
    + FullyQualifiedErrorId : Microsoft.Dism.Commands.EnableWindowsOptionalFeatureCommand

I *thought* I had finally found the answer here but, alas, it didn't work for me. Maybe it will work for you other folks who are struggling?

I went to the command line, as an administrator, and tried the above idea, typing

C:\WINDOWS\system32>dism /Online /enable-feature /FeatureName:"DirectPlay" /All

...and I received this error:

Deployment Image Servicing and Management tool
Version: 10.0.16299.15

Image Version: 10.0.16299.192

Enabling feature(s)
[==========================100.0%==========================]

Error: 50

The operation is complete but DirectPlay feature was not enabled.
A required parent feature may not be enabled. You can use the /enable-feature /all option to automatically enable each parent feature from the following list. If the parent feature(s) are already enabled, refer to the log file for further diagnostics.
LegacyComponents

The DISM log file can be found at C:\WINDOWS\Logs\DISM\dism.log

After a moment of panic, I was like, "Oh, yeah, that makes sense--I have to enable Legacy Components before I can jump into enabling DirectPlay, duh."

So I typed

C:\WINDOWS\system32>dism /Online /enable-feature /FeatureName:"LegacyComponents" /All

...and this time, the error message I received is a brick freaking wall: 

Deployment Image Servicing and Management tool
Version: 10.0.16299.15

Image Version: 10.0.16299.192

Enabling feature(s)
[==========================100.0%==========================]

Error: 50

The operation is complete but LegacyComponents feature was not enabled.

The DISM log file can be found at C:\WINDOWS\Logs\DISM\dism.log

So there you have it. Windows 10 won't enable Legacy Components, and the reason given is "because, just no."

At this point I did consult the log file... and... and... I don't think it actually logged this. I swear to God.

I really struggle with this because, you know, the reason I'd always preferred Windows to OSX is, I'd appreciated having granular control, independence and autonomy, when it comes to my operating system. The fact that I can't make this one single, permanent change to my OS--one that my husband was able to make on his own computer with a single pair of clicks, no problem--is absolutely crazymaking. The fact that my husband can't reproduce my issue AT ALL, is crazymaking. What, do I have a different Windows than he has??

(Actually... maybe?? He's checking, and, uh-huh, he's running Pro. Do I need to upgrade from Win10 Home to run "legacy" software???? Again: crazymaking.)

21 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

[SOLVED]

Hey, everyone, me again. Finally got Roller Coaster Tycoon working, did not even STOP TO PLAY IT and, instead, immediately exited-out to revisit this thread and tell y'all what finally worked for me.

Okay, so: Something in the 1709 "Fall Creators Update" update stops all of us from enabling DirectPlay and LegacyComponents—and from being able to continue updating Windows 10!

In a 2015 (!) Microsoft Answers reply, Giridhar J details how to brute-force Windows 10 into updating by manually resetting Windows Update Components through command prompt. Following these steps allowed me, at last, to update from 1709 to 1803. And 1803 lets me install and enable DirectPlay.

Giridhar writes:


1. Press Windows Key + X on the keyboard and then select “Command Prompt (Admin)” from the menu.

2. Stop the BITS, Cryptographic, MSI Installer and the Windows Update Services. To do this, type the following commands at a command prompt. Press the “ENTER” key after you type each command.

                           net stop wuauserv
                           net stop cryptSvc
                           net stop bits
                           net stop msiserver

3. Now rename the SoftwareDistribution and Catroot2 folder. You can do this by typing the following commands in the Command Prompt. Press the “ENTER” key after you type each command.

                          ren C:\Windows\SoftwareDistribution SoftwareDistribution.old
                          ren C:\Windows\System32\catroot2 Catroot2.old

4. Now, let’s restart the BITS, Cryptographic, MSI Installer and the Windows Update Services. Type the following commands in the Command Prompt for this. Press the ENTER key after you type each command.

                        net start wuauserv
                        net start cryptSvc
                        net start bits
                        net start msiserver

   5. Type Exit in the Command Prompt to close it.

Now you may try running the Windows Updates and check if the above steps resolve the issue.

Well, I did try running Windows Update, and it did resolve the issue.

I can't say that these steps will for-sure work for everyone, but I can say that if you are "stuck" on Windows Fall Creators Update, nothing you attempt will work until you address the main issue of your Windows being trapped on 1709.

22 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated August 5, 2020 Views 17,979 Applies to: