Question

Q: Closing the lid will only enter into sleep by chance

I have a thinkpad X1 carbon, and upgraded to Windows 10.

Everything worked fine including sleep.

Suddenly one day ( well I can't really recall which day, just recently), I noticed that when I close the lid, it won't enter into sleep.

If I open the lid, and close the lid again in short time, it will enter into sleep then.

I then started testing, and close and open close and open.

Generally, the behaviour is like this:

1. If I close the lid, 9 out of 10 will not sleep, and there's some chance that it will sleep.

2. If I close the lid (no sleep), open the lid again, and close the lid again in shor time, 9 out of 10 it will sleep at the second close.

3. If I close the lid (no sleep), open the lid, and do some operation (browsing etc), then close the lid, it will not sleep (see step 1)

4. If I change the settings to : close the lid then hibernate, then it works everytime, closing the lid will hibernate the computer.

5. In battery mode, the sleep works when lid is closed, only in plugged-in mode, the sleep doesn't work!

My attempts:

1. I tried to see the system event log, and found that, if I close the lid, and the comuter is not in sleep mode, it enters into Away mode. So it did detect the closing action, and tried to do something, but decided to go to away rather than sleep, which is really rediculous.

2. I tried to seach on the forum, and found some media sharing stuff, I tried all settings, including disable media sharing, they didn't solve my problem.

3. I also tried to use "powercfg -requests" in cmd window and found there are none applications that is preventing the system from entering into sleep.

4. I tried to set every single power settings of plugged-in mode to be as same as "battery" mode, no use. Battery still works and plugged in mode still not working most of the time.

5. System restore is not an option because I disabled system restore (harddisk is too small for system restore).

Any advice will be appreciated.

Thanks.



Hello,

Thank you for posting your query on Microsoft Community Forums.

As per description, you are facing issue with the sleep mode.

I would suggest you to follow methods given below and check

Method 1:

Run Power Troubleshooter

I would suggest you to run power troubleshooter which will tell you if there is something wrong with the power settings.

Follow these steps to run power troubleshooter.

  1. Press Windows key + X key and Select Control Panel
  2. Select Troubleshooting.
  3. Select View All on the top left corner.
  4. Run Power troubleshooter.

If issue still persists try method 2.

Method 2:

Follow these steps check the Power Options settings. You can set them to default and check.

a. Press Windows key + X

b. Select Power Options.

c. Check if the preferred plan is Balanced.

d. Click on Change when the computer sleeps and select Restore Default settings for this plan.

If issue didn’t get resolve try method 3.

Method 3: Create a power plan

  1. Press Windows key + X

  2. Select Power Options.

  3. Click where it says "Create a power plan" in the area on the left side of the Power options window.

  4. Select a power plan to start with such as "Balanced" or "High performance" and then click "Next."

  5. Select a number of minutes you want both the display and the computer sleep mode, and then click "Create."

Hope this information is helpful. Do let us know if you need any further assistance, we'll be glad to assist you.        

Did this solve your problem?

Sorry this didn't help.


I am going to answer myself. Not final though because I only tested 10 times I am not sure whether it will work forever after this. More updates will be following if it doesn't work.

After several hours of testing, I found that it is the problem of "Paragon Mounter", which auto mounts my Linux drive during windows startup (it was not auto-mount before, but after some update a month ago, it changed to automount).

Whenever "Paragon Mounter" is on, the sleep glitches in plugged in mode (not in battery mode). How strange but disabling paragon auto mount solves the sleep problem, for now. (tested only limited time).

Did this solve your problem?

Sorry this didn't help.


Hi,

Thank you for replying back with the status of this issue. In case, if you need any assistance you may always post your questions along with your valuable suggestions in this forum.

Did this solve your problem?

Sorry this didn't help.


 
Question Info

Views: 1,107 Last updated: December 29, 2017 Applies to: