Can't take ownership of external hard disk

I have an external hard drive and when i try to open it, it says access denied..

when i try to see the ownership, it says unable to determine owner.

When i try to change the ownership through various methods like cmd promp takeown or by going to the properties of the drive, it says unable to set new owner, access is denied...

Please help!!

 

Question Info


Last updated September 18, 2018 Views 19,322 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi Jenil,

Welcome to the Microsoft community.

In order to assist you better could you please confirm a few things like:

  • Have you installed any third party folder lock software on your computer?

I would suggest you to follow methods and check if it helps.

Method 1:

Step 1: Make sure that you are logged in as an administrator.

Step 2: Try to take ownership of the files and check if it helps.

Taking ownership of a folder from explorer

1)       Locate the file or folder on which you want to take ownership in windows explorer.

2)       Right click on file or folder and select “Properties” from Context Menu.

3)       Click on "Security" tab.

4)       Click on “Advanced” button.

5)       Now click on "Owner" tab in Advanced Security Settings for User windows.

6)       Click on Edit Button and select user from given Change Owner to list if user or group is not in given list.

7)       Click on other users or groups. Enter name of user/group and click ok.

8)       Now select User/group and click apply and ok. Check “Replace owner on subcontainers and objects” if you have files and folder within selected folder.

9)       Click ok when Windows Security Prompt is displayed.

10)     Now Owner name must have changed.

11)     Now click Ok to exist from Properties windows.

Once you have taken the ownership of file or folder next part comes is granting permissions to that file/folder or object.

If the above method doesn’t work, you could try taking ownership from the command line.

Or Taking ownership of a file or folder from command line

Open an elevated Command Prompt window.

 To do so:

 a. press windows + X.

 b. Select Command Prompt as Administrator.

 c. Type the following command and press ENTER:

 takeown /f <foldername> /r /d y

 d. To assign the Administrators group Full Control Permissions for the folder, use this syntax:

icacls <foldername> /grant administrators:F /T

The /T parameter is added so that the operation is carried out through all the sub-directories and files within that folder.

 e. To know more information about the above commands, run these commands from a Command Prompt window.

takeown /?

icacls /?

Once you take ownership, you can grant permissions on those files or folders.

Method 2:

Try the steps in the following Microsoft article.

http://windows.microsoft.com/en-us/windows-8/improve-performance-optimizing-hard-drive

Chkdsk disclaimer.

Important: While performing chkdsk on the hard drive if any bad sectors are found on the hard drive when chkdsk tries to repair that sector if any data available on that might be lost.

Hope this information was helpful and do let us know if you need further assistance. WE will be glad to assist.

12 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

in method 1, around step 9, when i press apply, it says unable to change owner access is denied..

Similar when i use takeown cmd..

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I agree: this is NOT a working solution. Argh.

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

Thank you for update and reply.

Follow the steps below and check If that helps.

        1. Press Windows key + X and click on Command Prompt (Admin).

        2. Type in the command  takeown /f <drive_name> \ /R /D Y

        3. You can replace the < drive_name(F)> with the target drive name.

Refer, https://support.microsoft.com/en-us/kb/2623670(Applies to Windows 10)

Hope this information is helpful. Please do let us know if you need further assistance, we’ll be glad to assist you.

Thank you. 

Pavan N

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I sorted this issue out after a few hours of following instructions here an elsewhere.

Follow instructions to take ownership:

Folder properties

Security tab

Advanced

Ensured ownership was correct - "Change" Ownership to MS ID name [my name  (registered MS account registered email address)

I opened "permissions" properties for a folder that I did have access to and tried to ensure all properties were the same for the problem folder.

[Properties/security tab/advanced/Permissions]

For the problem folder there were a number of "Account Unknown" permissions. I tried to remove these but there was some "inheritance" issue. So I highlighted the "Account Unknown" permission entry in question [not sure if this mattered, I don't think so] and clicked on "Disable inheritance".  All permissions entries disappeared except mine, ie, the one that is same as "Owner", and  "WMPNetworkSvc".  

WMPNetworkSvc permission had full access, but in the folder I was comparing permissions to, it only had read access.  So I changed the permissions for it in the problem folder to "read".  Hit ok etc and bingo could read files in the folder.  

There were some other permissions entries too that disappeared when I Disabled inheritance: 

- Adminstrators

- System

- Account unknown but same as in folder I was comparing to.

These all had full access.

So, Ownership is not necessarily the issue, or not the only issue.

I think the ownership was correct at the outset.  

Changes that I made were:

- WMPNetworkSvc having full access being changed to only read permission,

the other permissions removed when I disabled inheritance

- disabling of inheritance on my permission or the WMPNetworkSvc permission or both.

Now I only have to permissions:

- me ["my name (MS account registered email address"]  full access I am also administrator in user account type [Control Panel\User Accounts\User Accounts\Change Your Account Type]

- WMPNetworkSvc  read access.

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

in method 1, around step 9, when i press apply, it says unable to change owner access is denied..

Similar when i use takeown cmd..

Same here...

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

THANK YOU! the CMD method is exactly what I needed.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Same message came "ERROR: Access is denied." in comment prompt 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

did you launch CMD as admin?

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I launched command prompt as administrator, followed the instructions, and got "ERROR: File ownership cannot be applied on insecure file systems; there is no support for ACLs." 

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.