AMD Switchable Graphics not working in Windows 10 (HP Pavilion DV7t-4100), How to stop Automatic Driver Updates in Windows 10

Hi,

I have HP Pavilion DV7t-4100 laptop with Core i5 (Intel HD Graphics) and AMD Mobility Radeon HD 5000. I don't have any option in BIOS for Switchable Graphic Mode : Dynamic or Fixed,  In Windows 8.1 I had the "Configure Switchable Graphics" options once right clicked on Desktop and it had option for switching automatically while plugged in or on battery. I updated my laptop to Windows 10 Home 64-bit yesterday through windows update. Now once I get this

I can't manually switch to AMD Graphics. I selected Maximize Performance in both Plugged In and Battery, restarted and before Login Screen the screen starts to flash repeatedly for 15-20 seconds then message pops that loginui.exe failed. I restarted several time, same issue, had to to system restore, worked fine, but once I changed it to Maximize Performance it happened the same way on login. I don't game much but I have my Laptop connected to LED TV through HDMI out for media playback and external display only works once AMD Graphics are active. There is no multiple display options once Intel graphics are active.

I have the latest Catalyst and Intel graphics driver for Windows 10 64-bit and Windows update is also up-to-date. I uninstalled everything, re-installed, tried all links and out of ideas now, any ideas....  

 

Question Info


Last updated August 18, 2019 Views 57,256 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

but how do you stop windows update from making automatically updates? because win10 dont have any option to disable auto updates, if i install win7 drivers, the windows update is gonna update it automatically

I've searched other forums as well and found this website from Microsoft. Since i installed Windows 7 again, i'm not able to test it myself but pherhaps someone here could give it a try? It's a work around to temporally turn off automatic updates.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I also Searched and found this method I am trying it now so far so good.

Control Pannel

System and Security

System

Advanced System Settings

Hardware Tab

Device Installation Settings

Do You want windows to download Driver Software? No Let me Chose

Never Install Driver software from Windows Update

Ill Post If it blows up and gets broken again

Reguards

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

So I seen this article http://www.ghacks.net/2015/07/27/microsoft-releases-tool-to-block-windows-10-updates/

that explains the use of the tool you can get from microsoft. It will block auto updates if I read it right just haven't tried it yet went to using a vga for now. Links in the article and here. https://support.microsoft.com/en-us/kb/3073930 I sure hope it helps you, I know your pain when your machine isn't working up to par!

æ

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Found the problem buddy..... :D
That you are looking for, the switchable menu, that dont exist anymore. That menu is calling by "Fixed Mode" when is supported until windows 8.1.
With Windows 10 only supports "Dynamic Mode" that amd uses since 2012. In dynamic mode let you choose which gpu but by applications/profiles. With the driver that windows update downloaded some profiles are locked and the games freezed (indications that was intel graphics activated).
I tried to download last version to both drivers, with detect tools, always first intel, and then amd. intel said i was up to date and amd downloaded last version 15.7.1, and it works, then with dynamic mode, all games were freezing, now with the update, they unlocked most of that profiles, and no more freezes in games. I hope i can help in something :)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

SOLVED

- search for "device installation settings"

- Select options as shown

- Go to Device manager (right click on start button)

- Uninstall the drivers (right click on device - uninstall) and check "delete driver software for the device"

- Graphic card will show as "Microsoft Basic Display Adapter" (Scan for new hardware if it doesnt show)

- Download latest AMD driver from HP (in my case HP only had Windows 7 drivers for my laptop model, so I am installing Windows 7 drivers in Compatibility Mode as explained below), when you run the setup, it will extract the drivers in C:\swsetup\SP50640

- Update the driver

- Go to C:\swsetup\SP50640 and run it in compatibility mode (right click on "setup" go to "compatibility" tab, check "run this program in compatibility mode for" select Windows 7 from drop down menu, click ok, then run the setup.

- you'll have the fixed mode switchable graphics

- HDMI Out to TV only works when AMD Graphic card (High Performance GPU) is selected, now I can switch to AMD and I have display on TV working great. Previously with automatically updated drivers from Microsoft it was not possible to switch to AMD and hence there was no HDMI Out.

- No need to download or install Intel graphic driver because it is included in AMD package and will be installed automatically.

- Now to prevent driver updates, download and run the Microsoft “Show or hide updates” Troubleshooter described in KB 3073930. (Or run the troubleshooter directly by clicking here.)

- Click Advanced

- Uncheck "Apply repairs automatically"

- Click "Hide updates"

- Check AMD and Intel drivers

- This will prevent Automatic Driver Updates.

- Somehow the multi display settings in AMD Catalyst Control Centre werent working for me but Windows Display Settings works (right click on desktop), change "Multiple Display" from drop down menu

Hope this helps, thank you for all your answers, its what made this possible.

35 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

SheldoreD, did you use drivers for Windows 7? I have HP dv6 6030ew and the only latest drivers are from 2011 - only for Win 7 (e.g. there are no drivers for Win 8). Should I install these drivers on Win 10? Please also tell me is HDMI working for you? I was trying almost everything with these drivers with no results...

Moreover, did you install Intel HP graphics drivers from HP page? Or you just left drivers from Microsoft?

Thank you in advance :)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I used the intel detect tools  and amd detect tool (installed amd catalyst 15.7.1 and this is working, but only in dynamic mode

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I used the latest drivers from HP, in my case Windows 7 drivers were the latest for my laptop, HP doesn't have any Windows 8 or 8.1 drivers for my laptop. And yes I have HDMI out to TV working fine now because now I can select AMD graphics (High Performance GPU) from Switchable graphics and HDMI out only works once AMD selected. No need to download or install Intel graphic driver because it is included in AMD package and will be installed automatically. The Intel driver on HP page is for those models with Intel graphic only.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Many thanks for information :) and the last question:

Do you have any problems with games/programs? I read that many people have freezes/BSOD etc.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Many thanks for information :) and the last question:

Do you have any problems with games/programs? I read that many people have freezes/BSOD etc.

I have not faced any issues yet, it has been 4 days since installing these drivers, I mostly use this laptop for browsing, playing videos and light gaming on TV and all is working fine. I use Windows Media Player, Media Player Classic (with CCCP plugins), Kodi and iTunes for media playback. I have tested my games , I play mostly FPS, but on medium to low settings (coz thats only what my laptop can handle) and they worked fine.  

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.