Question
447 views

After Windows 10 update/restart, Networking, Wi-Fi, USB Audio/Video drivers are all gone

djsumdog1 asked on

Today I came to find my Windows 10 laptop rebooted. I really really really hate how Windows installs updates and reboots for you. It's a pretty terrible design decision. In any case, when it came back up, many of my drivers totally disappeared.

I had no networking, USB audio, USB video or bluetooth. I was able to put the Wi-Fi/Ethernet drivers on a USB stick and reinstall them. That worked fine. But the other drivers are core drivers. When I try to let windows reinstall them, I get the following:

Searching for this turns up a plethora of useless posts for Windows XP/7/whatever from years ago. So I tried the following:

  • Uninstalled KB3176493 -- Didn't help
  • Used a system restore point from two days ago -- Same issue -- no drivers (had to reinstall networking again)

I checked my C:\Windows\INF\setupapi.dev.log and see the following when I try to update the driver in the device manager for a USB Audio device:

>>>  [Device Install (DiShowUpdateDevice) - USB\VID_262A&PID_1100&MI_01\6&213CF812&1&0001]
>>>  Section start 2016/08/17 14:19:36.912
      cmd: "C:\WINDOWS\system32\mmc.exe" "C:\WINDOWS\system32\compmgmt.msc" /s
     dvi: {DIF_UPDATEDRIVER_UI} 14:35:31.130
     dvi:      Default installer: Enter 14:35:31.133
     dvi:      Default installer: Exit
     dvi: {DIF_UPDATEDRIVER_UI - exit(0xe000020e)} 14:35:31.137
     ndv: {Update Driver Software Wizard for USB\VID_262A&PID_1100&MI_01\6&213CF812&1&0001}
     sto:      {Setup Import Driver Package: c:\windows\inf\wdma_usb.inf} 14:35:35.293
!    sto:           Unable to determine presence of driver package. Error = 0x00000002
     inf:           Provider: Microsoft
     inf:           Class GUID: {4d36e96c-e325-11ce-bfc1-08002be10318}
     inf:           Driver Version: 10/29/2015,10.0.10586.0
     sto:           {Copy Driver Package: c:\windows\inf\wdma_usb.inf} 14:35:35.308
     sto:                Driver Package = c:\windows\inf\wdma_usb.inf
     sto:                Flags          = 0x00000007
     sto:                Destination    = C:\Users\cassius\AppData\Local\Temp\{360925e0-0e26-7643-bd01-ff3a8203caf7}
     sto:                Copying driver package files to 'C:\Users\cassius\AppData\Local\Temp\{360925e0-0e26-7643-bd01-ff3a8203caf7}'.
     flq:                Copying 'c:\windows\inf\wdma_usb.inf' to 'C:\Users\cassius\AppData\Local\Temp\{360925e0-0e26-7643-bd01-ff3a8203caf7}\wdma_usb.inf'.
!!!  flq:                Error installing file (0x00000002)
!!!  flq:                Error 2: The system cannot find the file specified.
!    flq:                     SourceFile   - 'c:\windows\inf\USBAUDIO.sys'
!    flq:                     TargetFile   - 'C:\Users\cassius\AppData\Local\Temp\{360925e0-0e26-7643-bd01-ff3a8203caf7}\USBAUDIO.sys'
!!!  cpy:                Failed to copy file 'c:\windows\inf\USBAUDIO.sys' to 'C:\Users\cassius\AppData\Local\Temp\{360925e0-0e26-7643-bd01-ff3a8203caf7}\USBAUDIO.sys'. Error = 0x00000002
!!!  flq:                SPFQNOTIFY_COPYERROR: returned SPFQOPERATION_ABORT.
!!!  flq:                Error 995: The I/O operation has been aborted because of either a thread exit or an application request.
!!!  flq:                FileQueueCommit aborting!
!!!  flq:                Error 995: The I/O operation has been aborted because of either a thread exit or an application request.
!!!  sto:                Failed to copy driver package to 'C:\Users\cassius\AppData\Local\Temp\{360925e0-0e26-7643-bd01-ff3a8203caf7}'. Error = 0x00000002
     sto:           {Copy Driver Package: exit(0x00000002)} 14:35:35.362
     sto:      {Setup Import Driver Package - exit (0x00000002)} 14:35:35.365
!!!  ndv:      Driver package import failed for device.
!!!  ndv:      Error 2: The system cannot find the file specified.
     ndv:      Installing NULL driver.
     dvi:      {Plug and Play Service: Device Install for USB\VID_262A&PID_1100&MI_01\6&213CF812&1&0001}
!    ndv:           Installing NULL driver!
     dvi:           {DIF_ALLOW_INSTALL} 14:35:35.****
     dvi:                Default installer: Enter 14:35:35.421
     dvi:                Default installer: Exit
     dvi:           {DIF_ALLOW_INSTALL - exit(0xe000020e)} 14:35:35.421
     dvi:           {DIF_REGISTER_COINSTALLERS} 14:35:35.422
     dvi:                Default installer: Enter 14:35:35.422
     dvi:                Default installer: Exit
     dvi:           {DIF_REGISTER_COINSTALLERS - exit(0x00000000)} 14:35:35.423
     dvi:           {DIF_INSTALLDEVICE} 14:35:35.423
     dvi:                Default installer: Enter 14:35:35.424
!    dvi:                     Installing NULL driver!
     dvi:                     Install Null Driver: Removing device sub-tree. 14:35:35.425
     dvi:                     Install Null Driver: Removing device sub-tree completed. 14:35:35.429
     dvi:                     Install Null Driver: Restarting device. 14:35:35.431
     dvi:                     Install Null Driver: Restarting device completed. 14:35:35.435
     dvi:                     Install Device: Starting device. 14:35:35.435
     dvi:                     Install Device: Starting device completed. 14:35:35.448
     dvi:                Default installer: Exit
     dvi:           {DIF_INSTALLDEVICE - exit(0x00000000)} 14:35:35.448
     ump:      {Plug and Play Service: Device Install exit(00000000)}
     ndv: {Update Driver Software Wizard exit(00000002)}
<<<  Section end 2016/08/17 14:35:37.358
<<<  [Exit status: FAILURE(0x00000002)]

It claims the USBAUDIO.sys is missing. I installed Windows 10 in a VM and...that file doesn't exist in C:\Windows\INF. There is one in System32\Drivers, but if I copy it to this location, I get an error about how the INF isn't signed! Why is it looking in the totally wrong location for this driver? How do I get USB video/audio working again?!

2 people had this question

Abuse history


progress