Windows 10 System High CPU Usage ACPI.sys

Hello all,

Post upgrade to Windows 10 Pro I have been experiencing higher than usual system CPU usage (~10%), accompanied with system interrupts. I used process explorer (screenshot attached). It seems to be ACPI.sys.

All the drivers (that are available for Windows 10 ) are updated to their last versions, as well as the BIOS. Booted into safe mode - problem persists. SSD Firmware has been updated as well. I disabled non-critical devices one by one and the problem persists. 

Hardware:

Laptop: ASUS N550JV; CPU - i7 4700HQ; 16GB RAM; NVIDIA GT750M; Samsung EVO 840 120GB (System Partition); Samsung EVO 840 500GB (additional non-windows stuff installed). Realtek LAN; Qualcomm Atheros WLAN.

I can provide the trace file from xperf as well, but it shows the processes as Unknown.

Any help appreciated! Thank you in advance.


 

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hello,

Thank you for your response.

I appreciate your time and concern.

Microsoft safety scanner works with latest build 10586.36. You may try to upgrade to latest build.

Please keep us updated.

Thank you

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

any updates on this?

I'm seeing the same issue in process explorer. acpi.sys 20-30% cpu use

this is on 1511 even with CU that got installed just today.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hello All,

I solved my issue - it turns out that the SSD Caddy was causing this - by flipping a switch on it the problem was solved. Thanks to everyone for your support!

13 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hello,

Thank you for the reply.

I appreciate your patience.

I would suggest you to perform clean boot and check the issue.
Refer this article:
How to perform a clean boot in Windows
https://support.microsoft.com/en-us/kb/929135

Clean boot is performed to start Windows by using a minimal set of drivers and startup programs. This helps eliminate software conflicts that occur when you install a program or an update or when you run a program.

Note: After you have finished troubleshooting, follow these steps from section “How to reset the computer to start as usual after clean boot troubleshooting” to reset the computer to start as usual.

Please keep us posted.

Thank you

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I have the same problem on my MacBook Pro Retina Late 2013 (11,2) with the same thread (ACPI.sys+0x1e7f0). It happens even on clean installed system with bootcamp drivers, official bootcamp page says nothing about Win 10 support though so I think drivers might cause this problem. Going into sleep mode and back fixes it but when I restart my computer it happens again.

Edit: In my opinion cause of this problem is Intel's driver for integrated graphics because when I delete it and reboot I don't have high cpu usage problem anymore but once I install it again usage goes back to 10-20%. P.S.: I have and had latest drivers for it.

I have the exact same problem as you. MacBook Pro, clean install of Windows 10 with Bootcamp dirvers, going to sleep then waking up fixes the issue but I have to do it every time I reboot which is a pain. I'm on the latest drivers of everything, including the Intel graphics driver. Did you manage to fix it?

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

After many hours researching the problem, i found the real solution: Downgrade the INTEL RAPID STORAGE TECNOLOGY DRIVER (RST) driver to previous version. I've download this:https://downloadcenter.intel.com/download/22194/Intel-Rapid-Storage-Technology-Intel-RST-RAID-Driver. It works with 11.7.0.1013.

The problem is related with power management and sata ahci driver.

SAMSUNG NP700Z5C-S01ES · HDD SAMSUNG EVO 850 512MB · WINDOWS 10 PRO X64

Bye!!

8 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hello Carmelo,

Thank you for sharing information with us.

I hope that your suggestions may help other community members to resolve similar issues.

I appreciate it.

Thank you

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Any update on this? I'm still needing to sleep/wake my laptop every time I boot it up. It's ridiculous now.

Can I provide anything to help fix the issue? An xperf trace or something?

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hello,

Thank you for the reply.

I appreciate your patience and concern.

You may update to latest Windows 10 build 14361 which may include bug fixes and check.
Refer:
https://blogs.windows.com/windowsexperience/2016/06/08/announcing-windows-10-insider-preview-build-14361/

Thank you

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I actually have an active ticket open with MS on this now.

to date, they have been able to reproduce the issue, though for us, we've only seen this on one specific surface model. have not been able to reproduce it on any others.

I too have heard the preview build would fix it, but my stability issues with the latest slow ring build have kept me from jumping into the fast ring, as the machine I can repro the issue on is also a daily driver for me.

I've only found one thing that on my system helps keep this issue at bay...

go to you power options

change plan settings

change advanced power settings

find pci express in the list and expand it

expand link state power mgt

set both on battery and plugged in to max power savings.

since google seems to indicate acpi cpu usage has been an occasional issue on systems for years on various OS versions and systems, my little broke around may only work on my system.

hopefully in fact anniversary will fix it though.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated April 22, 2021 Views 29,184 Applies to: