Windows 10 does not give me the option to eject external hard drives

In windows 10 every time I plug in one of my external hard drives to my surface pro 3 I always have to pull it out without ejecting it because it never gives me the option. It doesn't come up when right clicking the hard drive and it's faded out in file explorer. I know this presents a danger to the files on my external. Does any one have any way to help? I don't want to lose the files on this drive.

It may not be a problem. Have a look at your disk drive in Device Manager, in Properties/Policies.

If Quick removal is set you don't have a problem; your data is not at risk.

231 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

That's correct, thank you I wasn't aware of that setting

19 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I don't have a policies tab displayed; any suggestions

16 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

And you are right clicking on the external hard drive properties?

7 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

[Answering for anyone else who finds themself here, like me, and wondering the same thing!!]

I don't have a policies tab displayed; any suggestions

If your tabs include the others but they are missing the Policies tab, look at bottom left of the pop-up and click on Change Settings. The policies tab will then appear.

And for others, to get to this particular Properties pop-up window, you need to right-click over your portable hard drive name in file manager, select Properties. Then select the Hardware tab. Find the name of your portable hard drive in the Hardware list, highlight it, and click on Properties at bottom right of the pop-up.

53 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

[Answering for anyone else who finds themself here, like me, and wondering the same thing!!]

I don't have a policies tab displayed; any suggestions

If your tabs include the others but they are missing the Policies tab, look at bottom left of the pop-up and click on Change Settings. The policies tab will then appear.

And for others, to get to this particular Properties pop-up window, you need to right-click over your portable hard drive name in file manager, select Properties. Then select the Hardware tab. Find the name of your portable hard drive in the Hardware list, highlight it, and click on Properties at bottom right of the pop-up.

Further clarification, at least in my case, after choosing the drive and clicking on Properties, I had to click on Make Changes (marked with the shield icon) before Policies appeared.

17 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Windows 10 - I could not eject through Device Manager. Ask Leo offers this solution and it works for me.

Right click the Windows icon in task bar on the far left.  Click on Run…, and type in:

RunDll32.exe shell32.dll,Control_RunDLL hotplug.dll

Press OK.

That will bring up the “Safely Remove Hardware” dialog.

From this dialog you can click on the device you want to remove, and press Stop. Once Windows is done with it, you are told you can remove the device.

  

135 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated April 15, 2021 Views 89,267 Applies to: