Windows 10 - Cannot Disable tap-to-click function for ELAN Touchpad Mouse - Acer Laptop

I just upgraded to 10 a couple of days ago and I'm back to having my old tap-to-click issues with my touchpad mouse. My palm hits the touchpad and screws up my typing. (I've already had to fix a few errors while typing these few sentences) I adjusted the mouse settings to longest delay but still have the issue. 

I would like to:

a) disable the tap-to-click (or whatever you call it) on my touch pad

or, if I can't,

b) disable the mouse all together

I don't see a way to disable the mouse like in previous versions of windows. If I try to uninstall the mouse in device manager (so I can use a usb mouse) it removes the device but it still keeps working. The mouse shows up in device driver after rebooting, like nothing happened. 

It's rather frustrating. 

Anyway, hardware is: 

Acer laptop model E1-572-6870

Mouse driver just says ELAN pointer device

 

Question Info


Last updated September 1, 2019 Views 11,987 Applies to:

This was driving me insane. I hate tap-to-click. Anyway, finally stumbled across this page this morning. Hope this works for your laptop, and for everyone's laptop the same as it did for mine.

http://www.tenforums.com/drivers-hardware/10379-how-disable-tap-click-windows-10-a.html

7 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I found that one in my research as well, however it doesn't work for me. At this point I have a feeling I just need to wait for a driver update. The mouse driver for Windows 8 was flaky as well. I used to have to change the setting every time I rebooted this laptop, otherwise it would just revert back. 

Going to contact Acer now and see what they have to say.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I just figured it out, and I can't believe I didn't try this yesterday.

It looks like Windows 10 didn't properly migrate the drivers when it upgraded. 

If you're ELAN option button is greyed out, reinstall the Windows 8.1 ELAN drivers from the Acer website. 

The next step is done in the Mouse Properties window. Here's how to access:

From the "Search the web and Windows" box in the lower left, just type mouse and the first option that comes up is "Change your mouse settings."

Scroll down to the bottom of the settings and click "Additional Mouse Options."

Click on the ELAN tab.

Click the options button.

The first option should be "Tapping"

Uncheck "Enabled"

That should do it. Hope that works for you folks.  

8 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I had this very same problem after I downloaded Windows 10, and few online Answer Sessions are providing a solution. Here was my solution.  I suspect it will work for everyone but here are my particulars. I have a Samsung Laptop.  I had to go to my particular devices web support page and re-download the Synaptics Touchpad Driver to my computer.  When you do, MAKE SURE YOU EXTRACT ALL before running.  My computer restarted.  I went back into the Settings --> Devices -->  Mouse and Touchpad --> Additional Mouse Options.  NOW after the new driver download and restart there was a far right tab called "Device Settings"  Click on Settings --> Tapping.  Unclick "Enable Tapping."  VOILA!!  Hope that helps everyone.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I found that none of the answers detailed helped. In the end I disabled the feature in the registry:
[HKCU\Software\Elantech\SmartPad]

Tap_Activate_Enable:dword=0

Tap_Enable:dword=0

Tap_One_Finger_Enable:dword=0

[HKLM\Software\Elantech\SmartPad]

Tap_Activate_Enable:dword=0

Tap_Enable:dword=0

Tap_One_Finger_Enable:dword=0

Reboot after making the changes. It might be wise to back up those keys first, but I don't have to tell you that...right?

Andy.

17 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

doesn't work.

i can see the tap-to-click in the advanced mouse settings.

but i cannot toggle it, i only see a question mark, but no gear icon.

this drives me crazy, there are 2 big buttons so why, should i use tap-to-click?

can anybody explain this? i always tap a bit too heavy, and that's a click.

i also had this with a logitech keyboard with touchpad with 2 big buttons,

i had to throw away this keyboard because i could not turn off the tap-to-click.

what a rotten hardware feature, especially if there are 2 big buttons present.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Worked like magic! However, I found the registry component under HKCU. Followed the steps, and now I love my new laptop!

Thank you!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have  a Toshiba S55-C5274 with the Elan "smart"pad and windows 10. This procedure is the only thing that worked for me. That is, it worked until Microsoft sent another update. Then, and every time since then when another update is sent, it reverts to tapping. Yes, I have system controls set to not update device drivers but Microsoft overrides that. Plus, Elan keeps adding more settings to the registry each time. As of this date, the settings are appearing only in HKCU in the registry. No longer in HKLM.

The solution appears to be not to ever buy another computer with an Elan Smartpad or Windows OS. I don't like touchpads anyway but it's the only viable solution for mobile use.

                                                                                       ---30---

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.