Win 10 keeps changing my printer static IP port to WSD, already turned off windows printer management

What the ****!!  I have about 100 computers to deal with and now Windows 10 keeps randomly changing the static IP's I have set up at several locations to the WSD-9..port.  Nothing prints when it's on the WSD port, "Let Windows (stupidly) manage my default printer" is set to Off.  Yet, everyday I come in someone can't print and it's the same problem everytime. Last week I watched it happen to each computer in our accounting department.  One after another, one by one they couldn't print and I had to go back in and reassign the ip address under ports to each one.  These port IP have not been changed in over a year, but some recent update is doing this over 4 different locations. 
Answer
Answer

Here was my resolution:

For months users RANDOMLY will get a WSD Port assigned to their printer, Microsoft decided to give WSD Priority over TCP IP Address so each time this happened users randomly will be unable to print, specially if you are working with Citrix, here was my resolution: 

We have Lanier C6502, 3503 and 4503 series and i went into the 

Configuration > Network Security > Disabled the following:

- WSD (Device) Disabled

- WSD (Scanner) Disabled

- WSD (Network) Disabled

I was still able to ping the Printers, scan to email, fax and everything else. This will stop computers from grabbing the WSD Ports from the printers randomly, to make 100% sure this issue will not happen you can also do the following: 

On your computer: 

System > Advanced System Settings > Hardware (Tab) > Device Installation Settings > NO Let me choose what to do (Never Install driver software from Windows Update. 

This will not let you grab Drivers from Windows Updates, after all who in the world would wanna do that ?? 

Life Saver and Headache gone ! ;) 

Clovis :)

21 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Answer
Answer

We're running into this same issue. What registry entry need to be changed to keep it from swapping to WSD from static TCP/IP? This is getting really old. 

If you can't stop the printer advertising WSD, then I would try removing the following registry key and restarting Print Spooler. This will disable the WSD Port Monitor.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\WSD Port

39 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated January 18, 2021 Views 69,858 Applies to: