The USB device returned an invalid USB configuration descriptor - Windows 10

Hi

I a have made myself a small gaming device for my flight symulator. device works with Windows XP but when I try to connect it to my new laptop it shows:

"The USB device returned an invalid USB configuration descriptor" and information about error code 43

in Windows Xp it is a normal game controler with HID

please help!

Marek

Hi Marek,

Error Code 43 is a Device Manager error that means the following:

Windows has stopped this device because it has reported problems. (Code 43)

 

When you get this error with USB devices it’s because one of the drivers controlling the device notified the operating system that the device failed in some manner. This can be because of corruption in one of the loaded drivers and the driver cache just needs to be flushed.

Try to initiate hardware troubleshooter and check if it helps.

  • From the desktop press Windows flag key +R and type control and click ok.
  • This will open control panel, now select all control panel items and then click troubleshooting.
  • Click view all, this will display all the troubleshooters, now select hardware and device troubleshooter and keep us updated.

Please keep us updated.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

If the above suggestion doesn't solve your problem, please try the following:

1. If this is an ASUS system, uninstall AiCharger+ and if it is installed   

    a. Please report back to the forum what the version number is

    b. Reply to this thread and let us know the version number

2. Check your USB controllers in Device Manager

    a. Is there an error code? If so what is it?

    b. it the Microsoft driver? If not what is it?

    c.  try to update the USB drivers in Device Manager

3. If those don’t work file Windows Feedback bug using repro mode with the feedback app as described here (note, repro mode is only available to those who are part of the insiders program): http://blogs.msdn.com/b/usbcoreblog/archive/2015/08/17/filing-usb-feedback-with-repro-mode-in-windows-10.aspx and include the following in the bug:

    a. If the issue is happening all the time or only after certain events (such as waking from sleep)

    b. If all your ports are not working, or if this is only happening on a specific port

If these steps don't fix your problem, please file the Windows Feedback.  This will give us more info as to what is going on.

Thanks!

Kristin

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated July 27, 2020 Views 6,444 Applies to: