Stereo Mix missing in Windows 10? Did they remove it?

So, I've seen Microsoft make this program continually harder and harder to find/use since Windows 7.  I spent weeks getting it to work on my Windows 8.1.  Now, I just updated to Windows 10, and Stereo Mix is gone again.  I have tried all the usual steps.  I have checked "enable devices" under the audio manager.  I have tried re-installing my sound drivers, and I have tried troubleshooting them.  I've even tried the way that worked for me last time, which was to search the program files for a folder called C:\Windows\ System32\ DriverStore\ FileRepository\ chdrt.inf_amd64_4559154dc75c2011, and edited the file chdrt.inf.  I searched for the lines that were the suspect ones last time:

;HKR,%EPattributePath%\EpSettings\StereoMixEnable,Enable,1,01
;HKR,%EPattributePath%\EpSettings\StereoMixEnable,MixAssocSeq,1,E0,E0
;HKR,%EPattributePath%\EpSettings\StereoMixEnable,MuteGainSettings,1,00,00

Last time, the problem was that they had semi-colons in front of those lines, making them comments, and not actual lines.  However, this time, they also were already missing their semi-colons, and looked like this:

HKR,%EPattributePath%\EpSettings\StereoMixEnable,Enable,1,01
HKR,%EPattributePath%\EpSettings\StereoMixEnable,MixAssocSeq,1,E0,E0
HKR,%EPattributePath%\EpSettings\StereoMixEnable,MuteGainSettings,1,00,00

Other pertinent info: I have a Dell Inspiron 5520 Laptop running Windows 10.  I have had every update since Windows 8.  Under Device Manager's "Sound, video & game controllers" tab, I have two audio devices: the Conexant SmartAudio HD, and the Intel(R) Display Audio.  If I don't get any responses soon, I'll try "Rolling back" the drivers, though I'm not sure if you can roll back through a system update.

I guess I have two questions: 1) am I missing some solution to make stereo mix work, or 2) did Windows just up and remove it?

 

Question Info


Last updated November 8, 2018 Views 33,774 Applies to:

hi, i have just experienced the same problem, but managed to sort it out.

when you get the sound box up, if you right click and tick the show disabled devices, then you can enable stereo mix.

hope this helps, see the attached screenshots.

103 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Ok, now I'm really confused.  I have tried doing that a dozen times, and somehow this time it worked.  I somehow now have a box called Stereo Mix in my recording devices.  BUT, when I opened the device I used Stereo Mix in (Audacity) I received the following message:

Error Initializing Audio

Could not find any audio devices.

You will not be able to play or record audio.

Error: Internal PortAudio error

Pic: http://i.imgur.com/XyXtXkx.png

Additionally, there were no boxes to record sound or anything anymore.  It claimed I couldn't listen to music, despite the fact I was listening to music as it said that through WMP.

Pic: http://i.imgur.com/XeyeR81.png

I don't know why the things stopped working, but Stereo Mix started working (I think) after I right-clicked both of them in "device manager" and chose "scan for hardware changes."

Also, when in Audacity, when I click "Audio Device Info," if comes up with this: 

"==============================
Default capture device number: -1
Default playback device number: -1
No devices found"

Pic: http://i.imgur.com/P04nSSK.png

I may try re-installing the drivers, as (according to my "research"), that seems to work for some people.

7 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Well, I just chose "Update Driver" and did the automatic one suggested for the Conexant Driver, and restarted my computer.  When I logged back on, Stereo Mix was disabled (but still there).  I opened Audacity after enabling stereo mix, and like magic, it worked.  Not sure how or why, but all of a sudden, now it's working.  Thanks.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have had this problem too.

Just bought an i7 Lenovo Think Pad this year.

Last year I bought an Acer i7 laptop.

The Acer worked if I right clicked, selected show disable devices and selected Stereo Mix. It recorded streaming sound no problem until plugged in the HDMi cable to my monitor. Once the HDMi cable was connected the Stereo Mix did show but it would not record streaming sound. I had the same problem with an older HP laptop I have.

The Lenovo would not show the stereo mix ever. No matter if the HDMi cable was plugged in or not.

Today CyberLink was offering 80 percent off their PowerDirector 14 Ultimate package so I bought it for the Acer. In the package it has Cyberlink screen recorder. CyberLink Screen recorder has an option to record system sound. That worked perfectly for recording streaming video sound even with the HDMi cable plugged in.

I bought another PowerDirector 14 Ultimate package today for the Lenovo and that also works perfectly even though Stereo Mix does not ever show up.

CyberLink Screen recorder is able to record System Sound even if the Stereo Mix option does not show up.

Today is October 11, 2016.

I hope this helped someone.

Thanks.

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.