Low wifi signal strength after windows 10 update

i upgraded to windows 10 yesterday but after the update wifi signal strength has dropped significantly now i get only one bar and some times my wifi does not even detects my router . Before the upgrade to windows 10 i used to get full wifi signal. I suspect windows 10 is not fully compatible with my wifi adapter please help me out .
I am using HP 15 notebook pc.
I am using Ralink RT3290 802.11bgn Wi-Fi adapter.
Answer
Answer

Dear all,

I used to have this problem, this is the way how I solved it. Go to device manager, then right click on your RT3290 and select properties. Go to the advance tab and in the sensibility option select the highest option 1 and accept.

The adapter will restart and the RT3290 excellent reception will be back.

Regards

193 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer

Hi, the same thing happened to me, Do not act until you have read everything I have to say.  I opened my netbook pavillion x360, looked around,  reconnected the wifi antena to another socket and voila, full signal.  Today, a few months later, same thing happened to a friends HP stream x360 (few hardware changes) right after software reinstallation, so I realized it could be fixed through software.  The driver is OK, you just have to fo to the Device Manager, Advanced options tab of the Wifi Adapter 802.11n broadcom driver in the "properties" window, go to Antenna diversity and switch it to auxiliary.  For some reason HP has not realized this and the default antenna is automatic, which does not work.  Same thing must be happening to it's bluetooth which I have not been able to use. 

 

This usually happens afeter windows 10 and windows 8 installation as their default values do not match what assembly line should be doing also as default, switch the sockets.

 

Hope this helped.

 

ALAN

313 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated September 13, 2020 Views 63,640 Applies to: