How to Enable AHCI for SSD in Windows 10.

Original title: AHCI for SSD

I've installed a Samsung 850 Pro 512 gig  SSD. The Samsung Magician is telling me " AHCI is disabled for one or more connected SSDs. System must boot in AHCI mode for best performance". How do I enable AHCI in Windows 10 Pro? Thanks in advance.

 

Question Info


Last updated June 17, 2019 Views 85,799 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hello David,

Thank you for posting your query in Microsoft Community.

We regret for the inconvenience caused to you. We will be glad to assist you with your issue.

You can try the below steps and check if it helps:

1. While in Windows, press the Win+R keys to open Run, type regedit, and click/tap on OK to open Registry Editor.
2. If prompted by UAC, click/tap on Yes.
3. In the left pane of Registry Editor, browse to the key location below.


HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStorV

4. In the right pane of the iaStorV key, double click/tap on the Start DWORD to modify it. (see screenshot above)
5. Type 0 (zero) for AHCI, and click/tap on OK.

6. In the left pane of Registry Editor, browse to the key location below.


HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStorAV\StartOverride

7. In the right pane of the StartOverride key, double click/tap on the 0 DWORD to modify it.
8. Type 0 (zero), and click/tap on OK.

9. In the left pane of Registry Editor, browse to the key location below.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci

10. In the right pane of the storahci key, double click/tap on the Start DWORD to modify it. (see screenshot above)
11. Type 0 (zero) for AHCI, and click/tap on OK.

12. In the left pane of Registry Editor, browse to the key location below to see if you have the StartOverride here. If you don't, then go to step 15 below. 
          HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci\StartOverride

13. If you do, then, in the right pane of the StartOverride key, double click/tap on the 0 DWORD to modify it.
14. Type 0 (zero), and click/tap on OK.

15. When finished, close Registry Editor.
16. Boot the computer to your BIOS or UEFI firmware settings.

17. In your BIOS or UEFI firmware settings, enable AHCI, and save & exit to apply and restart the computer.

Note: These settings will vary per brand and model number of motherboard. Please read your motherboard manual for more specific details about how to change SATA settings for it.

18. When Windows starts, it'll automatically install AHCI drivers.

19.  When finished, you'll need to click/tap on Restart Now to restart the computer one last time.

Check if it helps. For further assistance you can contact Samsung support.

Thank you.

158 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thank you for the information. It was helpful. The registry keys were already set as you described. I changed the setting from RAID to AHCI and let the computer boot. Windows would not boot up because of a disk error. I let it do the automatic shut down and let it restart for the second time as you mentioned in 19 and the same error resulted. I changed back to RAID and Windows loaded. Samsung Magician gave me an error notification that some of the features wouldn't work because AHCI was not enabled. But at least I was able to get Windows to load. For the most part everything works. It would be nice to be able to use all the features and benefits of the SSD.

Regards.

David.

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thank you very much.

It Worked great for me.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello Alber,

Welcome to Microsoft Community.

Thank you for updating us with the status of the issue and we are glad to know that your issue is resolved.

For further assistance related to Windows feel free to post your queries in Microsoft forums. We will be glad to assist you.

Thank You.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I attempted this today, unsuccesfully I'm afraid. I have a Samsung 850EVO SSD.
As I went through the registry changes I found that at step5 value was 0, at step 7/8- HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStorAV, there was no option for StartOverride. I went back to iaStorV and found the StartOverride option there which I changed fro 3 to 0. at step 11 value was 0, step 15 value was 0.
I then closed regedit and booted to BIOS, changed to AHCI, saved & exited to restart.
Instead of restarting, I got this error message "INACCESSIBLE_BOOT_DEVICE"
I went back to BIOS changed back to IDE, same message.
Finally after a few restart attempts Windows "repaired the problem" and the computer restarted normally.
I went back to regedit and found the iaStorV\startoverride was changed back to 3.
Any idea what went wrong and how I can make the change?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I followed your instructions to the letter, but unfortunately I could never get Win 10 to boot in AHCI mode.  I found all the locations mentioned in steps 3, 6, 9, and 12.  Does Win 10 use the Msahci service?  I could not find it in my registry.

The only registry settings that were not already set to 0 were the StartOverride parameters.

Any suggestions?

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Bonjour,

J'ai appliqué les modifications au registre de mon pc, après redémarrage, les modifications n'ont pas été appliquées ,Type 3 comme au départ?

Merci à vous

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

J'ai trouvé ce lienhttp://www.win-raid.com/t2187f25-Samsung-Magician-sata-AHCI-N-A.html
pour info supplémentaires.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

exactly and this aint the first problem with no help or straight answers windows ten has caused is it lol...

u gave it away for free so no one could make a big fuss .....adapt enough then bring windows 11 out straight away .

incompatible is just bad customer care ASIO probs WinDVD not free , No hardware drivers ready from manufacturers , AHCI . glitches , clicks in audio , USB 3 drv glitches , windows update problems ........

THX MICROSOFT WE LOVE YOU TOO GOD MY SYS WAS PERFECT BEFORE YOUR ""GIFT""

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello David,

Thank you for posting your query in Microsoft Community.

We regret for the inconvenience caused to you. We will be glad to assist you with your issue.

You can try the below steps and check if it helps:

1. While in Windows, press the Win+R keys to open Run, type regedit, and click/tap on OK to open Registry Editor.
2. If prompted by UAC, click/tap on Yes.
3. In the left pane of Registry Editor, browse to the key location below.


HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStorV

4. In the right pane of the iaStorV key, double click/tap on the Start DWORD to modify it. (see screenshot above)
5. Type 0 (zero) for AHCI, and click/tap on OK.

6. In the left pane of Registry Editor, browse to the key location below.


HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStorAV\StartOverride

7. In the right pane of the StartOverride key, double click/tap on the 0 DWORD to modify it.
8. Type 0 (zero), and click/tap on OK.

9. In the left pane of Registry Editor, browse to the key location below.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci

10. In the right pane of the storahci key, double click/tap on the Start DWORD to modify it. (see screenshot above)
11. Type 0 (zero) for AHCI, and click/tap on OK.

12. In the left pane of Registry Editor, browse to the key location below to see if you have the StartOverride here. If you don't, then go to step 15 below. 
          HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci\StartOverride

13. If you do, then, in the right pane of the StartOverride key, double click/tap on the 0 DWORD to modify it.
14. Type 0 (zero), and click/tap on OK.

15. When finished, close Registry Editor.
16. Boot the computer to your BIOS or UEFI firmware settings.

17. In your BIOS or UEFI firmware settings, enable AHCI, and save & exit to apply and restart the computer.

Note: These settings will vary per brand and model number of motherboard. Please read your motherboard manual for more specific details about how to change SATA settings for it.

18. When Windows starts, it'll automatically install AHCI drivers.

19.  When finished, you'll need to click/tap on Restart Now to restart the computer one last time.

Check if it helps. For further assistance you can contact Samsung support.

Thank you.

One additional item was overlooked.  I had to boot the PC into windows safe mode after making changes to the registry.  Then after, reboot the PC, go into the PC BIOS before it boots into windows, change the BIOS to ACHI mode, then reboot normally.  Only then would wondows load the correct drivers.

Keith

22 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.