How can I remove the option to eject SATA drive from the Windows 10 tray icon

Hi,

I have replaced my laptop's DVD-ROM with SATA Hard Drive Bay Adapter and HDD disk. Windows 10 now shows a tray icon "Safely Remove Hardware and Eject Media" for this (secondary) drive whic is basically non-removable device.

So, how can I remove the option to eject SATA drive from system tray.

(Sorry for the Slovenian language in the snipped Picture)

Hi,

Thank you for posting your query in Microsoft Community.

I suggest you to Restart the computer and check if it helps.

Hope this helps, if not do get back to us. We will be happy to assist you.

 
Rakesh C N

Microsoft Community.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

thank you for your reply, but unfortunately this doesn't solve the problem.

Best regards,

Tadej

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

We appreciate your time and effort for getting back to us and I apologize for the delay in responding.

 

Is your issue resolved?

 

Let us know so that we can assist you further.

Rakesh C N

Microsoft Community.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi, I still haven't find a solution.
Tadej

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I suggest you to follow the steps and check if it helps:

  1. Right click on the taskbar>>select properties.
  2. Choose customize option>>settings window pops up.
  3. Find select which option appear on taskbar option and click on it. 
  4. Switch off the option safely remove hardware and eject media

Hope this helps, Let us know the status of the issue. 

Rakesh C N

Microsoft Community.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

this actually works but not in a way I was hoping. This setting only hides the icon from taskbar -for all devices, so if I insert a USB key, I can't safely remove it through this icon.

Tadej

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated October 24, 2020 Views 4,522 Applies to: