High Memory usage by ntoskrnl.exe System after upgrading to windows 10 home

Before upgrading to widows 10 ntoskrnl.exe System in my windows 8.1 only use 0.1 mb ram . But now ntoskrnl.exe System uses 250 to 600 mb ram and its usage keeps on rising when I open more apps . On windows 8.1 my Lenovo flex 2-14 with 4 gb ram uses only 1.5 gb of memory and now 2.5 gb of memory . Is it do to any kernel issues or bugs or is windows 10 is designed like this.  
 

Question Info


Last updated September 14, 2019 Views 115,571 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hello,

Thank you for your interest in Windows 10.

To diagnose and resolve this issue, try the following methods.

Method 1: Run the System File Checker tool (SFC.exe)

System File Checker is a utility in Windows that allows users to scan for corruptions in Windows system files and restore corrupted files. It will scan your system files and to repair missing or corrupted system files in Windows. To run the SFC scan, refer to the Microsoft article below.

http://support.microsoft.com/kb/929833

Method 2:

Let’s place your computer in clean boot state and check if the issue appears in in clean boot state as well.

Clean boot is a process of starting your computer by using a minimal set of drivers and startup programs so that you can determine whether a background program is interfering with your computer performance.

Please refer the Microsoft article below to get more information on this.

How to perform a clean boot in Windows

http://support.microsoft.com/kb/929135

Please refer the section “How to reset the computer to start normally after clean boot troubleshooting” in the article below and follow the steps to bring your computer to the normal state.

Method 3: Update Drivers

Refer to the following article and update all the drivers available.

How to: Install and Update drivers in Windows 10

Install graphics card driver in compatibility mode with Windows 8.1. 

First download the driver from your computer's manufacturer website and then install it in compatibility mode.  

Refer (Make older programs compatible with this version of Windows)

http://windows.microsoft.com/en-US/windows-8/older-programs-compatible-version-windows 

Note: This link also applies to Windows 10.

Hope this information is helpful. Please do let us know if you need further assistance with Windows, we’ll be glad to assist you.

Regards,
Mann Manohar

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have the same issue. The System process (ntoskrnl.exe) is using 1.2 GB RAM. Not much CPU though.
alas

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

CPU : 3 / 20% 

RAM : 52,8% | 1358.6 or 1.35Go

HDD : 0.1Mo/s

Please HELP !

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

To do this, press Win+R, type regedit, then go to HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Ndu and change Start value to 4 (mine was 2) to disable. this will turn off data usage monitoring which may be bad for those with data quotes. Hope this helps. @Found this in other topic with same problem and it looks like helps me!

12 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thank you, but I risk the problem with "explore"?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

For me there no any problems with that.

Update: Issue is not resolved. After a few hours leak of memory shows again...

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

i ve that problem too. need fix.

at half hour

open source OS developer / coder
Furkan Ege Öztürk

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Today this process was 2.1 Gb for me...

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

now its 440 mb ... damn why?!?
open source OS developer / coder
Furkan Ege Öztürk

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Try this

"Disable Runtime Broker to fix high CPU and memory usage

Recent discussions on Reddit strongly suggest that Runtime Broker is one system process which often consumes a large portion of CPU cycles, due to its poor memory optimisation.

However, it can be disabled as follows: Go to Start menu > Settings app and then open System > Notifications & Actions. Deselect the option "Show me tips about Windows" and reboot the computer.

That's it. The memory leak and high CPU usage issues should now be resolved on your PC running Windows 10." from http://www.ibtimes.co.uk/

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.