Excel not recognized as an app in Windows 10.

Windows 10 does not recognize my installed excel 2016 as an app.  I am having trouble associating file types to excel.
 

Question Info


Last updated April 4, 2020 Views 7,402 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi Mike,

Thank you for posting your query in Microsoft Community.

Let's try the following steps and check.

From Start Menu (the Window lower left) -> Settings -> System -> Default Apps -> "Choose default apps by file type"

Scroll to .XLS or .XLSX and left click. Pop-up dialog "Coose an App" will show applications registered to handle that file type. A Excel icon will show -- but is not labeled. Left click to select Excel icon (unlabeled) now shows as application. Repeat as desired. Close the dialog.

Should now be set. Double click file from Desktop of Windows explorer to test.

If the issue remains, I would request you to post your query in Office forums for better assistance.

Hope this information is helpful. Please feel free to reply in case you face any other issues with Windows in future.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Mike,

Thank you for posting your query in Microsoft Community.

Let's try the following steps and check.

From Start Menu (the Window lower left) -> Settings -> System -> Default Apps -> "Choose default apps by file type"

Scroll to .XLS or .XLSX and left click. Pop-up dialog "Coose an App" will show applications registered to handle that file type. A Excel icon will show -- but is not labeled. Left click to select Excel icon (unlabeled) now shows as application. Repeat as desired. Close the dialog.

Should now be set. Double click file from Desktop of Windows explorer to test.

If the issue remains, I would request you to post your query in Office forums for better assistance.

Hope this information is helpful. Please feel free to reply in case you face any other issues with Windows in future.

Hi There your answer to this question doesn't work. Windows 10 does not recognise Excel 2016 as a default programme and it does not show in any lists?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Murray,

Thank you for the update.

Let's try the following:

a. Open a blank Excel sheep

b. Click on File and then click on Options

c. Click on Trust Center and then click on Trust Center Settings

d. Click Protected View

e. Under Protected View window click to check all the 3 options and click OK

f. Close Excel sheet and check if it works now

Please keep us updated.

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi the Excel 2016 works if you go through the programme it's self but it is not recognised by the old folders as a programme that will open them. Your suggestion didn't work and the settings were all correct. Sorry to say.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Murray,

Thanks for the update.

There could be possibility of the files that you are trying to open are saved from older version of Excel which the new one Excel 2016 is having incompatibility difficulty opening it.

  • What is the version of files that you are trying to access in Excel 2016?

Please let us know so we can further research on the issue.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi

I had this problem as well when upgrading Office 365 to 2016 in Windows 10. It relates to Excel 2016 only recognising newer ".xlsx" files as worksheets and not the older excel files (".xls"). Opening ".xls" files from within Excel 2016 worked just fine, but not being able to open them by clicking the file in a folder is a nuisance 

I solved it by doing the following

Go to "Settings" - "System" - "Default apps"

Scroll down, select "Set defaults by app"

Select "Excel 2016"

Select "Choose defaults for this program"

A list of file types will come up including ".xls" which in my case was blank. 

Tick the ".xls" box and save

When you next click on a ".xls" file you will be given the option for Excel 2016.  Once this is selected once, it seems to work for other ".xls" files.  However, a pop-up stating that "Excel is not the default for editing spreadsheets" will come up which I just close.

Hopefully a later upgrade will fix it, at least this work around means you don't have to open ".xls" files from within the Excel app.

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi

Thank you for keeping us updated on the issue and I really appreciate the effort made by you in order to fix the issue.


Your response will sure help others in this community facing similar issues.


Please feel free to reply in case you face any other issues with Windows in future.

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have the same problem. If I go to "Set defaults by App", there is no Excel 2016 entry, although Excel is installed and does work fine. How can I make Excel to appear in this list?

12 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am having the very same issues with excel 2016. I hope that this will be given a solution immediately.

7 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am having the same issues and none of the suggested fixes correct the problem.

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.