AMD Switchable Graphics not working in Windows 10 (HP Pavilion DV7t-4100), How to stop Automatic Driver Updates in Windows 10

Hi,

I have HP Pavilion DV7t-4100 laptop with Core i5 (Intel HD Graphics) and AMD Mobility Radeon HD 5000. I don't have any option in BIOS for Switchable Graphic Mode : Dynamic or Fixed,  In Windows 8.1 I had the "Configure Switchable Graphics" options once right clicked on Desktop and it had option for switching automatically while plugged in or on battery. I updated my laptop to Windows 10 Home 64-bit yesterday through windows update. Now once I get this

I can't manually switch to AMD Graphics. I selected Maximize Performance in both Plugged In and Battery, restarted and before Login Screen the screen starts to flash repeatedly for 15-20 seconds then message pops that loginui.exe failed. I restarted several time, same issue, had to to system restore, worked fine, but once I changed it to Maximize Performance it happened the same way on login. I don't game much but I have my Laptop connected to LED TV through HDMI out for media playback and external display only works once AMD Graphics are active. There is no multiple display options once Intel graphics are active.

I have the latest Catalyst and Intel graphics driver for Windows 10 64-bit and Windows update is also up-to-date. I uninstalled everything, re-installed, tried all links and out of ideas now, any ideas....  

 

Question Info


Last updated November 8, 2019 Views 58,439 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi,

Thank you for posting in Microsoft Community.

I suggest you to uninstall and reinstall the drivers in Compatibility mode and check if it works:

Follow the steps to uninstall the Wi-Fi driver:

  1. Press Windows Key + X key.
  2. Click on Device Manager.
  3. Right-click on the Sound drivers listed and click on ‘Uninstall’.
  4. Select the option to Delete driver software.
  5. Restart the computer after its uninstalled. 

Now download the drivers the manufacturer website and install it in Windows 8.1 compatibility mode. Follow the steps provided below to install the drivers in compatibility mode:

  1. Right-click on the driver setup file and click on ‘properties’.
  2. Click on the ‘compatibility’ tab and check the box "Run this program in compatibility mode for” and select Windows 8.1 operating system from the drop down.
  3. Click on ‘Apply’ and click ‘OK’ and run the file to install it.

Hope it helps.

Thanks.

7 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I know this isn't maybe exactly how you wanted it fixed, because to me it isn't fully switchable yet. I just wanted my ATI graphics and HDMI back. So I just used the old drivers from HP website seems we have the same laptop. Display Driver Uninstaller I found at that thread. It's using for now the ATI graphics card and HDMI to tv is back "windows_key + p" or "function + f4" seems broke so I'm using right click desktop display settings. It's pretty late but I noticed Catalyst Control Center was missing. Closer anyways. I'll post other findings for sure if I find any. Night!

---


Well that's a no go since windows keeps up dating me to the new drivers. Well at least I got to play my game for like 10 minutes! Hope there's a fix on the horizon. This sucks!

æ

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Same error with me. just disappeared the fuction of switchable graphics, and intel HD Graphics is the one activated.

PC SPECS:
HP Pavilion DV6-6060ep
Intel Core i7 2630QM 2.00GHZ
6GB RAM

DUAL GPU:

     AMD Radeon HD 6770M 1GB (Now appears on CCC 6700M)

     Intel Graphics HD 3000

Please microsoft....need to launch a fix for that. I think windows update made the update with diferent drivers (one update for amd and another to intel) but that's is wrong for switchable graphics.......needs to be a update all-in-one, that update both graphics driver.

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I had the same problem with the HP G72 B10SD. 

I use the HDMI-port also for playing media on the TV. When i did the upgrade to Windows 10, i was not able to getting media out of the HDMI-port because the Intel GPU was the only GPU that works with Windows 10 and that GPU seems not to support the HDMI-port. I tried also to install the drivers from the HP site (made for windows 7, 2007 version) but with Windows 10 it seems you may not choose yourself wich driver is the best for you and automaticly installs the newest (2015) version wich does not support switchable graphics. 

Is there a way to turn off this automaticly driver updates? Or can you please make a driver that works?

I had to go back to Windows 7 because of this dumb bug. The Windows 10 notification icon on Windows 7 sayd that my PC was ready for the upgrade to Windows 10 but it say nothing about not supporting HDMI-port or something not working so didn't expect a problem like this. More because its installing like it is an update trough Windows update.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

GUYS FOUND PROBLEM. Graphics cards launched before 2012 work in fixed mode (change gpu by the switchable menu) but after 2012 all been launched with dynamic (change gpu by choosing profiles). So that goes to the problem WINDOWS 10 ONLY SUPPORTS DYNAMIC MODE, BUT YOUR CARD SUPPORTS FIXED MODE

ONLY FIXED I SEE, AND LESHCATLABS(DEVELOPER OF AMD) ADMIN SAID IS TO RETURN TO ORIGINAL OPERATIVE SYSTEM, IN MY CASE GOING BACK TO WINDOWS 7

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi I have a HP DV7T-4100 laptop with a intel and AMD 5650  display adapter. I have had the same problem as Yall. I just uninstalled ccc reboot. uninstall intel video drivers reboot. Downloaded the win7 amd drivers from the hp website and installed them in compatibility mode. Boom It works. Try it.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

but how do you stop windows update from making automatically updates? because win10 dont have any option to disable auto updates, if i install win7 drivers, the windows update is gonna update it automatically

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I don't know I have not ran across that problem yet, when I do IF I can find a solution Ill Post it.

Reguards

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

It worked for a while but Windows update automatically updates to newer graphics drivers which are set to dynamic switching and which are not meant for my PC. I'm going back to Windows 7, no Windows 10 for me, upgrading to cripple my PC doesn't make sense.

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks for your reply, I uninstalled the new ones and installed back the old drivers from HP, got TV back on thru HDMI and it was stuck on Extended mode in catalyst control centre, so had to change it from display settings from desktop like you said. But windows updated the wrong drivers automatically. I've gone back to Windows 7, lets see if there is another work around to have selective Windows Updates.

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.