Q: Windows 10 "Invalid Value for Registry" JPEG

I bought a new computer and almost immediately *upgraded* to Windows 10 when I got the alert, and then downloaded a bunch of photos from my phone and now I cannot open any of them, because I get "Invalid Value for Registry" errors. I need to be able to open them so I can edit and I can't even open to view!  Please advise, I don't know what to do or how to fix this.   I'm a novice, and I need help.... 

***Post moved by the moderator to the appropriate forum category.***



UPDATE NOV 2016: Since I created the post below (roughly one year ago) it appears that Microsoft has added a new feature with the anniversary update that allows to reset the app without touching the registry. I suggest you try this first:

Go to Start, then Settings, System, Apps & Features and click on "Photos" app. Under Advanced options you'll find the reset button.

If that still doesn't work, here is my old post....:


Solution from December 2015:

Hi, I had the same problem and I after a few days of research to find a solution I think I got it:

As expected, the problem is with the registry. I have actually done several things at once but I think this does the magic:

1. Open regedit as Administrator

2. check the following key: \HKEY_CURRENT_USER\SOFTWARE\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\Repository\Families\Microsoft.Windows.Photos_ ... etc.

3. You should have several entries for this key which all have a version number for the app in the name - like: Microsoft.Windows.Photos_15.1201.10020.0_ etc.

4. Check if you have 8 entries in total of which 4 have an older version number than the other 4. That basically means that 4 are outdated an were not deleted for some reason (if you have already uninstalled the photo app there might be only 4 entries in there; some reported having only 4 keys, with 2 keys being outdated - same principle should apply though).

5. Delete the outdated entries (ie. the entries with the smaller version number). That sounds easier than it is, because you won't have the right to do that - even as admin. To take property of the obsolete entries, right click each entry, go to permissions, click advanced, change owner from System to yourself, press ok and then assign full rights to the key to yourself. Now you should be able to delete it. (Check this video to see are more detailed explanation on how to take ownership of the registry keys: Link to Youtube)

6. Do that for all outdated keys and restart.

That should be it. Good luck :-)

I actually deleted all keys in the registry that carried the old version number before I did what is described above - but only the steps above solved the issue. Let me know if it helped!




Did this solve your problem?

Sorry this didn't help.

290 people were helped by this reply

Question Info

Views: 143,034 Last updated: March 24, 2018 Applies to: