Question

Q: Windows 10 DirectShow problem

Hello,

I don't know the correct place to post so do it here.

There is a problem with Windows 10 DirectShow: there sometimes can be an error 0x8004020d while playing the video in GraphEdit or GraphStudio. The file which is played is AVI and the problem must be in FileSource Async or AVI Splitter. However, the same error exists with other file formats. In previous versions of Windows the file played without problems.

Please let me know if you need more details or a sample file.



Hi Maxim,
 
Thank you for being part of Windows 10 family.

 
Sorry to know that you are facing issues with Windows 10.

The issues that you are facing is better suited in MSDN forum support. They have the advanced tools and resources to help you better. 

I would suggest you to post the same question in MSDN forum for further assistance.

https://social.msdn.microsoft.com/Forums/en-US/4fe5d531-914b-47ed-8b90-2e65ade97417/windows-10-and-directshow?forum=windowsdirectshowdevelopment

Hope it helps. Get back to us for further assistance and we will be glad to help.

Did this solve your problem?

Sorry this didn't help.

2 people were helped by this reply


I got the same problem.

I think it is in the sound part, because if you disconnect the sound decoder, the video playes well.

While playing a mp3 is no problem with graphedit

Did this solve your problem?

Sorry this didn't help.

2 people were helped by this reply


Did this solve your problem?

Sorry this didn't help.

2 people were helped by this reply



install the LAV splitter, then it wil work.

but it is a bug, i hope that the avi splitter get fixed in the future.

Did this solve your problem?

Sorry this didn't help.

2 people were helped by this reply


I have the same problem, windows 10 will choke on avi files using mjpeg codec that worked great in windows xp/7/8, and the problem is somewhere in the avi splitter since replacing that with another thrird party splitter like "LAV" or "Haali" fixes the error.

This is critical since the program i have developed, which is a video subtitling software, no longer functions correctly in windows 10 unless a third party replacement of core directshow functionality, is installed.

Note i can also provide a sample video that will enable you to recreate the error in windows 10.

How do we report this bug to Microsoft so that they will actually take notice and start fixing it? It seems that the insider preview and feedback programs doesn't lead anywhere, the bug is already posted in several of these Microsoft forums without any reaction from them.

cheers

uffe

 

Did this solve your problem?

Sorry this didn't help.

2 people were helped by this reply


 
Question Info

Views: 6,274 Last updated: July 20, 2018 Applies to: