Win 10 (64 bit) File Explorer Does not Auto Refresh

I just had an update by MS and now my autorefresh doesn't work on File Explorer.

Searching on line I found notes about looking in CLSID for "dontrefresh". My computer doesn't have that in the regestry anyplace they said to look.

Now what do I do? Can someone show me/tell me how to get it working again???

I am doing a lot of file management and not having this autorefresh not working is a pain in rear.

I don't want to have to do an F5 every time I edit/copy a file. (which I'm doing  tons of right now...

HELP PLEASE!

[Original title: Windows 10 64 bit file explorer auto refresh]

***Subject edited for clarity by the moderator.***

 

Question Info


Last updated December 8, 2019 Views 42,742 Applies to:
Answer
Answer

Hi Dave,

Regarding your query that your Windows Explorer don't refresh automatically, the solution you've just found will definitely work. But if you could not find the DontRefresh DWORD inside your PC registry, you can create one for your Windows 10. Here is how:

Note: The method to fix the issue will include Registry modification. Before you modify the Registry, make sure to back it up and understand how to restore the registry if a problem occurs. Please refer to this link: How to back up and restore the registry in Windows.

1. Go to Registry editor (regedit.exe)

For 64-bit based computer, locate this key address HKEY_CLASSES_ROOT\Wow6432Node\CLSID

For 32-bit system base, locate this: HKEY_CLASSES_ROOT\CLSID

2. Right click on CLSID, hover to New and click on Key.

3. Use this as key name: {BDEADE7F-C265-11D0-BCED-00A0C90AB50F}

4. Right click on the newly created key, hover again to New and choose Key. Name it as Instance.

5. Now, right click on Instance, Hover your mouse to New, choose the ~WORD Value (DWORD is for 32-bit, and QWORD is for 64-bit) and name it as DontRefresh. ~WORD value should 0 (Zero).

6. Restart the computer.

This should get the job done. Base on our further tests, for some reasons, DWORD also work with 64-bit. You can try both files, one at a time. Just be sure to delete the first ~WORD that did not work.

Let us know when you need further assistance.

119 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.