USB Safe to remove Notification missing

After an update for Windows 10 the USB notification for "Safe to remove Hardware" no longer appeared in the notifications in the action center.

I checked that the notifications where on in Notifications & Actions and it is. 

The icon also moves position, however no prompt that said it was safe to remove and no sound was played.

 

Question Info


Last updated November 19, 2018 Views 23,620 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi,

Welcome to Microsoft Community.

Create a batch file that will prompt you to “Safe to remove Hardware" with just a click.

  1. Open notepad

  2. Type “rundll32 shell32.dll,Control_RunDLL hotplug.dll”

  3. Click save as and file name should be XYZBAT.bat. (XYZ can be any name of your choice)

  4. Double click the file anytime you want to get ““Safe to remove Hardware" prompt.

Thanks, 

26 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

Welcome to Microsoft Community.

Create a batch file that will prompt you to “Safe to remove Hardware" with just a click.

  1. Open notepad

  2. Type “rundll32 shell32.dll,Control_RunDLL hotplug.dll”

  3. Click save as and file name should be XYZBAT.bat. (XYZ can be any name of your choice)

  4. Double click the file anytime you want to get ““Safe to remove Hardware" prompt.

Thanks, 

This is a very poor answer.  Why should I have to run yet another script to tell me when a USB device has safely dismounted?  Prior to W10, this prompt was automatic and definitely helped to prevent file corruption when dismounting a USB stick.

So I will ask the question again:  How to I set the chime and prompt to automatically announce that it is "safe to remove hardware"?  Or is this a "feature" that is no longer available within Windows 10?

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The safely remove hardware icon is flaky in Windows 10 (and is still doesn't work in the current preview version)  You would think that such basic features would just work.

You could try this:

In Settings > System > Notifications & Actions > Select which icons appear on the taskbar

Turn off Windows Explorer-Safely remove hardware and eject media

Restart the computer

Turn it on again

10 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

That bat file doesn't work. I just lost the notice two days ago so it is not a preview issue.

NOTHING I found with a search works.

HELLO MICROSOFT

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The "eject" or "safely remove" does not work in W10.  So I've been doing the following:

Do the "eject" (it does have a partial function).

Then put the computer to "sleep".

Disconnect the USB device (external drive or memory stick).

Wake up the computer.

The USB device seems to completely shut down upon putting the computer to sleep, even if powered by an external power supply (some large hard drives).  Upon the wakeup, the device is not shown in the File Explorer.

Crazy, but the W7 clean dismount (safely remove) seems to be lost in W10.

HELLO MICROSOFT. 

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

On Acer laptop with fresh install of Win 10, followed by Win 10 Anniversary Update.

ISSUE: Upon inserting a USB thumb drive I did not get the notification that normally appears.

And after using the 'Safely Remove Hardware…' icon to eject the thumb drive I did not get a notification saying that it was OK (or not) to remove the device.

SOLUTION: r-click Action center icon on taskbar and turn off Quiet Hours.

That's it. All I had to do was turn off Quiet Hours (was not even aware that it was turned on) and I was again getting the notifications from 'Safely Remove Hardware...' as expected.

Hope this helps someone else,

Lilla

150 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

On Acer laptop with fresh install of Win 10, followed by Win 10 Anniversary Update.

ISSUE: Upon inserting a USB thumb drive I did not get the notification that normally appears.

And after using the 'Safely Remove Hardware…' icon to eject the thumb drive I did not get a notification saying that it was OK (or not) to remove the device.

SOLUTION: r-click Action center icon on taskbar and turn off Quiet Hours.

That's it. All I had to do was turn off Quiet Hours (was not even aware that it was turned on) and I was again getting the notifications from 'Safely Remove Hardware...' as expected.

Hope this helps someone else,

Lilla

Thanks a lot, seems to work here, on W10 (still 1511 version) -- and without rebooting ... :)

Best Regards

Wolfgang

26 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi..

You can follow this step

  1. Press keyboard "win + R"
  2. Type "regedit"
  3. Search the value "HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Notification\Settings\Microsoft.Explorer.Notification.{...}"
  4. If you REG_DWORD 0x00000001(0) set "0" you can double click on value. Set the value data to "1"
  5. Click "OK"
Good luck

384 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thank you! Worked perfectly!

7 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This bat displays the same drives as the icon in the System Tray. When I run it, a message comes up telling me that this drive is not removable and cannot be removed. It used to work before I upgraded to Windows 10 v1607.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.