RuntimeBroker error

I'm having a problem with Windows 10.  Whenever I right click on certain things such as a listing on the start menu and click "open file location" I get the following error.  This problem does not exist on the Administrator user profile.

"RuntimeBroker.exe    This file does not have a program associated with it for performing this action.  Please install a program or, if one is already installed, create an association in the Default Programs control panel".  

I'm note sure what I'm looking for when I go to the Default Programs Control panel or how to correct this situation. 

I've run the following repair functions, and none have corrected the situation.

sfc /scannow

dism /online /cleanup-image /restorehealth

devmgr_show_nonpresent_devices=1

Can anyone give me some advise on how to fix this?

 

Question Info


Last updated July 12, 2019 Views 2,275 Applies to:

Hi,

Refer to the link and follow steps from the Reset your PC section

http://windows.microsoft.com/en-us/windows-10/windows-10-recovery-options

Vinod Archak
Forum Moderator

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

HI,

Be sure to check for malware if the below does not work.

First -> Start  Settings- System - Notifications & actions - Turn off -> "Show
me tips about Windows".

Then Reboot the computer.

That will work for many.

Hope this helps.
--------------------------------------------------------------------------------------------
Rob Brown - Microsoft MVP <- profile - Windows Experience : Bicycle - Mark Twain said it right.
Rob Brown - Microsoft MVP - Windows and Devices for IT 2010 - current
Windows Insider MVP 2016 - current

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I know this is more than two years old, but I had the exact same problem and was unable to solve it. I found that another profile on the same PC was working, so I started by exporting the registry keys for folder and directory from both registries and compared them. I very quickly found out that those two keys from the two profiles were an exact match apart from one single value.

I don't know what changed it - for sure it was not a manual change on my behalf. Maybe some installer or some recent patch, I believe it might have happened no earlier than November - at first I didn't notice it.

HKEY_CLASSES_ROOT\Folder\shell should not have any value in Default. if you export it, it should appear in the .reg file as:

    ...

    [HKEY_CLASSES_ROOT\Folder\shell]
        

    [HKEY_CLASSES_ROOT\Folder\shell\explore]

    ...

in my case, Default had a "none" value, appearing in the exported .reg as:

    ...

    [HKEY_CLASSES_ROOT\Folder\shell]
    @="none"

    [HKEY_CLASSES_ROOT\Folder\shell\explore]

    ...

simply deleting the "none" value in Regedit solved the issue, without even logging off or restarting.

Note that this value caused at least two issues that I am aware of:

1. selecting More | Open file location for a tile in Start screen caused a RuntimeBroker.exe error

2. clicking on Open Folder for favourites in Microsoft Edge caused a browser_broker.exe error.

Both issues were solved.

Hope this helps other users with the same or similar issues.

14 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.