Read Only Issues - Windows 10 Upgrade

After upgrading to Windows 10 I began to have issues with ReadOnly permissions issues in my local users directory. I was also having issue with syncing with OneDrive. After much deliberation I decided to reinstall Windows 10 which then doesn't give me access to restore back to Windows 7 Ultimate.

AFter doing so I still have run into many issues but the main issue I am finding is that All of my files are still in readonly status. I went to the properties of the directory and unchecked the readonly option and applied it. All of my files are now executable but the problem that remains is the Directories are READ ONLY, which means I cannot write a file to any directory.

I do not see a  way to change the directory to read-write permissions.

Come on Microsoft why does this **** happen every time you release a new version of Windows? Don't you test all of the scenarios! I am not stuck. I am a freelance web developer and I cannot even do my work. Am I going to have to another operating system?

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hello,

Thank you for posting your query on Microsoft Community Forums.

I can understand the inconvenience you have experienced.

I would suggest you take the permissions of the drive and check.

How to take ownership of a file or folder or Drive in Windows

 

a)    Go to the drive that contains the file or Folder whose ownership you want to change.

b)    Right Click of mouse on that file or Folder and Choose “Properties“.

c)     Navigate to “Security” tab.

d)    Click on “Advanced” on the Security tab to open the Advance security setting for the file.

e)    On the Owner; Click on “Change“.

f)     Click on “Advanced” on the open “Select User or Group” Window.

g)    Click on “Find Now” on the open Window.

h)    It will show you all the available user on the Search results.

i)      Now select the user that you want to give the ownership and click on “OK“.

j)     Again Click on “OK” on the “Select User or Group” to change the ownership.

k)     Now the Ownership for that file or folder is changed.

l)      Now apply all the changes and Click on OK and close all the open Window.

How to change permission of a file or folder or drive in Windows

 

a)    Go to the drive that contains the file or Folder whose ownership you want to change.

b)    Right Click of mouse on that file or Folder and Choose “Properties“.

c)     Navigate to “Security” tab

d)    Click on “Edit” on the Change permission.

e)    Now it will the Windows to change the permission.

f)     Now select the user whose permission you want to change on the “Group or User names“.

g)    Now on the permission for selected user tick below the Allow Section of Full Control.

h)    Now click on “Apply“.

i)      It will show you a warning message “You are about to change the permission setting on system folders. This can reduce the Security of your computer and cause users to have problems accessing the files. Do you want to Continue?“. Just ignore the message and Click on “Yes“.
OK

j)     Now click on “OK” and close all the open Windows.

k)     Now you have change the permission for the selected user and give them Full control.

 

Hope the information helps. Let us know if you need further assistance with Windows, we’ll be glad to assist you.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I've done all these steps and *still* can't (1) open a file in editable form--all are Read Only, whether I open from the explorer window or from within Word and (2) can't save anything to the Documents folder.

Like the OP, this has put my work to a halt and it's incredibly frustrating.

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Same issue.  I've checked permissions, I am the administrator.  I simply cannot change files/folders from "read only".  

68 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

System Builder, Power User, Gamer, Computer Geek
Windows 10 Pro 64-bit

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

This worked....until I restarted my computer then it reverted back to Read Only

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I believe this has to do with the OWNERSHIP of the directory and files in it.  When I upgraded to Windows 10, it saw all files as unowned so it assigned them to a "random" owner.  Even though I had full control authority, it would not let me update those files, though it would let me create new files.

I found this guide for changing ownership of them and it works for the entire hierarchy and also includes inheritance.

http://winaero.com/blog/how-to-take-ownership-and-get-full-access-to-files-and-folders-in-windows-10/

NOTE:  I have a smaller SSD drive for my C: drive.  In order to save space, I created JUNCTION links within my C:\Users\tom directory so that all my pictures and documents can exist on a larger SATA drive.  The automatic process above does not traverse the junction links, so I had to make sure to process the real locations.  I am now in the process of taking ownership of all files on my large drives, though I am not modifying any system files on my C: drive unless I have to.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

After upgrading to Windows 10 I began to have issues with ReadOnly permissions issues in my local users directory. I was also having issue with syncing with OneDrive. After much deliberation I decided to reinstall Windows 10 which then doesn't give me access to restore back to Windows 7 Ultimate.

AFter doing so I still have run into many issues but the main issue I am finding is that All of my files are still in readonly status. I went to the properties of the directory and unchecked the readonly option and applied it. All of my files are now executable but the problem that remains is the Directories are READ ONLY, which means I cannot write a file to any directory.

I do not see a  way to change the directory to read-write permissions.

Come on Microsoft why does this **** happen every time you release a new version of Windows? Don't you test all of the scenarios! I am not stuck. I am a freelance web developer and I cannot even do my work. Am I going to have to another operating system?

I went to this website:  http://www.howtogeek.com/howto/windows-vista/enable-the-hidden-administrator-account-on-windows-vista/ .....followed the instructions (sort of) and got all my read-only files unchecked.  When I clicked on a folder in my Documents folder and selected Properties, the Read-Only block was filled.  I unchecked it and it asked if I wanted to apply that to all the sub-folders and files.  I replied that I did.  When I went back to the folder after doing so, it still said Read-Only BUT the files in the folder were unchecked.  I went through all the sub-folders in each "master" folder and did the uncheck, Apply, OK routine all the way through the Documents hierarchy.  It took me almost 2 hours to do so but when I logged off as Administrator and back on as myself, all the files within the folders were okay.  It beats getting a new computer!

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I too followed all of these steps (before I read this) and now I have no problems at all. Thanks for everything. I hope that other users find your steps useful.

JB

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I have the same problem as well as the critical error when cortana and notifications don't work.

The critical error has gone away, the read only issue is still here. It is embarrassing that these guys release software like this and offer up solutions that don't fix the bugs.

No wonder we're all moving from MSFT.

My read only problem is still not fixed!

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I have taken ownership and changed permissions on my Documents folder as described. However I am still not able to change the files from read only.  

Other posts have linked this issue to running OneDrive. Is this not part of the problem?

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated November 16, 2020 Views 19,325 Applies to: