Raid 1 broken after Windows 10 install

I just upgraded from Windows 7 to Windows 10.  Windows is installed on my C: drive which is a SSD.  I also had a Raid1 array for data storage.  Looking at my drives post install, it now shows the Raid1 array as two separate drives:

Please let me know how to rebuild the array without losing my data.  Thank you

 
Question Info

Last updated July 17, 2018 Views 5,332 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi Andrew,

Thank you for posting your query on Microsoft Community.

I appreciate your interest in Windows 10. We sincerely regret for the inconvenience caused. 

I suggest you to perform the startup repair using the Windows 10 installation media from the below link and check if it helps.

Boot from the Windows 10 installation media and then perform automatic repair and check if it helps.

Follow the steps to perform Automatic repair:

  1. Insert installation media and restart the computer.

  2. Select language and click on Next.

  3. Select Repair your Computer and click on Skip this drive.

  4. Select Troubleshoot and click on Advanced Options.

  5. Here choose the option Automatic Repair and follow the prompted instructions.

Please let us know if you need further assistance.

Thank you.

Did this solve your problem?

Sorry this didn't help.

Hi Divya,

The issue is not resolved.  I used the windows media creation tool to create a bootable dvd with windows 10 on it.  I then tried the steps above.  On step 5, "choose Automatic Repair" was not an option.  There was a startup repair option so i tried that.  It did not find anything to repair.  I clicked through every other option available in the troubleshoot section.  Nothing presented me with an ability to rebuild the RAID array.  

Please let me know if there are other troubleshooting steps I can take.  Thank you.

Did this solve your problem?

Sorry this didn't help.

Since there was no response to this I did further research.  I think that the reason the RAID 1 was broken was due to it being a software RAID through windows rather than a hardware RAID setup.  Windows 10 does not appear to support the RAID structure.  They created something called "Storage Spaces" instead.  It looks to be a more dynamic version of RAID, but I'm not 100% sure.  I had to copy all of the data off of the existing drive to save it.  Then I used Storage Spaces to create a new, mirrored drive out of the two hard drives.  I then copied all of my data back onto the drive.  Seems to have solved my problem, even if it did take hours of time and research when it instead should have been part of the upgrade process.  Thankfully I also had an additional hard drive on hand.  I hope this helps someone with a similar problem down the road. 

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Unfortunately I have the exact same thing. 2 SSD mirrored for system drive + 2 traditional SATA mirrored for data (both are the built in soft raid). Upgraded from 7 to 10, and the failed redundancy was a fact.

I can rebuild my mirrors inside the Disk Manager (tho it takes 3 full days to complete) BUT after EVERY restart they break again and it starts rebuilding anew. This is a 100% reproducable error!

Microsoft, you seriously have to do your homework here.

Did this solve your problem?

Sorry this didn't help.

Hello - I don't believe the problem happens only to software RAID.

I had on my HP Phoenix h9-1020fr with WIN7 a similar structure to the one described :

  • 1 SSD as a C:
  • 1 "RAID1" as B:.

My RAID1 had been created directly from the Boot manager, not WIN7.

After migrating to WIN10 the RAID structure was split and a copy before the migration left behind as a new D: disk.

Now I do not know how to simply unite them without wasting a whole WE.

This problem from WIN10 is totally appalling. What was MS thinking ? Do they think they can force people to use their solutions like 'Storage Spaces' ? I am so disappointed. 

Did this solve your problem?

Sorry this didn't help.

Same, I have a hardware RAID array and the update last October split the disks in the array. I copied all the data to an external drive, rebuilt the RAID with my on-board controller, and then copied the data back. I just installed the most recent Microsoft "feature", and it broke by RAID again. How about Microsoft creates a new feature where Windows Updates don't break things? That would be a novel achievement. Of course, the Microsoft support staff blames everything except for the OS. This is Windows 10, I thought it was supposed to be about progress and improvement.

Did this solve your problem?

Sorry this didn't help.

@Xenorm,

If I understand you correctly, I have just had the same problem, albeit a little different. I have a Samsung 500 GB SSD as my boot drive and have or had a RAID 1 volume (that's the simple mirroring type of RAID, right? I thought what I had was called RAID 0 but Device Manager says 'Intel RAID 1 Volume') consisting of two (2) WD Red 3 TB HDDs set up in a RAID 1 mirroring configuration. Device Manager also shows 'Intel RAID 1 Volume SCSI Disk Device', but it is grayed out.

I've been running Win 10 for about a year now (from just before the free upgrade offer ended). Everything seemed to be running ok until 7/24/2017 9:06:02 AM when I got an error according to Event Viewer, showing the source as Kernel-PnP with  Event ID = 441 (preceded by IDs = 410 & 400). Following is what the General Tab shows:

Device SCSI\Disk&Ven_Intel&Prod_Raid_1_Volume\4&325caff0&0&030100 could not be migrated.

Last Device Instance Id: USBSTOR\Disk&Ven_Generic&Prod_STORAGE_DEVICE&Rev_0570\000000000570&0
Class Guid: {4d36e967-e325-11ce-bfc1-08002be10318}
Location Path: 
Migration Rank: 0xF000FC00FFFFF130
Present: false
Status: 0xC0000719

I am fairly computer-literate, but much of this is gibberish to me. However, Xenorm, your post struck me because under the Event Viewer for "Device Manager - Intel(R) Desktop/Workstation/Server Express Chipset SATA RAID Controller", I received three Information Events (IDs = 410, 400 & 440) at 7/22/2017 3:18:24 AM, which must have occurred while the latest Win 10 update was installing on my computer. 

I knew nothing about the WIN 10/Hardware RAID incompatibility. I did not create a restore point before scheduling the update to run.. On the morning of the 26th, presumably

at 9:06 AM, I restarted my computer as directed ( I had not used it the day before) and it gave me a blue screen instructing me to hit CRTL-I (as in Irving) to enter the configuration menu (even before the MSI -- the motherboard manufacturer -- screen flashed by. When I did so, it said that the status of the RAID 0 volume was 'Rebuild'. The config screen showed six options, three of which were 'grayed out', including 'Repair Volume Options'. 

 

The three active options were, IIRC, 'Rebuild Volume', 'Delete Volume', and 'Exit'. Follow-up screens to both Rebuild and Delete warned that 'ALL DATA WILL BE LOST'. Naturally, I chose 'Exit'.  The next time I tried to boot, the message was 'Failure' instead of Rebuild.

 

Then, the computer rebooted from the boot disk, a Samsung 500 GB SSD containing all operating system and program files. However, the RAID 1 volume no longer appeared in File Explorer. It was my data volume, and consisted of two (2) WD Red 3 TB HDs set up in a RAID 0 mirroring configuration.  It contained over 14 years of data that I presumed to be safe.

Can you, or ANYONE, help me figure out how to get my data back? PLEASE!!!

Did this solve your problem?

Sorry this didn't help.

You should be able to see your disks in Disk Manager and reactivate it there. No data should be lost if you do. Then you should be able to see it in File Explorer again. Get your data backed up pronto, if you have 14 years worth of data but no backup you are seriously asking for it and to be honest I wouldn't feel very sorry for you if anything happened to it. RAIDS are never a backup! RAIDS are meant for uninterruptable data transfer usage only. Only decoupled offgrid redundancy media should be treated as backups.

About the raid issues: It seeems that the only solution is to skip the soft raid you built with Win7 and rebuild it in Windows 10 (after moving your data to other disks ofc). Windows 10 cannot read soft raids created by Windows 7. Its that simple. A very good friend of mine working for Microsoft has admitted they know about this issue but no fix is planned anytime soon, or ever, as they work under the assumption that Windows 7 is phasing out.

Did this solve your problem?

Sorry this didn't help.

@Fuzzietech, etc.,

To be frank, if I lose the data because of my stupidity for not separately backing up my data, I'm mature enough to accept that as I get what I deserve. I actually might be able to recreate much, but not all, of it with some piecemeal backups. That said, I simply did not realize that,

"RAIDS are never a backup! RAIDS are meant for uninterruptable data transfer usage only. Only decoupled offgrid redundancy media should be treated as backups."

I thought that by having RAID 1, I was automatically backing up safely (excluding a fire, etc).  I don't mean to be dense; I'm merely trying to learn. I presume that your third sentence means that I should back up my data and store it either offsite or in the Cloud. But what is meant by your second sentence?

Similarly, I don't mean to be picky, I just want to make sure I am performing the correct specific steps to restore my data. So, by 'Disk Manager', do you mean the 'Disk Management' app available when I right-click on the Windows icon? I forgot that was there. IIRC, it was a Control Panel app in Win7 and Win10 shuffled so much around. Also, by 'reactivate', do you mean 'Initialize Disk'? (A window that pops up for 'Disk 1' , my unknown, unitialized and unallocated  2,794.52 GB (Logical, mirrored?) volume.)

 

 

If so, should I pick the MBR or GPT partition style? I read that GPT is not recognized by previous versions of Windows. I have no current plans to revert to Win7, but I always prefer backward compatibility, unless there is a significant performance benefit to switching to GPT. Also, I plan to only use this volume for data, unless you would recommend that I create a small (~100 GB) bootable partition in case my Boot SSD bites the dust. Or would that destroy access to my data? Hopefully the screen print above is readable and may help.

 

Finally, you say that, "About the raid issues: It seems that the only solution is to skip the soft raid you built with Win7 and rebuild it in Windows 10 (after moving your data to other disks ofc). Windows 10 cannot read soft raids created by Windows 7. Its that simple."

 

Again, please pardon my ignorance, but Are you saying that Volume 1 [Intel RAID 1 Volume (SCSI Int)] on my computer ( a store-assembled -- not personally -- custom build) is a Win7 Software RAID 1 implementation? Device Manager shows the controller as, "Intel(R) Desktop/Workstation/Server Express Chipset SATA RAID Controller" and it implies that it is installed in a PCI socket. 

 

(I admittedly have not yet opened the case because I know myself well enough to realize I'd start yanking things out -- like one physical HDD at a time -- to see if that fixed things. Then, I might become sorry that I did.)

 

Basically, I just want my data back. The easiest way to do that is what I need, perhaps laid out step-by-step for my simple mind. (BTW, I discovered that the Win10 update on 7/22 that I gather caused this problem automatically created a restore point for me. Is all I need to do is restore my system back to that?) After that, I will do EVERYTHING  I need to, starting with two backups, one of which I'll store offsite. Next, if I need to convert to Microsoft's Storage Spaces solution, which doesn't sound perfectly stable itself, I'll do that too.

 

Thank you to both Fuzzitech and Xenorm and any future saviors for your help!

Did this solve your problem?

Sorry this didn't help.

I tried deliberately to push your buttons to just make sure you understand in the future that you should at all not rely on any raid solution as a backup, in the means that your data is safe from destruction/loss. If I came across a bit too harsh, I apologize but I think it is the most effective way to make it stick. ;-)

I've learnt that the hard way myself, so I can speak from experience. I wouldn't want anyone else to suffer the same loss of data if I can avoid it. I work at a large company within IT, and even though we have a proper RAID61 setups even, we still rotate out backups of data into other decoupled entities. A decoupled entity can be any media that is not normally connected to a device, a harddrive or a DVD, or even another server at another site.

I assume you mean this sentence: "RAIDS are meant for uninterruptable data transfer usage only." What I mean with this is that the purpose of raids is foremost to prevent interruption of normal data operations(read/write) in the event that a physical drive fails. A raid gives you the opportunity to switch out a faulty device and rebuild it while still having access to your data with absolutely no downtime.

To answer your questions to retrieve your data:

*) Go to Disk Management (right-click startbutton and there it is).

*) All your drives should appear there, even the ones that are not normally available in File Explorer.

*) Right click your drive that you want to "recover" and choose Reactivate Disk. It might start rebuilding your RAID again automatically there and then, but even if it does you can still work with your data. You might have to assign a letter to it for File Explorer to see it properly.

I would assume it is indeed built using the Windows7 soft raid because it perfectly matches the description of the problems you mention. Unless you have a totally separate RAID software application installed on your computer I will can for sure say that it is using the Win7 Softraid. Normally a true raid controller would be accompanied with its own custom software where you normally build and control your raid setups. There are also the chance that the raid controller is integrated on your motherboard, in which case it should be accessable through the BIOS startuup sequence shortly after POST is completed. However, normal and "first-time" raidbuilding users will never use these tools as they are not as easy in their interfaces to understand. Most users then use what the OS itself brings to the table and thinks it is the same thing. This is not true though, as the post BIOS interface caters to a hardware raid and the OS caters to a software raid.

I hope this makes some sense to you and puts some light on things. :-)

Did this solve your problem?

Sorry this didn't help.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.