My files will not sort alpha-numerically in Windows 10

How do I correct this problem Permanently.  When Microsoft switched to 8.0 or 10 - THEY NEVER ASKED THE USERS WHAT THEY WANTED - WE ARE THE CUSTOMER - GET WITH IT - HOW DO I CORRECT THIS PROBLEM?

 

Question Info


Last updated September 9, 2019 Views 8,650 Applies to:

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The link you provided only covers up to Windows 7.  Does anyone know how to switch from numeric to literal (or alphanumeric) file name sorting in the File Explorer on Windows 10?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Did you try it?  Many registry values remain the same in form & function from one version of Windows to the other.

A quick look with Procmon shows that Explorer still looks for the value.  That's usually a pretty good indication that it will work if you create the value.

This is what I found filtering registry access during Shell startup.

explorer.exe

  RegQueryValue

 HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoStrCmpLogical

 NAME NOT FOUND Length: 144

explorer.exe

  RegQueryValue

  HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoStrCmpLogical

NAME NOT FOUND Length: 144

Keith

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yes if you go to that link you sent, you'll see I figured out a way to accomplish this in Windows 10 Pro.  

1. Run gpedit.msc to open the Local Group Policy Editor

2. Navigate to: Computer Configuration -> Administrative Templates -> Windows Components -> File Explorer (not "Windows Explorer") -> Turn off numerical sorting in File Explorer

3. Select "Enabled" and save

23 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

You hadn't specified a version.  Home users don't have Group Policy Editor, so I assumed you be using the regedit, which has remained the same.

Bottom line, you got it working, right?

Keith

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

You hadn't specified a version either :)

Yes the instructions I provided for Windows 10 Pro worked for me

So you are saying the instructions you linked to for Windows XP, Windows Vista and Window 7 also work for Windows 10 Home?

What about Windows 8 Home and Windows 8 Pro?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yep, works in 10.  Created HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer

NoStrCmpLogical=1   Gives:

NoStrCmpLogical=0

Don't have a Win 8 to test on.

Keith

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Apologies for the confusion.  It was "Method 1" in the link you originally sent that doesn't work in Windows 10 (and probably Windows 8) as written, because "Windows Explorer" has been renamed to "File Explorer"

The "Method 2" you are referencing probably does work regardless of whether it's Windows Pro versus Home.  (I never made it that far because the page said it was instructions for Windows XP, Vista and 7, and never claimed to work in Windows 8 or 10)

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

So many registry keys/values remain the same from one version to the next that I always check to see if they still exist, or even when they don't exist by default, will be recognized when created.

Keith

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.