MTP - File transfers on Win 10 are broken in several ways

When trying to copy a file from MTP drive SD to internal or other way on Win 10, the copy doesn't work. Windows says the device is busy. Works fine on Win7. After this fails, the device is broken, and other actions will also fail in various ways. Reinserting the cable fixes the issue.

Playing a file directly with the new "music" player doesn't work, however Windows Media Player does.

Moving a file from one directory to another on the same storage media doesn't work.

All appear to stop sending IN pids near the start of the transfer.

Something to note: normal file transfers in File Explorer to and from the device still work.

Tested with BlackBerry 10 Passport, Nokia Lumia 1520, Nokia N9, Samsung Galaxy S5.

 

Question Info


Last updated June 30, 2019 Views 7,177 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hello,

Thank you for posting your query in Microsoft Community.

I request you to check the drivers.

Uninstall and Reinstall the USB Drivers.

Step 1: Uninstall the Drivers

a. Press “Windows Logo” + “X” keys on the keyboard.

b. Click on “Device Manager” from that list.

c. Search for the USB from the device list, right click on it and then select “Uninstall”. On the un-installation window, if you have an option: “Delete the driver software for this device” you may select that and then remove the corrupted drivers from the computer.

d. Follow the on-screen instructions to complete it and then restart the computer if prompted.

After the restart, please go ahead with the next steps to install the latest drivers and check if that resolves the issue.

Update Driver Software from the Manufacturer’s website:

Step 2: Go to the Computer's  manufacturer’s website and search for the latest Windows 10 drivers available for the USB and then install it by following the instructions given in the website.

Also, run inbuilt app troubleshooter.

Follow the link below:

  1. Press “Windows” + “X” and select Control Panel.
  2. Select Troubleshooting and select View all on left hand side of the screen.
  3. Select the App and follow the instruction to troubleshoot.

I hope this helps you. If you have any further query in future, feel free to contact us. We will be happy to help you.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Amit,

Thank you for your quick response. I am unable follow your instructions because the drivers that all the devices tested are using come from Windows and are not removable. Here is a screenshot of the drivers being used by all the devices:

There are no MTP drivers for each device outside of windows. The problems appear to be with the windows MTP driver since BlackBerry 10, Windows Phone and Android OS's are all having the same issues.

Please let me know if a fix is being looked at from your side to correct these issues and if this is a know issue on your side.

Thanks,

Andrew

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I still haven't received back a response from Microsoft on this issue. This seems to be very widespread since it affects all devices using MTP. Can Microsoft acknowledge this issue with their driver and let me know if something is being done to fix it?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have the same issue too, with a Fuji S5 Pro DSLR camera. In Windows 7 I could import raw files, but now I only see CF card usage, but 'no files'. I cannot use Windows 10 because of this 'upgrade'...

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

Sorry for the late response. Are you still facing this issue?

Ensure that all Windows pending updates are downloaded and installed, both important and critical.  Reboot PC if necessary.

You may also refer to this article: https://msdn.microsoft.com/en-us/library/windows/desktop/dd562734(v=vs.85).aspx

 while we dig a little deeper into this issue.

 

We appreciate your patience and understanding.  

Thanks & Regards
Joy

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Joy, I am experiencing the same issue OP had. I would like to know if his case was resolved yet, and if so how can I go about resolving this for my Windows 10 installation?

I frequently use my computer to transfer music to my phone via MTP back in Windows 7. Now that I have Windows 10 the device still shows up, however when I look inside the device with Windows Explorer there is nothing inside. It appears to be blank which leads me to believe MTP is broken on the OS.

I've confirmed the issue is not restricted to an individual device. However both of the devices I am trying to transfer files with are both Android devices.

Edit: I just wanted to also add I have tried all recommended steps listed in this thread.

-Uninstall drivers from computer

-Update drivers

-Try different USB ports

-Windows is up to date

-I do have the latest version of Windows Media Player

-And like I said, this is happening on two devices. Both Android.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'm totally bewildered why the MTP file transfer worked on the Tues and didn't work on the Thursday (the next time I plugged in to use)

My husband is MCP qualified he has tried everything he knows from this end..
Windows 10 has really messed up ...
Codes have been missed it only takes one letter(Number) and that's it DEFUNKED

My only hope is that someone with in Microsoft uses a ANDROID/BLACKBERRY/
DEVICE!!  So he/she may just recognise the right spot for the thousands of users out here!!  Until Then I'm afraid ladies and Gents we are doomed.. Cannot use MTP transfer!!

Your own support call desk are being to tell people it is NOT a Microsoft fault!
I am afraid I beg to differ, WORKED SUPERB on WINDOWS 7 for me!!

Microsoft are not taking responsibility for this mess!!!   But it was only when the Win 10 updates and then the fantastic Anniversary package was released, I stupidly thought that this would rectify any drivers etc ... Believe me I have tried everything a MSN engineer can try!! 
Sometimes wish I had stuck with Windows 7!!! SMH!!!

To the Microsoft engineers who actually work at Microsoft, my husband understands the large task you have ahead of yourselves he also understands that the MTP drivers aren't importing you have bigger fish to fry, but please
CAN someone take a look at the codes for MTP via USB!!!

From A Happy (Ex) User

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This problem started with me as well recently, I think just before the aniversary update. My work around is to use PTP in my devices. (Note my Windows 7 computers work ok with MTP, just the Windows 10 computers). PTP only allows access to the pictures folder on my devices but I can copy my music, etc there and then on the device copy again to the right directories. This is a Win10 issue and Microsoft needs to fix it.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

the only options are 1) copy the files to the installed HDD, then to the folder in the device desired; or two, use a Linux LiveCD and use that OS running from the disc to do the job.

<Edited due to COC violation>

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This problem just started for me after KB4013429 installed.

I found another article, on this site, regarding updating the device driver by pointing to the C:\Windows\Inf folder and using "wpdmtp.inf" as the source.

It appears to have worked for me=)


I wish the same luck to the rest of you!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.