Long file paths crash File Explorer when accessing files on network attached storage device after Windows 10 Anniversary Update

When I upgraded to Windows 10, File Explorer worked fine when I was accessing files on my network attached storage device (Western Digital MyCloudEX2Ultra).  After updating to Windows 10 Anniversary, when working with subdirectories on the NAS that contained files with long file paths, attempting to sort by "Date Modified" crashed File Explorer.  I soon learned that other File Explorer functions also crashed when working with such files in those subdirectories.

After reading comments on this forum and other places, I attempted to enable long file capability in the registry but the entry was no longer present.

I have resorted to reducing the length of my directory titles to attempt to bring the files within the limitations of Windows 10AU, but there are far too many files affected for this to be a permanent solution.

Microsoft needs to fix this issue as soon as possible.

 

Question Info


Last updated May 12, 2019 Views 9,421 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Is this somewhat related?

http://answers.microsoft.com/en-us/windows/forum/windows_10-files/source-path-too-long-bug-in-windows-10/b0cb82b0-85c1-4fcf-81cd-041b2175563e

Sincerely,

Jaqui

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Not really.  The problem in the thread that you are referring to is a an error message displaying that the path is too long.  The issue here is that File explorer crashes and restarts whenever browsing to a long path with a file that has a long name.  The faulting module in the logs is ntdll.dll.  Sometimes it doesn't crash immediately when browsing to the folder but trying to open, rename, move, delete the file will cause it to crash.  Enabling preview pane or changing the file view will cause it to crash as well. 

This is happening in an environment with Windows 10 1607 computers accessing a Windows Server 2012 R2 file server in my case. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I found a TEMPORARY solution at the end of another link regarding this problem:
https://answers.microsoft.com/en-us/windows/forum/windows_10-files/file-explorer-crashes-after-windows-10-anniversary/d2a5e4bc-e5f7-4790-bf8a-bd4b1b6cc1ec

It refers to the answer here:
http://www.windows10forums.com/threads/network-folder-access-issue-explorer-crash.7949/

Basically, you use folder options on the computer that you use to access the external drive, and you check the box "Always show icons, never thumbnails" 

This is obviously a temporary fix because not being able to see thumbnails is a very significant limitation to the use of Windows 10AU, especially if you want to browse photos.

Microsoft, we need a permanent fix to this problem!

36 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

That actually helps.  Can navigate to the folder without crashing and even use the preview pane to preview PDFs and Excel documents without crashing.  So that's a plus.  Still crashes when trying to delete files with long names in long paths though.  One way around this is to rename the file to a shorter filename if it doesn't crash and then delete.

Thanks.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Also, forgot to mention that it also fixes Quick Access from crashing.  I had actually disabled folder and file history but now can enable them again.  Do not even need to clear the history first if Quick Access is crashing.  Just disable the thumbnails and Quick Access stops crashing immediately.  Only deleting causes a crash now but that is minor with the workaround.

Thanks AlF_HB!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

it works if you unchick the privacy in folder options > General tab.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This helped me out a lot, thank you!  I've noticed this bug but haven't had a chance to track it or watch any threads but it's definitely a crappy bug!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Is there any progress on a proper fix for this?

It's got to the point where users are so frustrated with it they've asked me to roll them back to the previous Win10 build. 

Unfortunately, Microsoft delete rollback data after 10 days now, so it looks like it's going to be a shed load of reinstalls.

Microsoft, this problem needs urgent attention! As does the decision to delete rollback data of a major, buggy update after 10 days!

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Here is the GPO setting if you wish to deploy the workaround as a policy to all your Win10 machines

User Configuration | Administrative Templates | Windows Components | File Explorer

Enable "Turn off the display of thumbnails and only display icons"

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

It's frustrating to have to continually reset the quick access toolbar so that this problem doesn't happen.  I'm afraid this isn't happening to enough people so it's a fringe problem.  It's definitely a bug introduced since they've increased the maxpath in Windows 10.  But regardless of if the option is on or off it still happens.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.