iPersist 0x80070002 Error

When I install programs I get this:

IPersistfile::save failed; code 0x80070002.  The system cannot find the file specified.

I'm using Windows 10 Pro ver 1709.  I can find info on how to fix it for Windows 7 or what to do when trying to do a Windows backup but nothing about getting it every time I install a program.  I can click OK and it goes away and the programs seem to work ok, but are they really working completely?

 

Question Info


Last updated September 16, 2019 Views 36,676 Applies to:
File History, System Image, Backup and Restore in Windows 10 are partially broken and they are not being actively maintained or developed. Microsoft is planning to remove them in a future release. You are seeing the effects of this. You should switch to a third party solution such as Macrium Reflect (Free).

Learn more: https://www.groovypost.com/howto/create-windows...
Best,
Andre
Windows Insider MVP
MVP-Windows and Devices for IT
twitter/adacosta
groovypost.com

10 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'm confused.  I'm not trying to do any sort of backup.  I'm installing programs.

22 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This maybe an issue with a system file being corrupt.
You can try a couple things.

Right click your start button and select Command prompt (Admin) to bring up elevated Command prompt.
In Command prompt type sfc /scannow and press enter.
Restart the computer.

If that doesn't work then try this,

Right click your start button and select Command prompt (Admin) to bring up elevated Command prompt.

In the Administrator: Command Prompt window, type the following commands.
Press Enter key after each command:

DISM.exe /Online /Cleanup-image /Scanhealth

DISM.exe /Online /Cleanup-image /Restorehealth

Important: When you run this command, DISM uses Windows Update to provide the files that are required to fix corruptions.
To close the Administrator: Command prompt window, type Exit, and then press Enter.
Restart your computer.

21 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

You could try the Windows Update troubleshooter that is downloaded from this page:
https://support.microsoft.com/en-us/help/271443...

It should work with Win10 even though it is not explicitly identified.

That web page identifies that error code as a Windows Update Database error.

Go to this page
HTTPS://ANSWERS.MICROSOFT.COM/EN-US/WINDOWS/FORUM/WINDOWS_OTHER-UPDATE/WINDOWS-UPDATE-ERROR-CODES-8007-PART-5/54E58CCD-6467-4FF2-BC9B-41C416879029?TM=1518541821079
.
and follow the process defined in "Manually Reset Windows Update System"

.
There are 10 kinds of people:
Those who understand binary and
those who don’t.
(hint: geek joke about binary numbers)
.
¯\_(ツ)_/¯
.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Try disabling your Antivirus utility and any other installed security utility then attempt the install again.

If you have any open programs, close them.

Open Windows Defender Security Center
Click Virus & threat protection
Click Virus & threat protection settings

Scroll down to Controlled folder access
Toggle it off

Also in Windows Defender Security Center

Open App & browser control
Set 'Check apps & files' to off

Still not working?

Open Start
Type: cmd
Right click CMD
Click Run as administrator

At the command prompt, type:
net user administrator/active:yes

Hit Enter

Close command prompt, restart, then try signing into the Administrator account.

Try running the file again.
Best,
Andre
Windows Insider MVP
MVP-Windows and Devices for IT
twitter/adacosta
groovypost.com

106 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Try disabling your Antivirus utility and any other installed security utility then attempt the install again.

If you have any open programs, close them.

Open Windows Defender Security Center
Click Virus & threat protection
Click Virus & threat protection settings

Scroll down to Controlled folder access
Toggle it off

Also in Windows Defender Security Center

Open App & browser control
Set 'Check apps & files' to off

====================================

I've done everything in previous messages and found no problems.  Then I did the above from your message.  When I rebooted it gave me a message and said it didn't like the fact that apps and files was turned off so I turned it back on.  I then installed the most recent program that had been giving me a problem and it worked just fine.

 

Now my question is:  What are the cons of toggling Controlled folder access off?  



44 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.