You do not have permission... Windows 10 Mapped Network Drive

I've been having permissions issues with a mapped network drive. I have an external hard drive attached to a PC via USB connection. It has permissions set to Everyone-Full Control. From the PC it's attached there is no problem accessing the drive and viewing the contents. When I map the drive from another PC, using the credentials of the other PC, I get "You do not have permission... contact system administrator" I have reset (icacls * /reset /t) the drive, tried changing owner to System, Everyone and even the user. I set permissions to Everyone Full Control. I mapped the drive using the login id of the remote PC, which is in the administrators group and also has full control of the drive. The drive seems to map, but when I try to open it I get the message above.  I have other drives attached to the remote PC which I can map to and access just fine. How do I reset/clear/change the permissions on this drive to allow it to be mapped and accessed? I'm getting pretty frustrated!

Both PCs are running Windows 10 Pro, obviously on the same network since I can map other drives connected to that PC. 

 

Question Info


Last updated March 24, 2020 Views 15,442 Applies to:

Hi Bruce,

We'd like to clarify of the steps you've done in creating the network connections. Please follow these steps to create a shared drive on the PC that the external drive is found for verification:

  1. Press Windows key + E on your keyboard to open File Explorer, then click This PC on the left hand panel.
  2. Right-click the drive you want to share, click Share with, then click Advanced sharing.
  3. Click the Sharing tab, and then click Advanced Sharing.
  4. Fill in Share name with the desired name of the drive, then click Permissions button.
  5. Click Add, then click Advanced on the next window and then click Find Now.
  6. A panel will appear that will show all of the user accounts and groups found on your network. Click the User account you want the drive to be shared with and then click OK.
  7. On the Permissions window, please check the Allow checkbox under Full control and then click OK.
  8. Check if the icon of the shared external drive was updated with an icon showing it is shared.
  9. Verify if the issue is now resolved.

We understand if it feels like this was already done on your end but following these steps will allow us to verify if you've done the right steps. May we also know if both of the PC are on the same OS build version? To check this information, press Windows key + R on your keyboard, type winver on the window that would show and press Enter key on your keyboard.

Update us if there are improvements.

8 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Although my frustration got the better of me and I reformatted the drive, the steps you outlined would have likely solved the problem. I did not go the extra step of adding the group to the share, only the individual user profile. That step makes sense to me now, in the future when I run into this problem I'll consult this reply!

Thanks

Bruce

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thank you for the updates, Bruce. Please do let us know if you encounter any issues in future and we'll be glad to assist.

All the best.

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.