Windows 10 File Explorer is extremely slow


This green loading bar takes 40-50 seconds to load, sometimes even more.

I've never experienced this before.

I've upgraded my system from Windows 8.1 pro to windows 10 pro. My system is updated. Virus Scanned. I am running windows on AMD A8 APU with 8GB RAM.

Anyone else also experiencing this problem? Any solutions?

Was this discussion helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this discussion?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this discussion?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.


This green loading bar takes 40-50 seconds to load, sometimes even more.

I've never experienced this before.

I've upgraded my system from Windows 8.1 pro to windows 10 pro. My system is updated. Virus Scanned. I am running windows on AMD A8 APU with 8GB RAM.

Anyone else also experiencing this problem? Any solutions?

Hope Microsoft will release an update to address this. I am also experiencing the same in my pc. Now I am thinking of going back to Windows 8.1.

Any workarounds available please...

96 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I am having the same issue with my Windows 10 File Explorer, but my load time is 1 to 5 minutes. Thanks, Randy

74 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I had the same problem...

The green loading bar seems to take forever to populate my files if I tried to sort by name, size, type, date etc...

The following fixed it for me:

  1. In Windows Explorer, right click the Downloads folder (or any folder you are having issues with), then select Properties.
  2. Select the Customize tab
  3. From the drop-down menu, Optimize this folder for: "General Items"

It instantly solved the problem for me.

Hopefully these steps help others who are having this issue.

Good luck!

184 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Mine takes 3-7 minutes to load. Worked fine up to a few days ago.

82 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Try my method out and see if it works for you...

I'd like to add that it might also depend on the "columns" you have selected in file explorer as well.

Example: Name, Size, Type, Date

If you have a certain variation, for example, Length added as another column.

It might still take time to load in order to generate the length for all your files in a certain folder.

If you choose the default Columns (Name, Size, Type, Date) it should work fine.

At least it did for me, following the steps I provided above.

45 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I've had this problem for a while. It seems to take place when I'm doing multiple things such as transferring files, copying big files etc. simultaneously.

Still searching for an answer but I suspect it's because the CPU is too busy.

If you get really fed up with it try:

CTRL+alt+del

Task manager

scroll down to the yellow icon of windows explorer and click re-start.

There is then a pause and wondows file explorer comes back and works normally - for a while at least.

Not sure why this happens.

If for example I'm moving 30Gb of pictures to my back-up hard drive, it tends to happen.

Maybe I'm just expecting too much from my pc.

The human brain is after all so much more complex than AI and we can cope with massive multi-tasking but maybe the trouble is that AI has a finite limit - unless you place unlimited resources in your machine.

41 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I had this same issue. What worked for me was running the Troubleshooter. Select Search and Indexing. This found the issue which involved incorrect directories which was making windows search for the files every time I tried accessing the file explorer. After doing that the issue was resolved for me.

131 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I had to do several things to fix mine.

sfc /scannow showed the license file corrupt.

to fix that I had to run dism. dism however, couldn't find the source files. The license corrupt file is an indicator that the Windows update utility is corrupt. In my case I used another machine to find the files so I wouldn't have to apply all the updates again. 

 Once dism ran I could then run sfc /acannow to fix the license issue.

Then I had to disable everything that I felt wasn't necessary from startup (task manager startup tab).

Once I did that file explorer has been working flawlessly.

19 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Thanks ... solve my problem :)

35 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Stopped working a week later!! 

Buggy Buggy operating system!!!

67 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Discussion Info


Last updated March 8, 2021 Views 71,757 Applies to: